LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-08-2015, 10:06 AM   #16
sudowtf
Member
 
Registered: Nov 2013
Posts: 187

Rep: Reputation: 45

/etc/resolve.conf MUST have the nameservers listed. Maybe eth0 is not configured for DHCP.

Try this (the DHCP part): http://blog.roozbehk.com/post/352773...tup-networking

Should work in centos7 also. note: There are multiple ways of configuring eth0 for dhcp, the one proposed is just one.
 
1 members found this post helpful.
Old 01-08-2015, 11:58 AM   #17
gtaylor828
LQ Newbie
 
Registered: Jan 2015
Posts: 23

Original Poster
Rep: Reputation: Disabled
That worked! Thanks
As suggested in the link you provided, I added a couple lines to resolv.conf and changed a couple settings in /etc/sysconfig/network-scripts/ifcfg-eth0. Then yum install gnome-desktop seemed to execute without issue.

But it still doesn't find startx. I'm searching for an answer
 
Old 01-08-2015, 12:16 PM   #18
sudowtf
Member
 
Registered: Nov 2013
Posts: 187

Rep: Reputation: 45
i just learned something myself:
Code:
sudo yum install yum-utils
sudo yum grouplist
...so probably...
Code:
sudo yum groupinstall "X Window System"
sudo yum groupinstall "GNOME Desktop Environment"

Last edited by sudowtf; 01-08-2015 at 12:17 PM.
 
Old 01-08-2015, 12:30 PM   #19
gtaylor828
LQ Newbie
 
Registered: Jan 2015
Posts: 23

Original Poster
Rep: Reputation: Disabled
Stumbling right along now ... ;-)
The yum groupinstall "X Window System" helped; it finds startx now.
But the process doesn't find gnome-session listed in .xinitrc.
 
Old 01-08-2015, 12:33 PM   #20
sudowtf
Member
 
Registered: Nov 2013
Posts: 187

Rep: Reputation: 45
lmao, at least you're learning.
create a second VM using a full sized ISO and make sure to checkmark "on" the desktop environment.

p.s. it's good that you're leaning this command-line stuff though; servers usually DO NOT install a desktop-envirnment and will be command-line only.
 
1 members found this post helpful.
Old 01-08-2015, 12:49 PM   #21
gtaylor828
LQ Newbie
 
Registered: Jan 2015
Posts: 23

Original Poster
Rep: Reputation: Disabled
I did the full install; it's what I've been trying to fix.
There was no opportunity to select/check a desktop environment during the installation.
(I ran through the first part of the process again just to be sure.)
During the process I saw a brief note that there wasn't enough memory for a graphical installer.

I found the answer on http://www.sysads.co.uk/2014/01/inst...ui-centos-6-5/
Edit /etc/inittab and change id:3:initdefault to id:5:initdefault (3 to 5)

Last edited by gtaylor828; 01-08-2015 at 01:03 PM.
 
Old 01-08-2015, 01:02 PM   #22
sudowtf
Member
 
Registered: Nov 2013
Posts: 187

Rep: Reputation: 45
gotcha. add more than 512MB (try 768 or 1024) to the VM and try again.
 
Old 01-08-2015, 01:07 PM   #23
gtaylor828
LQ Newbie
 
Registered: Jan 2015
Posts: 23

Original Poster
Rep: Reputation: Disabled
I found how to get the existing installation to work on http://www.sysads.co.uk/2014/01/inst...ui-centos-6-5/
Edit /etc/inittab and change id:3:initdefault to id:5:initdefault (3 to 5)
Then restart with init 6
 
Old 01-08-2015, 01:19 PM   #24
gtaylor828
LQ Newbie
 
Registered: Jan 2015
Posts: 23

Original Poster
Rep: Reputation: Disabled
Still have some problems getting this to work but the issue has evolved from the original request.
So I'm going to mark the topic SOLVED and start another.

Thank you, sudowtf, for all your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to archive torrent file + the iso files , like the ova archive of virtual box jheengut Linux - Software 2 12-22-2013 06:04 PM
Install Centos issue: in httpd and ftpd can't find install.img manuce Linux - Newbie 5 05-25-2013 07:34 PM
How to install Fedora Core 6 Zod torrent file Peter_APIIT Linux - Software 3 02-03-2007 09:37 PM
cannot find dependent files for Mplayer for CentOS-3(redhat el-3?) rolandkirk55 Linux - Software 1 08-15-2004 09:41 AM


All times are GMT -5. The time now is 01:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration