LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2014, 05:58 AM   #1
vineetcornelius
LQ Newbie
 
Registered: May 2012
Posts: 24

Rep: Reputation: Disabled
Post Centos M/c Stops Pinging giving error ip_conntrack


Sir,

I have a CENTOS 5 machine on which I am running squid proxy. The squid runs fine but once in 24 hours it starts giving RTU and does not ping continuously.
On checking the log file it gives the following message " kernel: ip_conntrack: table full, dropping packet".
On restarting the machine everything is restored back to normal but after 24 hours the same message starts appearing and restart is done.

On finding for a solution on the net the reason pointed out was too many sessions are opened I increased the limit by typing the command : sysctl -w net.ipv4.netfilter.ip_conntrack_max=120536 still the problem remains as it is.

Help is required as to why this is happening and how it can be resolved.
 
Old 04-02-2014, 06:40 AM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 2,972

Rep: Reputation: 508Reputation: 508Reputation: 508Reputation: 508Reputation: 508Reputation: 508
Try this:

http://www.maninmanoj.com/2013/02/ip...ng-packet.html
 
Old 04-02-2014, 11:26 PM   #3
vineetcornelius
LQ Newbie
 
Registered: May 2012
Posts: 24

Original Poster
Rep: Reputation: Disabled
Sir,

I have already tried doubling the ip_conntrack_max default value. But after 24 hrs the problem comes again.

Moreover I am not able to understand why the server experiences RTU when we continuously ping it.
 
Old 04-03-2014, 02:35 AM   #4
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 2,972

Rep: Reputation: 508Reputation: 508Reputation: 508Reputation: 508Reputation: 508Reputation: 508
OK, you have to read that whole page I gave you. If you don't read the entire page you won't know what to do. Your use of the term "RTU" may be incorrect. The RTU pings the server to make sure the server is up. The server does not experience "RTU." The server probably reboots each day, and then the /proc filesystem is reset, so your custom setting for ip_conntrack is reset to the default value.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
telnet ubuntu from centos giving error yaqootbilal Linux - Networking 3 07-01-2013 10:36 AM
[SOLVED] Giving cylinders in kickstart file - CentOS 6.2 vikas027 Linux - Server 4 06-13-2012 10:40 AM
[SOLVED] samba share with 2 folder giving problem centos 5.7 64bit khak.pa Linux - Newbie 11 01-14-2012 08:25 AM
some strange error while pinging Pinchiukas Linux - Networking 3 12-04-2004 09:23 AM
Pinging Error?? Ikik Linux - General 2 10-01-2003 04:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration