LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-24-2012, 04:35 AM   #1
vinod.chougule
LQ Newbie
 
Registered: Sep 2012
Posts: 2

Rep: Reputation: Disabled
CentOS 5.5 server Squid service stops automatically.


I am having CentOS5.5 server with third party firewall installed on it with 50 users.Initially the speed was good but after a year now the browsing speed is extremely slow.Also the squid service is getting stopped with error "squid dead but pid file exists" every 1/2 hour.I hv to manually start the squid service.After starting the squid service PID number also changes everytime with the error - squid: ERROR: Could not send signal 0 to process 4576: (3) No such process.I tried with removing log files & squid -z. but no any effect with speed.Please help me how to clear/purge the access.log, & other squid related log files.& how can i increase browsing speed?
 
Old 09-24-2012, 04:38 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Log files will have zero impact on the service. These should already be being managed by logrotate anyway.

Clearly squid is crashing for some reason. Why bother asking about the speed if it's already crashing? check the squid.out log for actual reasons why it's crashing. Potentially run it outside of the service script in the foreground with some debugging enabled and watch it for crashes.
 
Old 09-24-2012, 06:57 AM   #3
vinod.chougule
LQ Newbie
 
Registered: Sep 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
thnks a lot for the quick reply. but my purpose is not solved any. anyway thnks.
 
Old 09-24-2012, 07:03 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
your purpose is not solved? What does that mean??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i installed centos server successfuly. now how to do it a hosting service? celal Linux - Newbie 6 05-01-2012 02:14 PM
[SOLVED] Squid proxy server on centos 5.4 sandeep77897 Linux - Server 3 01-04-2012 06:16 AM
[SOLVED] How to start squid service automatically ? gardenair Linux - Server 7 03-14-2011 11:46 AM
[CentOS] Squid, iptables, dhcp server ? prixone Linux - Newbie 0 01-18-2008 01:37 AM
My CentOS installation stops booting at udev service arijit_2404 Linux - Desktop 3 11-11-2007 11:09 AM


All times are GMT -5. The time now is 08:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration