LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-28-2004, 07:50 PM   #1
xxsolusxx
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
CdRom will not work


I am a total linux newbie!!!
Just installed the college distro to check out linux and am thoroughly impressed. only prob lem is I cant seem to get my cd rom or floppy to work.
my etc/fstab is
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
none /dev/pts devpts defaults 0 0
/dev/hda3 / ext3 defaults 1 1
/dev/hda4 swap swap defaults 0 0
/dev/hdd
/mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0

/dev/hda1 /mnt/hda1 auto defaults 0 0

/dev/hda3 /mnt/hda3 auto defaults 0 0

/dev/hda5 /mnt/hda5 auto defaults 0 0
none /proc/bus/usb usbdevfs defaults 0 0

/dev/hda5 /mnt/hda5 auto defaults 0 0

/dev/hdc /mnt/dvdr0 iso9660 defaults 0 0

/dev/hda5 /mnt/hda5 auto defaults 0 0

/dev/hda5 /mnt/hda5 auto defaults 0 0
if i goto devices on KDE desktop I see an unmounted icon for cd rom but get this error
mount: can't find /iso9660 in /etc/fstab or /etc/mtab

Please HELP
 
Old 04-28-2004, 07:54 PM   #2
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
You need to make sure that /dev/hdd abd /mnt/cdrom are on the same line, like the /dev/fd0 is with the floppy on the line below.
 
Old 04-28-2004, 09:26 PM   #3
xxsolusxx
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
well that did'nt help.. any more ideas?
 
Old 04-28-2004, 09:29 PM   #4
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Rep: Reputation: 30
Drop to a promt and type.....

mount /dev/hdd /mnt/cdrom

and also....

mount /dev/fd0 /mnt/floppy

Let us know the output of both.

>Craig
 
Old 04-28-2004, 09:33 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,256

Rep: Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624Reputation: 1624
It looks like the icons are not configured to the correct device. Right click on the CDROM icon and select properities, it should indicate /mnt/cdrom

You should be able to mount the CD using a console window i.e.
mount /mnt/cdrom
 
Old 10-24-2004, 02:14 PM   #6
zinggniz
LQ Newbie
 
Registered: Oct 2004
Location: Alabama
Posts: 16

Rep: Reputation: 0
Unhappy

I am currently experiencing the same problem, but somehow I got my floopy drive to work by puting in a Windows 98 boot floopy disk, loading the dos prompt (This is without windows 98 installed, so the dos prompt is completly loading from the floopy drive), and then restarting my PC. I have absolutly no idea why this worked.
 
Old 10-24-2004, 04:03 PM   #7
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
I would fix up my fstab to look something like this;
/dev/hda1 /boot ext2 noauto,noatime 1 2
/dev/hda2 none swap sw 0 0
/dev/hda3 / ext3 noatime 0 1

none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0

/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get PCMIA CDROm to work Gripper Linux - Hardware 0 06-04-2005 08:42 PM
cdrom won't work anymore Smokey Slackware 7 01-29-2005 09:21 PM
cdrom dont work Spyiish Slackware 5 09-18-2004 07:17 PM
My cdrom doesn't work... AlfaGTV Slackware 2 05-06-2003 02:32 PM
CDROM(s) don't work Redhat2LFS Linux - Hardware 9 03-31-2003 07:47 PM


All times are GMT -5. The time now is 07:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration