LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-29-2003, 02:10 AM   #1
fbarre
LQ Newbie
 
Registered: Aug 2003
Location: California
Distribution: RedHat
Posts: 28

Rep: Reputation: 15
Unhappy CDROM in /etc/fstab not working


I have the following line in /etc/fstab defined:

/dev/hdb /mnt/cdrom iso9660 noauto,owner,ro 0 0

But it's not mounting after reboot and have to do it manually
every time which works i.e. with

mount -t iso9660 /dev/hdb /mnt/cdrom

Yes, /dev/hdb is the correct one
Yes, I tried with "auto" and still not working.


Can somebody give me a hand please

Thx
 
Old 08-29-2003, 02:23 AM   #2
tuxfood
Member
 
Registered: Aug 2003
Location: kerala , India
Distribution: RH9 , FC1 ,
Posts: 141

Rep: Reputation: 15
maybe you should change the /dev/hdb to /dev/cdrom.
try it not so sure.
(post result pls)

bye,
tuxfood
 
Old 08-29-2003, 02:44 AM   #3
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
change it to:
Code:
/dev/hdb /mnt/cdrom iso9660 auto,user,ro 0 0
Addendum:

You do not actually want to have auto-mounting cdrom drives. Because it will then refuse to eject. Some things in Linux just doesn't work like they do in Windows, the cdrom drive is one of them.

If you insert a CD into the drive and mount it, you will able to access the data, but you can't eject the CD until you unmount the drive first.


Last edited by Azmeen; 08-29-2003 at 02:50 AM.
 
Old 08-29-2003, 02:45 AM   #4
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
are you trying to mount data cd's or audio? you can't mount audio cd's, just play them in kscd or whatever program you like. if you're just doing data, then auto should make that change...if it doesn't then i don't know, try other options like users instead of owner ::shrug::

post any results please
 
Old 08-29-2003, 01:10 PM   #5
fbarre
LQ Newbie
 
Registered: Aug 2003
Location: California
Distribution: RedHat
Posts: 28

Original Poster
Rep: Reputation: 15
Thanks for your replyies guys.. you must be on different time zone... I'd have replied sooner but I was sleeping

No, I'm mounting data CD.. I'm aware of that issue with music CDs.

I've tried "auto" before but didn't work. I'll give it a try again with "user" option and let you know.


thx

Last edited by fbarre; 08-29-2003 at 02:05 PM.
 
Old 08-29-2003, 02:10 PM   #6
fbarre
LQ Newbie
 
Registered: Aug 2003
Location: California
Distribution: RedHat
Posts: 28

Original Poster
Rep: Reputation: 15
Ok, tried all combinations

/dev/hdb /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/hdb /mnt/cdrom iso9660 auto,owner,ro 0 0
/dev/hdb /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/hdb /mnt/cdrom iso9660 auto,owner,ro 0 0

and still doesn't work!

Time to give up.. I'll continue mounting it manually... I'm sure someday lights will turn on.

Thx for your help guys/gals!
 
Old 08-29-2003, 02:16 PM   #7
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
What did you mean by "not mounting"? After you made your edits, how did you try to look at your cd?
 
Old 08-29-2003, 02:20 PM   #8
fbarre
LQ Newbie
 
Registered: Aug 2003
Location: California
Distribution: RedHat
Posts: 28

Original Poster
Rep: Reputation: 15
I just did "ls /mnt/cdrom" and nothing appears!

but when I mount it manually with
mount -t iso9660 /dev/hdb /mnt/cdrom
then "ls /mnt/cdrom".. I see all files.

thx
 
Old 08-29-2003, 02:34 PM   #9
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
I am a noob also, but I thought /dev/hdb means your second harddrive. /dev/hda means you first?

this is the line in my /etc/fstab

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

Last edited by shanenin; 08-29-2003 at 02:36 PM.
 
Old 08-29-2003, 02:50 PM   #10
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You have to mount manually anyways, or use certain software.
Now that you have a correct line in your fstab, all you have to type is "mount /dev/hdb" to mount. The auto option mounts the cd (if there is one) automatically on startup. It's meant for hard drives, and is specified automatically for them when you put "defaults" as one of the options for one. In KDE or GNOME, you can create special links to the mount point (/mnt/cdrom) that automatically mount the cd when you click on them. I think there's software that will mount the cd as soon as you put it in.

Last edited by aaa; 08-29-2003 at 02:55 PM.
 
Old 08-29-2003, 02:54 PM   #11
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
shanenin,
/dev/cdrom is a link to /dev/hda, /dev/hdb, /dev/hdc, or /dev/hdd (and so on, if you have more than two ide controllers).
/dev/hda is the Primary Master IDE Device. (Doesn't have to be a harddrive)
/dev/hdb is the Primary Slave IDE Device.
/dev/hdc is the Secondary Master IDE Device.
/dev/hdc is the Secondary Slave IDE Device.
 
Old 08-29-2003, 02:58 PM   #12
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
shanenin,
Also, change the "owner" option in your cdrom line to "user" so regular users will be allowed to mount.
 
Old 08-29-2003, 02:58 PM   #13
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
thanks, I learned something new
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/etc/fstab - /mnt/cdrom d1l2w3 Linux - Hardware 10 01-08-2005 09:33 PM
mounting cdrom and fstab mikz Slackware - Installation 7 09-05-2004 01:07 PM
fstab cdrom help eo697 Slackware 24 07-26-2004 10:14 AM
cdrom not in fstab GlobShim Linux - General 8 04-02-2004 10:41 PM
fstab and cdrom links - hdc or cdrom? tunedLow Linux - Newbie 5 12-21-2001 01:57 PM


All times are GMT -5. The time now is 01:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration