LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2005, 01:46 PM   #1
noid
LQ Newbie
 
Registered: Apr 2005
Posts: 7

Rep: Reputation: 0
CD sound silent, cannot unmute


Just installed Suse 9.3. It looks really cool. It's on a completely new pc I bought yesterday. I have a combo cd dvd read recorder, which works, since I used cd's & dvd's to install Suse. The sound card plays mp3's. But I cannot get KsCD to play music cd's.

Let me be more specific. The cd's play. I can see the track titles as they play. But no sound. Nothing is muted or very low on Kmix, or on KsCD.

Anyone got any ideas?
 
Old 07-02-2005, 03:06 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Two options:

1: Attach the audio cable from the back of the CDROM drive to your sound card.
2: Use Xine to play audio CDs (Xine does digital extraction).

Dave
 
Old 07-02-2005, 03:09 PM   #3
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Most likely you're going to have to connect a cable from the cdrom to the sound card, as for one reason or another, since about kernel 2.6.7, you can't use the digital sound with cd playing (the analogue cable has much less CPU use as a side efect, though). That may be your problem. It was for me (haven't removed the cable since...)
 
Old 07-02-2005, 03:19 PM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Quote:
Originally posted by vectordrake
Most likely you're going to have to connect a cable from the cdrom to the sound card, as for one reason or another, since about kernel 2.6.7, you can't use the digital sound with cd playing (the analogue cable has much less CPU use as a side efect, though). That may be your problem. It was for me (haven't removed the cable since...)
Umm, nope. I've used every 2.6 series kernel, and I've never had any problems using CDDA.

Dave
 
Old 07-03-2005, 10:40 AM   #5
noid
LQ Newbie
 
Registered: Apr 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for the advice.
I am not sure how to do the actual connecting stuff, so I'll try the xine method first.
I notice that my sound card shipped with a cable that wasn't necessary, but I didn't click that this might be a cause of any problems. They don't call us newbies for nothing.

Thanks again,

noid
 
Old 07-03-2005, 11:48 AM   #6
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi again.

Yeah, that wee (usually gray) lead with 3 or 4 wires in it is what connects the CDROM to the sound card. The quality of the audio you get out the back of CDROM drives is generally pretty bad anyway, so the Xine method's preferable.

Dave
 
Old 07-03-2005, 03:07 PM   #7
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by ilikejam
Hi again.

Yeah, that wee (usually gray) lead with 3 or 4 wires in it is what connects the CDROM to the sound card. The quality of the audio you get out the back of CDROM drives is generally pretty bad anyway, so the Xine method's preferable.

Dave
I've got to agree. Thanks for the tip on Xine. I didn't realise it was a app problem. I just assumed that it was cause elsewhere. Now to find an Xine plugin for xmms...
 
Old 07-03-2005, 05:50 PM   #8
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
If you go into XMMS's menu, and go into:
Options -> Preferences -> Audio I/O Plugins tab
you should see a CD Audio Player plugin. Click on that and hit 'Configure'. Choose 'Digital Audio Extraction.
I can't remember exactly how you get XMMS to play CDs, but I'm sure a quick google should clear that up.

Dave
 
Old 07-24-2005, 06:57 AM   #9
noid
LQ Newbie
 
Registered: Apr 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Hey, the advice worked. Everything is cool now. Thanks everybody.

noid
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound,a silent world Swift&Smart Slackware 11 05-21-2005 08:02 AM
Sound Problems (suspect I must unmute some channels) Mr.Ampersand() Linux - Software 0 02-14-2005 07:27 PM
Silent Night.....my sound don't work draggin Linux - Hardware 6 12-24-2004 11:40 PM
How to Unmute sound using OSS?? shazam75 Mandriva 3 10-15-2004 04:59 AM
CD Player. Sound only works with Kaffeine, XMMS is "silent" :( m15a4 Linux - General 1 07-10-2004 02:32 PM


All times are GMT -5. The time now is 06:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration