LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-10-2002, 11:11 AM   #1
freeindy
Member
 
Registered: Nov 2002
Posts: 196

Rep: Reputation: 30
CD-RW setup made Debian crash...


HI ye all!

I have a debian woody installed on my PC. I wanted to burn on my CD-RW so I installed 'cdrecord'. But it didn't work and reading through a lot of forums I found out that I had to "do" CD-RW HOWTO process. So I did. When rebooting, it doesn't bootmy linux anymore This is what is popped out:
-----------------------------------------------
hdb: driver not present
VFS: Cannot open root device 3:42
kernel-panic: VFS : Unable to mount root fs on 3:42
-----------------------------------------------

Now I'm guessing that it has something to do with "append="hdb=scsi" but I can't figure out what to do.

And one more thing. Can I get "into" linux by typing something during startup at lilo???

Cheers a million.

Indy
 
Old 12-10-2002, 11:15 AM   #2
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
The line should properly be append=hdb=ide-scsi. If you can, boot from a rescue medium (floppy/CD) and edit your lilo/grub.conf file appropriately, and reboot. If it works and you can boot OK, then run cdrecord -scanbus to find out your scsi disk number.
 
Old 12-10-2002, 03:19 PM   #3
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
Are you sure the writer is on hdb?I think I screwed up about anything possible when I got mine - including lilo lines that didn't work and kernel configurations but that didn't affect the booting process.
 
Old 12-11-2002, 04:17 AM   #4
freeindy
Member
 
Registered: Nov 2002
Posts: 196

Original Poster
Rep: Reputation: 30
First of all, Thanks Thymox & CrashMeister for replying.

Thymox: It was appended as : append="hdb=ide-scsi". Sorry for that but I didn't know how to get to lilo.conf file before I realized (from you) that I could reboot with my floppy...
Anyway, this is how it is written in lilo.conf:
------------------------------------
default=Debian

image=/vmlinuz
label=Debian
read-only
append="hdb=ide-scsi"
------------------------------------

CarshMeister: I'm not sure at all. In fact, I haven't a clue. My writer was linked to hdc (cdrom->hdc) but the CD-RW Howto told me to change it. This is the only reader/writer I have installed on my PC. To be honest, this Howto file is very confusing for a newbie like me.

Any ideas.

Thanks again,

Indy
 
Old 12-11-2002, 04:38 AM   #5
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
Nooooo....!

If originally cdrom-->hdc, then you need to have
append="hdc=ide-scsi"
in your lilo.conf file. And don't forget to run /sbin/lilo to put the changes into effect.
 
Old 12-11-2002, 04:52 AM   #6
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
Check /var/log/dmesg to see where your writer is and take it from there.
 
Old 12-11-2002, 09:23 AM   #7
freeindy
Member
 
Registered: Nov 2002
Posts: 196

Original Poster
Rep: Reputation: 30
So... changed to hdc again. Now it boots OK... Thanks a lot!

Thymox:
But still, when I type 'cdrecord -scanbus' I still get following message:
----------------------
cdrecord: No such file or directory. Cannot open SCSI driver
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
----------------------
(Its on root I get it!)

Any idea. I pretty much followed the CD-Writing howto procedure although I was very confused during process.

Indy
 
Old 12-11-2002, 09:41 AM   #8
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
In /dev cdrom needs to be linked to /dev/scd0
At lest thats how mine works.Do you got the regular debian kernel?
 
Old 12-11-2002, 10:48 AM   #9
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
You changed the lilo.conf file... did you re-run lilo?
You re-ran lilo... what does lsmod show?
 
Old 12-11-2002, 03:36 PM   #10
freeindy
Member
 
Registered: Nov 2002
Posts: 196

Original Poster
Rep: Reputation: 30
CRASHMEISTER:
Yepp, it's linked to /dev/scd0 :
-----------------------------
lrwxrwxrwx 1 root root 4 Dec 11 15:35 cdrom -> scd0
------------------------------

THYMOX:
Yepp, and re-ran lilo. lsmod says:
-------------------------------
Module Size Used by
lockd 42420 0 (autoclean) (unused)
sunrpc 57816 0 (autoclean) [lockd]
sb 32456 0
uart401 5872 0 [sb]
sound 56384 0 [sb uart401]
soundlow 384 0 [sound]
soundcore 2452 5 [sb sound]
3c509 6324 1
af_packet 6152 1
unix 11352 23 (autoclean)
-------------------------------

Does this help?
Cheers, Indy
 
Old 12-11-2002, 03:41 PM   #11
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 56
Hmmm, it seems that the modules aren't being loaded. What do your /etc/modules and /etc/modules.conf (or whatever their Debian equivalents are) say? I have:
Code:
/etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line.  Comments begin with
# a `#', and everything on the line after them are ignored.
scsi_hostadapter

/etc/modules.conf
probeall scsi_hostadapter ide-scsi
 
Old 12-12-2002, 03:50 AM   #12
freeindy
Member
 
Registered: Nov 2002
Posts: 196

Original Poster
Rep: Reputation: 30
Nothing about scsi_hostadapter.
All there is relating to it is what was written in cd-writing howto:
------------
options ide-cd ignore=hdc
alias scd0 sr_mod
pre-install sg modprobe ide-scsi
pre-install sr_mod modprobe ide-scsi
pre-install ide-scsi modprobe ide-cd
------------

I don't know but using modconf, I can't load the ide-scsi module. It fails:
--------------------
modprobe: Can't locate module ide-cd
modprobe: pre-install ide-scsi failed
modprobe: insmod ide-scsi failed

Installation failed
--------------------

I hope this was of any help...

Indy
 
Old 12-12-2002, 06:52 PM   #13
sewer_monkey
Member
 
Registered: May 2002
Location: Toronto, ON, Canada
Distribution: Ubuntu, Debian, RedHat/CentOS
Posts: 622

Rep: Reputation: 31
I would have to add (to all this) that LILO kinda sux... Not very user friendly. Whenever you can stick with GRUB. Just my $0.02...
 
Old 12-13-2002, 02:38 AM   #14
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
You may have to recompile your kernel.If you do and don't have any RAM issues just compile all the scsi stuff right in the kernel not as modules.Works fine for me and I have one thing less to worry about.
 
Old 12-13-2002, 03:21 AM   #15
freeindy
Member
 
Registered: Nov 2002
Posts: 196

Original Poster
Rep: Reputation: 30
CRASHMEISTER:
I would like to do that but I don't know how to. You see, I only have had linux on my PC for two months. And debian I found was best for me for the reason there was not too much shit installed during installation and that this was I could learn a lot by setting up by myself and by help of good people like you.
So, every time some mention about recompiling, i don't know how to because in debian you just add the package (which I never managed either). So please, could you give me instructions on this?

SEWER_MONKEY: I'll look into it. last time I installed i got lost and with lilo it was more straight forward. But then again, I'm not very experienced in linux. Not yet at least... :-)

cheers
Indy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Review - Debian was made for KDE vxc69 Debian 23 05-28-2007 07:56 AM
Woot! Made my Radeon 9800pro work on DEBIAN beeblequix Debian 1 10-24-2005 11:24 AM
setup and ntsysv cause FC3 crash franz77 Fedora 1 03-02-2005 09:19 PM
setup and ntsysv cause FC3 crash franz77 Linux - Software 0 03-02-2005 10:16 AM
ATi linux made difficult for debian shorty_boy Debian 21 09-09-2004 01:58 PM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration