LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-05-2003, 09:53 PM   #1
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
CD-Rom blues....


Well, aside from the fact that either my Mixer isn't working, my soundcard isn't set up right, or both, something happened to my CD-ROM drive. When I went to /dev there was no cdrom file or image there, which was the cause of me not being able to mount my cd-rom drive.

Well, I ran ln -s /dev/hdc /dev/cdrom to create the link between my cdrom drive and my hdc, then I tried to mount my CD-ROM and got this new fancy prompt:

"Warning
Drivemount command failed.
"Mount /mnt/cdrom 2>&1" reported:
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file systems"

Well, all I have mounted are hda2 and hdb1, so I doubt it's too many file systems mounted. And it's a music CD which reads in cd-players, so I doubt it's a bad superblock. And I've ran the same option before by clicking on the mount icon I created, which worked before I made this great mess-up, so I doubt it's the option. That leaves a wrong fs type. Any suggestions?
 
Old 05-05-2003, 10:24 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
you don't mount audio cd's,
 
Old 05-05-2003, 10:25 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Audio CD's don't have a filesystem that
Linux could possibly utilize ...

This, however. doesn't explain why /dev/cdrom
should be gone after a boot ... what did you do? :)

Cheers,
Tink
 
Old 05-06-2003, 05:37 PM   #4
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Original Poster
Rep: Reputation: 45
Ahh! GAHH!!! Thanks for telling me that you can't mount audio CD's. I found it odd that normal users usually can listen to CD's, but that they can't mount CD's...
I don't know what I did, but I did "ln -s hdd cdrom", and I guess that did the trick...
P.S. Anyone know why my computer wouldn't see my ethernet card when I added a line to my modules.config? I took the line out(which was the only line) and it worked again. Odd....
Now to tackle my soundcard! Hooah!
 
Old 05-06-2003, 05:58 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally posted by r_jensen11

P.S. Anyone know why my computer wouldn't see my ethernet card when I added a line to my modules.config? I took the line out(which was the only line) and it worked again. Odd....
Depends on the line you added I'd guess ;)

Cheers,
Tink
 
Old 05-06-2003, 10:13 PM   #6
dfctve_end_user
Member
 
Registered: Dec 2002
Location: Kalamazoo, MI - US
Distribution: Ubuntu 8.04 Hardy Heron LTS x86_64
Posts: 144

Rep: Reputation: 15
I have found that if you use gnome-volume-control there may be problems. From a command line run this:

$aumix

or:

$aumix-X11(if it's installed)

and verify that your PCM,CdRom,Line1(2,etc) all have red R's on them (arrow down and press spacebar to change from green P to red R).

This will enable your audio to be heard.

Hope that was helpful.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
permission denied! floppy cd-rom dvd-rom HELP! OMEGA-DOOM Linux - Software 17 10-15-2004 06:40 PM
DVD-ROM/CD-ROM unable to recognize debain boot CD gottfried Linux - Newbie 2 01-20-2004 01:39 PM
how to add cd-rom, dvd-rom, floppy, hard disk icons on gnome desktop? spyghost Linux - Software 6 09-21-2003 06:44 PM
CD rom blues Yomaoni Linux - General 5 09-12-2003 07:49 PM
DVD-ROM not detected CD-RW mistaken as CD-ROM Device DarkXtar Slackware 21 06-02-2003 08:58 PM


All times are GMT -5. The time now is 12:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration