LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-21-2002, 12:34 AM   #1
shankariyer
Member
 
Registered: Feb 2001
Location: California, USA
Distribution: Ubuntu 6.10[ HP Pavilion dv6000z ]
Posts: 165

Rep: Reputation: 30
Post CD Drives - Inaccessible


greetings !

I've a Windows 2000/Linux Mandrake 8.1 box with 2 CD drives( CDROM and CDRW ) in working condition( under windows ).

I installed Mandrake 8.1. Installation( from the same CDROM ) went like a breeze. But now I'm not able to read anything from my CD's thro' the same drives.

Weird thing is this happens only for Recorded/mp3 cd's. I'm able to play audio CD's thro' the CDROM but not mp3's.

Also, I'm not able to see these files thro' my file manager or even doing an ls in those directories. Here are some output with which some body can throw some light.

Hard-drake
-----------

There is a list of devices. I don't know as why it list 3, where I've only 2 drives.

1) Yamaha CRW4416E
Vendor: Unknown
Model: YAMAHA CRW4416E
Device: /dev/hdd
Bus Type: ATAPI/IDE

2) CRD-8400B
Vendor: Unknown
Model: CRD-8400B
Device: /dev/hdc
Bus Type: ATAPI/IDE

3) Yamaha CRW4416E
Vendor: YAMAHA
Model: CRW4416E
Device: /dev/scd0
Bus Type: SCSI

Directories( under /dev )
--------------------------
$ ls -l cdrom*
lr-xr-xr-x 1 root root 13 Mar 20 11:10 cdrom -> cdroms/cdrom0
lr-xr-xr-x 1 root root 13 Mar 20 11:10 cdrom0 -> cdroms/cdrom0
lr-xr-xr-x 1 root root 13 Mar 20 11:10 cdrom1 -> cdroms/cdrom1

cdroms:
total 0
lr-xr-xr-x 1 root root 33 Dec 31 1969 cdrom0 -> ../ide/host0/bus1/target0/lun0/cd
brw------- 1 shankar cdrom 11, 0 Mar 19 13:24 cdrom1


fstab
-----
$ cat /etc/fstab
/dev/hda9 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdc /mnt/cdrom auto user,iocharset=iso8859-1,umask=0,exec,codepage=850,ro,noauto 0 0
/dev/scd0 /mnt/cdrom2 auto user,iocharset=iso8859-1,umask=0,exec,codepage=850,ro,noauto 0 0
/dev/fd0 /mnt/floppy auto user,iocharset=iso8859-1,umask=0,sync,exec,codepage=850,noauto 0 0
/dev/hda1 /mnt/windows vfat iocharset=iso8859-1,umask=0,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda10 swap swap defaults 0 0
$
$ pwd
/mnt
$ ls
cdrom/ cdrom2/ disk/ floppy/ windows/
$ ls cdrom
$ ls cdrom2
$ ls cdrom
$

-thanks-
shankar.
 
Old 03-21-2002, 02:06 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Right, but do you mount the cds? Plaing music doesn't require mounting.
 
Old 03-21-2002, 04:06 AM   #3
panjas51
LQ Newbie
 
Registered: Mar 2002
Posts: 10

Rep: Reputation: 0
Talking I solved it !

As far as I can understand:
You can mount CD's
You can hear MP3
You cannot listen and original audio CD's (.cab format)

correct?



I had the same problem two or three weeks ago.

Thru some forum like this one, I can tell you what I've done.

in your fstab:
change the iso type to 9660 like below.
fstab
-----
/dev/hdc /mnt/cdrom auto user,iocharset=iso9660,umask=0,exec,codepage=850,ro,noauto 0 0
/dev/scd0 /mnt/cdrom2 auto user,iocharset=9660,umask=0,exec,codepage=850,ro,noauto 0 0

Place the CD into your hdc for instance:

gtcd --device /mnt/cdrom2

if the drive runs, and you do not hear anything, try with root.

If it works, then add some rights to your user
right: 'audio'.


What I did, I removed the user, and created again.
 
Old 03-21-2002, 01:11 PM   #4
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
If it's just a mounting issue, try running KwikDisk (K -> Configuration -> Hardware -> KwikDisk). That puts an icon on your task bar which lets you mount and unmount removable filesystems with the click of a button. Just click the icon to get a list of filesystems, then click on the one you want to mount it. If you click on it again, it unmounts it.
 
Old 03-21-2002, 05:12 PM   #5
shankariyer
Member
 
Registered: Feb 2001
Location: California, USA
Distribution: Ubuntu 6.10[ HP Pavilion dv6000z ]
Posts: 165

Original Poster
Rep: Reputation: 30
Thanks a lot to all those pitched in. So everyt time do I need to do this with Kwikdisk. Is there a way to automate it so that as I'm in, the CD's should be accessible.

-thanks-
shankar
 
Old 03-21-2002, 06:22 PM   #6
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
Supposedly running "supermount -i enable" as root will make changes to your /etc/fstab file so you can do this, but I've never used it. You might want to backup your /etc/fstab first. Not sure if it requires a reboot.
 
Old 03-21-2002, 06:26 PM   #7
taz.devil
Senior Member
 
Registered: Nov 2001
Location: Wa. State
Distribution: Slackware
Posts: 1,261

Rep: Reputation: 45
Supermount's not my bag either. I just type mount /dev/hdc and it mounts, but that's because i've added the entry to the aforementioned /etc/fstab. You won't have to reboot, type mount by itself and it should do a mount of everything in fstab.
 
Old 03-23-2002, 01:21 PM   #8
shankariyer
Member
 
Registered: Feb 2001
Location: California, USA
Distribution: Ubuntu 6.10[ HP Pavilion dv6000z ]
Posts: 165

Original Poster
Rep: Reputation: 30
hi,

Thanks to all of you. KwikDisk did solved the problem without any modification to 'fstab', so I assume that there is nothing wrong in the entries I've in fstab( attached in the thread ). If so, is there an option to automate the mount, I mean do I need to start KwikDisk everytime to mount my drives. How do I make it automatic ?

Thanks again to all those responded.

-shankar.
 
Old 03-23-2002, 10:50 PM   #9
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
Maybe I wasn't too clear in my last post... there's a program called supermount that is supposed to automatically mount cd's and floppy's for you. In order to turn it on, you need to run "supermount -i enable" as root. This will make the necessary changes to your /etc/fstab.

However, I have had little luck getting it to work, and I just prefer to do it manually under Linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Protected members inaccessible leonscape Programming 4 03-27-2004 11:35 AM
Port 25 inaccessible remotely dkochan Linux - Networking 1 01-21-2004 05:29 AM
httpd inaccessible remotely ORiON2012 Linux - Networking 7 06-14-2003 07:30 AM
Inaccessible at night flash71 Linux - Newbie 0 10-17-2001 03:11 PM
inaccessible file names pikachu66 Linux - General 2 10-01-2001 01:24 PM


All times are GMT -5. The time now is 03:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration