LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-20-2004, 11:06 PM   #1
Chryzmo
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 10.1
Posts: 180

Rep: Reputation: 30
CD Drive Mount Problem


Heyas,

I just installed Mandrake 9.1 on my computer. I have a CD-RW drive and a DVD-RW drive. I want to use the CD-RW as the default CD drive, which I believe is how I have it set up right now. My problem is when I try to install packages from the RPMDrake, it open s the correct CD drive and asks me to insert the cd on (cdrom3) on device [/dev/scd0]. So, I close the CD drive and click ok and it spits the disc out again and gives me the same message. I can goto the mount points and see data on both the CD drive and the DVD drive.

Here is what my /etc/fstab looks like, maybe it can help:

/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
/dev/hda1 /mnt/win_c vfat defaults 0 0
/dev/hdb6 /mnt/win_d vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda5 /mnt/win_e vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0
/dev/scsi/host0/bus0/target1/lun0/cd /mnt/cdrecorder auto ro,noauto,user,exec 0 0
/dev/scsi/host0/bus0/target0/lun0/cd /mnt/cdrecorder1 auto ro,noauto,user,exec 0 0

I am not sure where it is coming up with cdrom3, as there are only two. And why it is opening the correct CD drive, but won't read the cd when I hit OK, it just opens again and says to put the cd in cdrom3.

I am quite stumped so any help would be appreciated.

Thanks,
Chris

Last edited by Chryzmo; 01-20-2004 at 11:31 PM.
 
Old 01-21-2004, 12:05 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
The problem might be that you have four entries in your fstab for two hard disks. I think that when you put the disk into your first cdrom drive, supermount mounts it under /mnt/cdrom when it is expected under /mnt/cdrecorder. Save a backup of your /etc/fstab file and remove the 3rd and 4th lines.

P.S. - I bet you re-setup your fstab using k3b-setup.
 
Old 01-21-2004, 12:20 AM   #3
Chryzmo
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 10.1
Posts: 180

Original Poster
Rep: Reputation: 30
Yes, I did do the k3b-setup. I tried removing those lines from my fstab. However, now when I try to install a package it asks me to place ot cd in (cdrom3) on device [/dev/hdc]. This time it does not automatically open either of the cd drives.

Here is my current fstab:

/dev/hdb1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
/dev/hda1 /mnt/win_c vfat defaults 0 0
/dev/hdb6 /mnt/win_d vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda5 /mnt/win_e vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdb5 swap swap defaults 0 0
/dev/scsi/host0/bus0/target1/lun0/cd /mnt/cdrecorder auto ro,noauto,user,exec 0 0
/dev/scsi/host0/bus0/target0/lun0/cd /mnt/cdrecorder1 auto ro,noauto,user,exec 0 0

Perhaps you might have another suggestion?

Thanks,
Chris
 
Old 01-21-2004, 11:15 AM   #4
Chryzmo
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 10.1
Posts: 180

Original Poster
Rep: Reputation: 30
Isn't there someone with another idea? Its a bit difficult to do anything when I cannot install any packages from the CD
 
Old 01-21-2004, 11:30 AM   #5
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Try placing cd in & mounting it manually, then run rpmdrake.
 
Old 01-21-2004, 11:58 AM   #6
psycho2004
LQ Newbie
 
Registered: Jan 2004
Location: Mexico
Distribution: Mandrake 9.2
Posts: 15

Rep: Reputation: 0
Are you CD drives actually SCSI? if not I think you should remove this: (backup first just in case)

/dev/scsi/host0/bus0/target1/lun0/cd /mnt/cdrecorder auto ro,noauto,user,exec 0 0
/dev/scsi/host0/bus0/target0/lun0/cd /mnt/cdrecorder1 auto ro,noauto,user,exec 0 0

and put these instead ones:

none /mnt/cdrom supermount dev=/dev/hdc,fs=udf,ro,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=udf,ro,iocharset=iso8859-1,codepage=850,umask=0 0 0

Do this only if you have IDE drives.

Let me know what happens
 
Old 01-21-2004, 01:53 PM   #7
Chryzmo
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 10.1
Posts: 180

Original Poster
Rep: Reputation: 30
OK, I figured out the device I need to mount is /dev/scd0 and /dev/scd1. When I mount it manually from the terminal I can read from both drives and rpmdrake even works. However, when I used what psycho2004 said for my fstab, it will not read the CDs when I click the desktop items, it just opens a window and says there are no files.

In my fstab I put:

none /mnt/cdrom supermount dev=/dev/scd0,fs=udf,ro,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/cdrom2 supermount dev=/dev/scd1,fs=udf,ro,iocharset=iso8859-1,codepage=850,umask=0 0 0

The CD drive and DVD writer are both EIDE drives. I think the k3b setup set them up as SCSI drives, I do not know why though.

So, now the only problem is figuring out why the fstab entries will not work.

Thanks for your replies so far,
Chris
 
Old 01-21-2004, 02:04 PM   #8
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Is supermount running? Does the cdrom mount automatically in other cases? Also, put 'fs=auto' or 'fs=iso9660' instead of 'fs=udf', since it is unlikely that the cd is in udf format.
k3b sets the drives with scsi emulation because the ide driver for cdwriters in the 2.4 kernel isn't good.
 
Old 01-21-2004, 11:31 PM   #9
psycho2004
LQ Newbie
 
Registered: Jan 2004
Location: Mexico
Distribution: Mandrake 9.2
Posts: 15

Rep: Reputation: 0
what command do you type on terminal that mounts the drives correclty?,, post it so we can see how to fit it on fstab
 
Old 01-28-2004, 08:57 PM   #10
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
The lines that psycho2004 gave look good. You may want to change the supermount type from fs=udf to fs=udf:iso9660.

I'm not at home right now, so I can't look in my computer. There is a setup file for urpmi with a line for the drive that linux was setup on.

Also, give us the options line from /etc/lilo.conf. There needs to be an entry for each ide drive setup as a scsi drive. Something like 'ide3=ide-scsi'.

By the way, some setup programs will not work well with supermount, such as live-update (for when you upgrade to LM 9.3). The ide-scsi emulation is needed in order to burn cd's. Using supermount, you avoid having to umount before ejecting, and mounting after inserting a cd.

About the desktop part of the problem. You probably have to right click on them and correct the information in the properties->devices tab.

If you run the Mandrake Control Center and use the Update Sources setup, you could edit the installation sources to reflect the new names.

Last edited by jschiwal; 01-28-2004 at 09:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB flash drive mount problem servnov Linux - General 4 10-10-2005 09:08 PM
mount usb drive + debian problem alaios Linux - Hardware 3 06-13-2005 01:51 AM
Drive Mount Problem hakkinen SUSE / openSUSE 1 11-03-2004 03:23 AM
problem creating an alias to mount a drive j_l_ajaste Linux - Newbie 6 07-01-2003 11:41 PM
Mount ntfs drive (problem with the kernel) steed_ Linux - General 8 12-06-2002 09:09 PM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration