LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2006, 07:11 AM   #1
hobbsie
LQ Newbie
 
Registered: Jun 2006
Location: Sydney, Australia
Distribution: SuSE
Posts: 14

Rep: Reputation: 0
Question CD autorun stopped working


I am runnin SUSE 10.1 and noticed bout 10mins ago that when i put in a cd into one of my 2 drives (i think hdc, hdd respectively) that they no longer mount automatically and prompt me with a question on what i want to do.

I am usure on how to mount drives and the like myself, but would like the ability back for them to mount automatically when i place a cd in the drive.

If anyone could give me some advice I would appreciate it

Cheers
hobbsie
 
Old 06-15-2006, 07:39 AM   #2
dfctve_end_user
Member
 
Registered: Dec 2002
Location: Kalamazoo, MI - US
Distribution: Ubuntu 8.04 Hardy Heron LTS x86_64
Posts: 144

Rep: Reputation: 15
I am assuming that you have not recently done any updates to SuSEplugger or udev. I know that when I had done those updates it screwed things up for me. you can go into:

/home/<username>/.kde/share/config (I think) and look for the suseplugger.rc file. There you can tell SuSE what you want to do with each type of media.

Hope that helps.
 
Old 06-15-2006, 07:47 AM   #3
hobbsie
LQ Newbie
 
Registered: Jun 2006
Location: Sydney, Australia
Distribution: SuSE
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by dfctve_end_user
I am assuming that you have not recently done any updates to SuSEplugger or udev. I know that when I had done those updates it screwed things up for me. you can go into:

/home/<username>/.kde/share/config (I think) and look for the suseplugger.rc file. There you can tell SuSE what you want to do with each type of media.

Hope that helps.
I'm not sure about updates to udev or the like but i did recently run smart package manager and installed all the patches/upgrades it said were avail and then run SuSEconfig & ldconfig after it had finished.

Well i looked in the folder you mentioned above however i only have a susepluggerrc not suseplugger.rc and the only lines it contains are
Code:
[Default]
CheckFor75dpi=false
what would i need to put in there to make my cd/dvd drives come back to autorun life??
 
Old 06-15-2006, 07:52 AM   #4
dfctve_end_user
Member
 
Registered: Dec 2002
Location: Kalamazoo, MI - US
Distribution: Ubuntu 8.04 Hardy Heron LTS x86_64
Posts: 144

Rep: Reputation: 15
can you paste your fstab and mtab files? they are in /etc.
 
Old 06-15-2006, 08:01 AM   #5
hobbsie
LQ Newbie
 
Registered: Jun 2006
Location: Sydney, Australia
Distribution: SuSE
Posts: 14

Original Poster
Rep: Reputation: 0
fstab
Code:
/dev/hda6            /                    reiserfs   acl,user_xattr        1 1
/dev/hda7            /home                reiserfs   acl,user_xattr        1 2
/dev/hda1            /windows/C           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda2            /windows/D           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda5            swap                 swap       defaults              0 0
/dev/hdc	      /mnt/LG               auto      ro,auto,user,exec   0 0
/dev/hdd	      /mnt/TDK		    auto	ro,auto,user,exec  0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
mtab
Code:
/dev/hda6 / reiserfs rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/hda7 /home reiserfs rw,acl,user_xattr 0 0
/dev/hda1 /windows/C ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
/dev/hda2 /windows/D ntfs ro,noexec,nosuid,nodev,gid=100,umask=0002,nls=utf8 0 0
securityfs /sys/kernel/security securityfs rw 0 0
hope this helps
 
Old 06-15-2006, 08:16 AM   #6
dfctve_end_user
Member
 
Registered: Dec 2002
Location: Kalamazoo, MI - US
Distribution: Ubuntu 8.04 Hardy Heron LTS x86_64
Posts: 144

Rep: Reputation: 15
Quote:
/dev/hdc /mnt/LG auto ro,auto,user,exec 0 0
/dev/hdd /mnt/TDK auto ro,auto,user,exec 0 0
check your permissions on these files in the /dev directory and the /mnt entries you made (suse doesn't like deviation from the norm :: shrugs :.
ls -la /dev/hd<put letter here>
Code:
brw-rw----+ 1 root disk 3, 0 2006-06-12 17:10 /dev/hda
since I am not a member of this group I don't have access. Check to see if there is a /dev/cdrom or /dev/cdrecorder. Even DVD roms seem to show up under /dev/cdrom (Kaffiene had a time with this).

ls -la /media/

Code:
drwxr-xr-x   2 root root  48 2006-04-26 13:47 cdrom
Suse no longer uses /mnt as of the addition of udev. So if you modified your fstab to reflect the /mnt entry it may not produce the results you are looking for. Let me know if you have any entries in your /media directory.
 
Old 06-15-2006, 08:42 AM   #7
hobbsie
LQ Newbie
 
Registered: Jun 2006
Location: Sydney, Australia
Distribution: SuSE
Posts: 14

Original Poster
Rep: Reputation: 0
ls -la /dev/hdc; ls -la /dev/hdd
Code:
brw-rw----+ 1 hobbsie disk 22, 0 2006-06-16 03:06 /dev/hdc
brw-rw----+ 1 hobbsie disk 22, 64 2006-06-16 03:06 /dev/hdd
ls -la /media/
Code:
total 7
drwxr-xr-x  4 root root  104 2006-06-15 23:10 .
drwxr-xr-x 24 root root  568 2006-06-16 03:06 ..
dr-xr-xr-x  7 root root 6144 2006-05-09 10:05 cdrom (created by myself)
drwxr-xr-x  2 root root   48 2006-05-09 03:44 xmms_audio_cd
there ya go
 
Old 06-15-2006, 08:51 AM   #8
dfctve_end_user
Member
 
Registered: Dec 2002
Location: Kalamazoo, MI - US
Distribution: Ubuntu 8.04 Hardy Heron LTS x86_64
Posts: 144

Rep: Reputation: 15
Code:
brw-rw----+ 1 hobbsie disk 22, 0 2006-06-16 03:06 /dev/hdc
brw-rw----+ 1 hobbsie disk 22, 64 2006-06-16 03:06 /dev/hdd
Were these already modified? I think the OS project is doing things differently than the Novell SuSE team is if you didn't.

check this command too:

ls -la /dev/cd*

My server is running 10 and has a cdrecorder. I have not had any problems with it even after reinstall. I guess if you have modified things you may want to visit YaST and look under Hardware for the cdrom drives and see if you can change them to directories under /media. It's the most user friendly anyway. Hope I have helped a little.

Last edited by dfctve_end_user; 06-15-2006 at 08:53 AM.
 
Old 06-15-2006, 09:06 AM   #9
hobbsie
LQ Newbie
 
Registered: Jun 2006
Location: Sydney, Australia
Distribution: SuSE
Posts: 14

Original Poster
Rep: Reputation: 0
I edited the permissions myself on hdc & hdd so they matched the perms you showed in your previous post

i have dvdram (symlink to hdc) and also cdrecorder (symlink to hdd) in /dev/

ls -la /dev/cd*
gives me these below
Code:
lrwxrwxrwx 1 root root 3 2006-06-16 03:06 /dev/cdrecorder -> hdd
lrwxrwxrwx 1 root root 3 2006-06-16 03:06 /dev/cdrom -> hdc
As for yast>>hardware>>cdrom there is no cdrom entry in the harware section only the ones shown in the image below.
http://www.hobbsie.info/ext_img/snapshot1.jpg
 
Old 06-15-2006, 03:56 PM   #10
dfctve_end_user
Member
 
Registered: Dec 2002
Location: Kalamazoo, MI - US
Distribution: Ubuntu 8.04 Hardy Heron LTS x86_64
Posts: 144

Rep: Reputation: 15
It's under IDE DMA Mode. If the drives are older, you may not want those to be activated. Might cause problems with the system recognizing them.
 
Old 06-21-2006, 06:34 PM   #11
hobbsie
LQ Newbie
 
Registered: Jun 2006
Location: Sydney, Australia
Distribution: SuSE
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for your assistance dfctve_end_user however under the IDE DMA area there is no option to set mount points.

Don't worry too much though I bit the bullet and reinstalled SUSE and its working fine now.

Thanks for your help

Cheers
hobbsie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
x stopped working sleepwalk Slackware 1 03-25-2006 09:52 AM
X stopped working ... Rackerz Ubuntu 1 12-11-2005 08:09 PM
X stopped working sueno Fedora 15 10-02-2004 12:23 PM
It stopped working. UmneyDurak Fedora 8 08-15-2004 02:41 PM
My X just stopped working??? freeindy Linux - Newbie 4 11-30-2002 10:53 AM


All times are GMT -5. The time now is 05:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration