LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2011, 01:53 PM   #1
ka2m
LQ Newbie
 
Registered: Nov 2011
Location: Saratov, Russia
Distribution: Ubuntu 11.10, Debian 6, Gentoo 2011
Posts: 3

Rep: Reputation: Disabled
Capturing Winkey.


I have Gentoo on VirtualBox with awesome WM. As host I've installed Ubuntu 11.10 with Unity. Every time (doen't matter if keyboard is captured in VB) I press winkey (which is the main in awesome), Ubuntu captures it and I can't go on.

I don't want to change Mod4 in awesome, it suits me. How can I turn capturing off?
 
Old 11-17-2011, 03:39 PM   #2
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
What is your host key in Virtualbox? If it's winkey change it to something else. If it's something else (right ctrl is the default I think), pressing it will release input capture in your guest and allow the host to see all keystrokes.

I don't know of any reason why a vbox guest should capture keys - except for the host key - unless it already has the mouse input captured and/or the vbow window is focused.
 
Old 11-21-2011, 10:42 AM   #3
ka2m
LQ Newbie
 
Registered: Nov 2011
Location: Saratov, Russia
Distribution: Ubuntu 11.10, Debian 6, Gentoo 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by SecretCode View Post
What is your host key in Virtualbox? If it's winkey change it to something else. If it's something else (right ctrl is the default I think), pressing it will release input capture in your guest and allow the host to see all keystrokes.

I don't know of any reason why a vbox guest should capture keys - except for the host key - unless it already has the mouse input captured and/or the vbow window is focused.
I don't know the reason why, because my hostkey in vbox is RightCtrl. But still, despite capture or non-capture in vbox, Unity interrupts me and catches the WinKey.

I found out that it would be easier to change Mod4 in X11 of Gentoo or just change ModKey in awesome wm.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WinKey not working anymore in KDE Phiebie Debian 12 09-29-2009 12:46 PM
Problem: WinKey as shortcut thool Zenwalk 1 09-13-2006 03:52 PM
using winkey+m in kde? hottdogg Linux - General 2 08-10-2006 12:20 AM
make use of winkey demmylls Linux - General 3 10-07-2003 09:27 AM
How to use the Winkey under linux? concoran Linux - General 9 11-19-2001 02:38 AM


All times are GMT -5. The time now is 06:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration