LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-19-2004, 12:52 PM   #1
vishi_1982
LQ Newbie
 
Registered: Jul 2004
Posts: 4

Rep: Reputation: 0
cant work on terminals even though GUI works just fine!


I have installed Red Hat 10 on my pc.
The graphical user mode works fine but when i login to a terminal by pressing Ctrl+Alt+F1 it shows error messages as shown below:

[drm:i830_wait_ring] * ERROR * lockup
[drm:i830_wait_ring] * ERROR * space : 131000 wanted 131064

these error messages continue for about 30 seconds
and eventually the system automatically logs out and the login screen appears.
This happens on all the terminals Alt+F2, Alt+F3 etc.
Can someone please help me rectify this problem.
 
Old 07-20-2004, 02:07 PM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
You start up in graphical mode, correct? And then you want to switch to a text terminal?

I am guessing here.

But, it that is what you want to do (i. e. work in textmode) try this:

Edit /etc/inittab and change the

id:5:initdefault:

line to

id:3:initdefault:

MAKE SURE YOU CORRECTLY SET IT TO 3. Any other values except 3 or 5 can make your system unusable!

Reboot.

What will now happen is that your system will come up in textmode. At the console login type your username and password as usual, exactly the same like you used for graphical login.

You should now be able to work in text mode to your heart's content. If you want graphical mode again, you should be able to get into it by just typing

startx

Hope this helped!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse works great ! Unless I swop terminals ? DudeArX Linux - Hardware 1 08-12-2005 09:03 AM
hw to get GUI in dump terminals ss100 Linux - Software 1 12-06-2004 12:43 AM
e0 will Rx, but not Tx...e1 works fine giant Linux - Networking 2 09-15-2004 01:13 PM
cant get gui to work in RH9, but worked fine in mandrake 10 sgcam2000 Linux - Hardware 0 07-13-2004 05:28 AM
No XF86Config on Fedora2 but the GUI works fine??? Crasherz Fedora 1 06-18-2004 08:05 PM


All times are GMT -5. The time now is 11:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration