LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2012, 05:04 AM   #1
bacon_cabbage
LQ Newbie
 
Registered: Sep 2012
Location: Donegal, Ireland
Distribution: Debian, Pinguy Ubuntu, Linux Mint
Posts: 14

Rep: Reputation: Disabled
Unhappy Cant watch videos. Flash non free installed.


HELP.
I installed debian 6 2 days ago, but I cannot watch and videos in youtube. I have flash player non free installed but still cannot watch videos in youtube. I have followed several tutorials on how to install it and as far as I can know i have done every thing right. Can some please help me on how to do this from scratch even if it means removing software and starting over again. I am pulling my hair out as to what Im doing wrong. I even removed iceweasel through synaptic and then did a reinstall made no difference.
 
Old 09-26-2012, 10:06 AM   #2
bacon_cabbage
LQ Newbie
 
Registered: Sep 2012
Location: Donegal, Ireland
Distribution: Debian, Pinguy Ubuntu, Linux Mint
Posts: 14

Original Poster
Rep: Reputation: Disabled
Ok got it working i had to install gnash. I was told to uninstall gnash from another forum, but reinstalled this morning and can watch videos in you tube now. But now yy daughter was on the pc since and now her facebook games wont load. Lets say the game is farm-town the pages just's keeps loading really quickly but thats all it does. (using ice weasel). I have chromium installed and tried it, her page loads but there is nothing on the page. PLZ PLZ PLZ help this is never ending don't want to uninstall debian
 
Old 09-26-2012, 10:30 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,133
Blog Entries: 2

Rep: Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836
Gnash sadly is not at the state the proprietary Flash player is, that is why the games won't work. If you want to get it working you should uninstall Gnash and install the non-free Flash player. If you have bot installed, Gnash and the Adobe player, you will run into problems, so use either one or the other.
 
Old 09-26-2012, 10:49 AM   #4
bacon_cabbage
LQ Newbie
 
Registered: Sep 2012
Location: Donegal, Ireland
Distribution: Debian, Pinguy Ubuntu, Linux Mint
Posts: 14

Original Poster
Rep: Reputation: Disabled
Ok but when I uninstall gnash I have nothing, cant watch videos, face book games wont load or nothing. Il uninstall it now. I have flash non free installed because when i open synaptic its marked as installed and also in software centre its marked as installed.
 
Old 09-26-2012, 10:58 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,133
Blog Entries: 2

Rep: Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836
Try if it helps if you re-install the non-free packages.
 
Old 09-26-2012, 10:58 AM   #6
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,465

Rep: Reputation: 1399Reputation: 1399Reputation: 1399Reputation: 1399Reputation: 1399Reputation: 1399Reputation: 1399Reputation: 1399Reputation: 1399Reputation: 1399
A non-working Flash may be caused by your having the wrong version for your CPU:
http://www.linuxquestions.org/questi...us-4175420481/
 
Old 09-26-2012, 11:05 AM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I've had that problem with flashplugin-nonfree it ended when I went to /usr/lib/flashplugin & double-clicked on public-key, which imported & saved key.
 
Old 09-26-2012, 11:14 AM   #8
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
apt-get purge gnash
apt-get install --reinstall flashplugin-nonfree

then delete pluginreg.dat in your Iceweasel profile
 
Old 09-26-2012, 12:00 PM   #9
bacon_cabbage
LQ Newbie
 
Registered: Sep 2012
Location: Donegal, Ireland
Distribution: Debian, Pinguy Ubuntu, Linux Mint
Posts: 14

Original Poster
Rep: Reputation: Disabled
Gnash now uninstalled and back to unable to play videos, like i said before i have flash non free installed so i dont know what I am doing wrong.
 
Old 09-26-2012, 12:10 PM   #10
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Try post #7 & 8
 
Old 09-26-2012, 12:13 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,133
Blog Entries: 2

Rep: Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836
Please post the output of
Code:
cat /proc/cpuinfo
so that we can see if DavidMcCann's solution applies here.
 
Old 09-26-2012, 01:03 PM   #12
bacon_cabbage
LQ Newbie
 
Registered: Sep 2012
Location: Donegal, Ireland
Distribution: Debian, Pinguy Ubuntu, Linux Mint
Posts: 14

Original Poster
Rep: Reputation: Disabled
root@debian:/home/kieran# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Pentium(R) Dual-Core CPU E5300 @ 2.60GHz
stepping : 10
cpu MHz : 1200.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm
bogomips : 5200.77
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 23
model name : Pentium(R) Dual-Core CPU E5300 @ 2.60GHz
stepping : 10
cpu MHz : 1200.000
cache size : 2048 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm
bogomips : 5199.74
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

root@debian:/home/kieran#
 
Old 09-26-2012, 01:10 PM   #13
bacon_cabbage
LQ Newbie
 
Registered: Sep 2012
Location: Donegal, Ireland
Distribution: Debian, Pinguy Ubuntu, Linux Mint
Posts: 14

Original Poster
Rep: Reputation: Disabled
Unhappy

now im getting this message from terminal as per post 8 from craigevil

root@debian:/home/kieran# apt-get install --reinstall flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 8 not upgraded.
Need to get 0 B/17.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Media change: please insert the disc labeled
'Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42'
in the drive '/media/cdrom/' and press enter

(Reading database ... 143623 files and directories currently installed.)
Preparing to replace flashplugin-nonfree 1:2.8.2 (using .../flashplugin-nonfree_2.8.2_amd64.deb) ...
Unpacking replacement flashplugin-nonfree ...
Processing triggers for man-db ...
Setting up flashplugin-nonfree (1:2.8.2) ...
--2012-09-26 19:07:15-- http://fpdownload.macromedia.com/get....x86_64.tar.gz
Resolving fpdownload.macromedia.com... failed: Name or service not known.
wget: unable to resolve host address `fpdownload.macromedia.com'
ERROR: wget failed to download http://fpdownload.macromedia.com/get....x86_64.tar.gz
More information might be available at:
http://wiki.debian.org/FlashPlayer
N: Ignoring file 'opera.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
root@debian:/home/kieran#
____________________________________________________________________________________________________ _______________


thanks guys for your help so far really appreciate this and dont mean to waste your time

---------- Post added 09-26-12 at 01:11 PM ----------

now im getting this message from terminal as per post 8 from craigevil

root@debian:/home/kieran# apt-get install --reinstall flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 8 not upgraded.
Need to get 0 B/17.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Media change: please insert the disc labeled
'Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42'
in the drive '/media/cdrom/' and press enter

(Reading database ... 143623 files and directories currently installed.)
Preparing to replace flashplugin-nonfree 1:2.8.2 (using .../flashplugin-nonfree_2.8.2_amd64.deb) ...
Unpacking replacement flashplugin-nonfree ...
Processing triggers for man-db ...
Setting up flashplugin-nonfree (1:2.8.2) ...
--2012-09-26 19:07:15-- http://fpdownload.macromedia.com/get....x86_64.tar.gz
Resolving fpdownload.macromedia.com... failed: Name or service not known.
wget: unable to resolve host address `fpdownload.macromedia.com'
ERROR: wget failed to download http://fpdownload.macromedia.com/get....x86_64.tar.gz
More information might be available at:
http://wiki.debian.org/FlashPlayer
N: Ignoring file 'opera.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
root@debian:/home/kieran#
____________________________________________________________________________________________________ _______________


thanks guys for your help so far really appreciate this and dont mean to waste your time
 
Old 09-26-2012, 01:18 PM   #14
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Edit /etc/apt/sources.list
as root #
Quote:
nano /etc/apt/sources.list
as user $
Quote:
sudo nano /etc/apt/sources.list
comment out 'Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42'
by putting # in front of it
 
Old 09-26-2012, 01:43 PM   #15
Terminator3000
Member
 
Registered: Jun 2012
Distribution: Centos 6 & Fluxbox
Posts: 86

Rep: Reputation: Disabled
You should be able to install the Genuine Adobe Flash 11 plugin if your cpu is sse2 enabled. Flash 11.2 is the last release from Adobe.

#cat /proc/cpuinfo look in 'flags' line for 'sse2', there's a guide and download link to it at

http://minimallinux.blogspot.co.uk/2...obe-flash.html

The guide is for Centos/RHEL but should easily adapt to Debian

If your cpu is only sse enabled then you want Flash 10 which you can find at the bottom of the same page

Last edited by Terminator3000; 09-26-2012 at 01:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install flash plugin to watch youtube videos ozulloa Linux - Newbie 3 09-05-2010 12:20 PM
Can't watch videos using fedora 7, which option is best for me?Adobe Flash? Antoniovega22 Linux - Software 2 07-03-2010 09:40 AM
cant view videos anymore with adobe flash player installed andy barnes Linux - Newbie 1 05-11-2010 10:50 PM
LXer: get-flash-videos - A command line program to download flash videos LXer Syndicated Linux News 0 04-06-2010 01:20 PM
cant watch videos from web due to no flash player in browser vivek2407 Linux - Newbie 2 08-07-2008 03:09 AM


All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration