LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2011, 10:16 AM   #1
Adol
Member
 
Registered: Feb 2011
Location: Osaka, Japan
Distribution: Gentoo, Opensuse
Posts: 262

Rep: Reputation: 5
Cant use ./configure as normal user after new OpenSuse install


hello,

Ive never had this problem before but after reinstalling OpenSuse I cant run
Code:
./configure
as a normal user or even with sudo(which I dont want to do anyway) unless its in my directory
Code:
/home/(username)
I can run it with su but I really dont like to do that.

I dont like this because I want to be able to compile from other locations also the other location is all chmod 777.

As I said before I have never had this problem before(with OpenSuse or any distro)

Last edited by Adol; 11-12-2011 at 10:18 AM.
 
Old 11-12-2011, 10:38 AM   #2
Adol
Member
 
Registered: Feb 2011
Location: Osaka, Japan
Distribution: Gentoo, Opensuse
Posts: 262

Original Poster
Rep: Reputation: 5
So I just found that I cant ./configure as root on that drive.

here is a copy of my fstab:
Code:
/dev/sda3               none            swap            sw                              0 0
/dev/sda4               /               ext4            noatime                         1 2
/dev/storage/working    /bigdrive       xfs             noatime,user                    1 2
/dev/sda1               /boot           ext2            defaults,noatime                1 2
/dev/sda2               /home           ext4            noatime,user                    1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
I have reinstalled OpenSuse many times and have never had this problem before.

Any ideas?
 
Old 11-12-2011, 05:12 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,990

Rep: Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448Reputation: 2448
what version of OpenSUSE ?

you stated you "reinstalled"

did you use the OLD /home partition ?- if so make a NEW user
 
Old 11-12-2011, 09:45 PM   #4
Adol
Member
 
Registered: Feb 2011
Location: Osaka, Japan
Distribution: Gentoo, Opensuse
Posts: 262

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by John VV View Post
what version of OpenSUSE ?

you stated you "reinstalled"

did you use the OLD /home partition ?- if so make a NEW user
Im using OpensSuse 11.4.

I completely wiped my system harddrive and installed OpenSuse. I did not however format /bigdrive where all of my non system related files are and where I want to build things.
 
Old 11-12-2011, 10:02 PM   #5
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Rep: Reputation: 37
Make sure you have a config file. Some source code only has a make file.

Then check who owns the file(s).
Code:
cd <directory where you are trying to compile>
ls -l
If it is owned by root move one directory up:
Code:
cd ..
chown -R <your name> <directory name>
Then try ./config
Code:
cd <directory name>
./config
 
Old 11-12-2011, 10:19 PM   #6
Adol
Member
 
Registered: Feb 2011
Location: Osaka, Japan
Distribution: Gentoo, Opensuse
Posts: 262

Original Poster
Rep: Reputation: 5
I think I have found the problem.

I took a look at mount and got this:
Code:
devtmpfs on /dev type devtmpfs (rw,relatime,size=1987600k,nr_inodes=496900,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda4 on / type ext4 (rw,noatime,user_xattr,acl,barrier=1,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/mapper/storage-working on /bigdrive type xfs (rw,nosuid,nodev,noexec,noatime,attr2,noquota)
/dev/sda1 on /boot type ext2 (rw,noatime,errors=continue)
/dev/sda2 on /home type ext4 (rw,nosuid,nodev,noexec,noatime,barrier=1,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,relatime)
gvfs-fuse-daemon on /home/petreuss/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
my /home and /bigdrive are set to noexec. but my fstab is:
Code:
/dev/sda3               none            swap            sw                              0 0
/dev/sda4               /               ext4            noatime                         1 2
/dev/storage/working    /bigdrive       xfs             noatime,user                    1 2
/dev/sda1               /boot           ext2            defaults,noatime                1 2
/dev/sda2               /home           ext4            noatime,user                    1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
which has no noexec option stated.

How can I un noexec my drives?
 
Old 11-12-2011, 10:25 PM   #7
Adol
Member
 
Registered: Feb 2011
Location: Osaka, Japan
Distribution: Gentoo, Opensuse
Posts: 262

Original Poster
Rep: Reputation: 5
figured it out

Ok thank you for your suggestions.

I figured it out.

In my fstab I set "user" as an option without fully understanding it. The "user" option set a noexec tag to my drive.

After taking it off, ./configure workes perfectly.

Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure SAMBA for AD as well as Normal User authentication? chandramani_yadav Linux - Server 0 11-11-2010 03:14 AM
cd-rom can not be used in apps as normal user in opensuse 11.1 sirius57 Linux - General 6 07-10-2010 10:32 PM
Install gnuplot without as normal user cstrieder Ubuntu 3 02-03-2010 05:09 PM
OpenSuSE 11.1 - VirtualBox howto run as normal user doddg Linux - Newbie 2 09-30-2009 02:05 AM
Can I install to /usr/local as a normal user? Jongi SUSE / openSUSE 8 12-21-2005 12:45 AM


All times are GMT -5. The time now is 11:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration