LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2004, 03:50 AM   #1
spedsta
Member
 
Registered: Aug 2003
Location: South Africa
Distribution: mandrake 9.1
Posts: 36

Rep: Reputation: 15
cant umount cd, always says its busy??


I am running mdk 10 CE and have a dvd rom (dev/hdc) and a cd writer (dev/hdd)
My problem is that when i insert a cd it would mount the cd correctly but when i want to umont the cd or eject it, it will tell me that the cd is still busy. I wait a while but no difference, I had to manually remove the instance from the fstab file, only then could i eject safely.

Is there some way that i wouldn't have to mess with my fstab file every time i want to remove my cd .

Besides this problem, i also can't mount a lot of cd's , all readable in windows, because it says that its a wrong medium.

How can it be a wrong medium when its just a normal music cd?

thanks ahead of time.
 
Old 05-31-2004, 04:10 AM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Hi spedsta!!!

How are you trying to eject the cd? Are you "right clicking" on the device from your desktop? Are you running "eject" from a terminal?. Try this:

Code:
umount /mnt/cdrom
where /mnt/cdrom is the mount point of your cdrom. (Note: it's not the device point /dev/, but the mount point ).

It's also important to remember that, if you accessing the files on your CDrom, or even "located" at your CDRom mount point, you won't be able to eject. What I mean is, if you are at /mnt/cdrom and try to eject/umount, it won't work. Type "cd", it will take you directly to your /home/user directory and it's safe to eject.

A last advice about umounting. Depending of your permissions set, only root may be able to eject a CD. I never used Mandrake 10.0, but 9.2 allows non-root users to eject the CD, so 10.0 may follow the same way of doing things, but you could take a look also at that .

Now, about the "wrong medium error", that's normal. You will get any message like that when trying to mount any media CD as audio, VCD's or DVD's. Simply put the CD into the drive and fire up the player (kscd, workbone or whatever you use) and it should play the CD
 
Old 05-31-2004, 04:24 AM   #3
spedsta
Member
 
Registered: Aug 2003
Location: South Africa
Distribution: mandrake 9.1
Posts: 36

Original Poster
Rep: Reputation: 15
thanks for the reply,

I have been right clicking in Konquerer, and choosing eject. Thats the first time that message came up. I closed everything down, opened a shell and tried umount /mnt/cdrom and it gave the same message. I then also tried umount /dev/hdc and it gave the same message.

Do you perhaps think that maybe its because i closed down Konquerer when still at the cd drive( actually dunno if i was but looking for a solution here?

About the cd being the wrong medium, that makes sense
 
Old 05-31-2004, 04:25 AM   #4
ToeShot
Member
 
Registered: Nov 2001
Location: Near Chicago
Distribution: FC5, Solaris 10, WinXP
Posts: 152

Rep: Reputation: 30
in your fstab you should have a line to mount the cd and the type should be iso9660 this will take care of the wrong medium error. example fstab

LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/sda1 /music0_B vfat defaults 0 0
/dev/sda2 /musicV_Z vfat defaults 0 0
/dev/sda3 /pics vfat defaults 0 0
/dev/sda5 /musicC_E vfat defaults 0 0
/dev/sda6 /musicF_J vfat defaults 0 0
/dev/sda7 /musicK_O vfat defaults 0 0
/dev/sda8 /musicP_U vfat defaults 0 0
/dev/sda9 /closet ext2 defaults 0 0

/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
 
Old 05-31-2004, 07:46 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,929

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Mandrake uses supermount which means you do not need to use the mount / umount commands. Before you try to eject the CD make sure there are not any applications accessing the drive. Close any file browsers and verify any console windows current working directory is not the CD.

Music CDs can not be mounted because they do not contain a valid data filesystem. A CD player does not reference fstab to access the CDROM drive. It has its on configuration settings.

BTW Kcd requires an audio cable between the CDROM drive and the sound card. xmms (latest version) is capable of digital audio extraction and therefore does not require the cable.

This might work:
http://www.elis.rug.ac.be/~ronsse/cdfs/
 
Old 05-31-2004, 11:35 AM   #6
spedsta
Member
 
Registered: Aug 2003
Location: South Africa
Distribution: mandrake 9.1
Posts: 36

Original Poster
Rep: Reputation: 15
thanks for the replies, i think it could have been that i had a window or shell open on the cdrom.
Is it dead set necessary to have alink to /dev/cdrom .

is the correct syntax " ln -l /dev/hdc /dev/cdrom" ?

another niggle is that kcd doesn't play the files once it opened. it just stalls .
 
Old 06-01-2004, 04:11 AM   #7
spedsta
Member
 
Registered: Aug 2003
Location: South Africa
Distribution: mandrake 9.1
Posts: 36

Original Poster
Rep: Reputation: 15
Hi there again, this is a follow up:

I got everything working as far as the drives are concerned, they are now mounting and umounting as normal , i had to turn on supermount.

Only thing is that Kde doesn't seem to refresh very well as it keeps the old file structure. When i double click oj the cd icon on the desktop it will display exactly whats on the current cd, i view an image thats on the cd by double clicking and then click the back button, this takes me to the root of the cd, only thing is that the previous disks file structure now shows.

How can i get Kde to flush the cach of the old disk after supermount umnounts it.

Another small question: Kscd can only work on one cd device(/dev/cdrom0 at the moment). Is it possible to have it read two devices so that on insert of either drive it can play. It does autostart but can't play if its not configured to read the correct cdrom.
Maybe the link wasn't done correctly?

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
umount :device busy Pedroski Linux - Hardware 14 12-29-2004 04:37 PM
umount - device is busy - with what??? Moebius Linux - Software 16 12-08-2004 11:32 AM
fam and umount says device is busy Brian1 Fedora 2 10-05-2004 08:33 PM
umount /var device busy winchester169 Linux - Networking 1 06-25-2004 08:53 PM
umount: /mnt/a5: device is busy PTBmilo Linux - General 2 01-31-2003 11:48 PM


All times are GMT -5. The time now is 12:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration