LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't retain my resolution or choose my graphic manager in Slackware 12.1 (http://www.linuxquestions.org/questions/linux-newbie-8/cant-retain-my-resolution-or-choose-my-graphic-manager-in-slackware-12-1-a-644496/)

gregorian 05-24-2008 11:46 AM

Can't retain my resolution or choose my graphic manager in Slackware 12.1
 
I installed Slackware 12.1 using the "full" option. The installation was successful. After I logged on, I typed startx but I got some No screen error. I browsed for help and found that I could get my graphic manager working by typing xorgsetup and choosing a few basic settings. After doing this I could start my X server. I logged in at 1024 x 768 resolution in KDE (chose this as my default manager during setup). I went to the KDE Control Center and changed the resolution to 1280 x 768. When I logged out and logged back in I found that the resolution had been restored to 1024 X 768. I changed the resolution again, but this time the screen went black and there was nothing I could do. I repeated this procedure several times and the screen went black a few of the times. It hasn't happened now for a long time and I think that the black screen problem has gone away. However, I still have to change the resolution every time I log in.

Besides this, I do not get the option of choosing the graphic manager at startup. I know that the full installation of Slackware gives you 4-5 graphic managers.

xorg.conf

Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/OTF"
        FontPath    "/usr/share/fonts/Type1"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
        Load  "glx"
        Load  "extmod"
        Load  "GLcore"
        Load  "xtrap"
        Load  "dbe"
        Load  "record"
        Load  "dri"
        Load  "type1"
        Load  "freetype"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"  "itouch"
        Option      "XkbLayout"  "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        #DisplaySize      280  210    # mm
        Identifier  "Monitor0"
        VendorName  "GSM"
        ModelName    "3acb"
        Option      "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "NoAccel"                  # [<bool>]
        #Option    "SWcursor"                  # [<bool>]
        #Option    "ColorKey"                  # <i>
        #Option    "CacheLines"                # <i>
        #Option    "Dac6Bit"                  # [<bool>]
        #Option    "DRI"                      # [<bool>]
        #Option    "NoDDC"                    # [<bool>]
        #Option    "ShowCache"                # [<bool>]
        #Option    "XvMCSurfaces"              # <i>
        #Option    "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName  "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
        BusID      "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport  0 0
                Depth    1
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    4
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    8
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    15
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    16
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection



Thank your for your time.

cwwilson721 05-24-2008 03:01 PM

From your post, it sounds like you are logging in a CLI (Command Line Interface), and then switching to xserver.

If you look in the Slackware forum, 99% of the issues you have described are already answered. Take a look there.

And welcome to Slackware!

gregorian 05-25-2008 12:16 AM

I went through the threads and added HorizSync, VertRefresh and the resolutions. I still have the same problem. It's not that I can't achieve the 1280 x 1024 resolution. It's just that it goes back to the 1024 x 768 when I log back. Even if I set it at 800 x 600, it goes back to 1024 x 768 as if that's the default resolution.

I've highlighted the additions with bold.

Code:

Section "ServerLayout"
        Identifier    "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/share/X11/rgb"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/OTF"
        FontPath    "/usr/share/fonts/Type1"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
        Load  "glx"
        Load  "extmod"
        Load  "GLcore"
        Load  "xtrap"
        Load  "dbe"
        Load  "record"
        Load  "dri"
        Load  "type1"
        Load  "freetype"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"  "logicink"
        Option      "XkbLayout"  "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        #DisplaySize          280  210        # mm
        Identifier  "Monitor0"
        HorizSync    30-70
        VertRefresh  50-120


        VendorName  "GSM"
        ModelName    "3acb"
        Option            "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "NoAccel"                    # [<bool>]
        #Option    "SWcursor"                  # [<bool>]
        #Option    "ColorKey"                  # <i>
        #Option    "CacheLines"                # <i>
        #Option    "Dac6Bit"                    # [<bool>]
        #Option    "DRI"                        # [<bool>]
        #Option    "NoDDC"                      # [<bool>]
        #Option    "ShowCache"                  # [<bool>]
        #Option    "XvMCSurfaces"              # <i>
        #Option    "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName  "82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
        BusID      "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth 24
        SubSection "Display"
                Viewport  0 0
                Depth    1
                Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    4
                Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    8
                Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Depth    15
                Modes      "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Modes      "1280x1024" "1024x768" "800x600" "640x480"
                Depth    16
        EndSubSection
        SubSection "Display"
                Viewport  0 0
                Modes      "1280x1024" "1024x768" "800x600" "640x480"
                Depth    24
        EndSubSection
EndSection


okos 05-25-2008 03:05 PM

Have you tried installing the video drivers for your monitor?
:twocents:

I had a similar problem until I installed the Nvidia driver.

Perhaps it is just a work around the actual issue.

cwwilson721 05-25-2008 03:52 PM

If you look, it's an Intel chipset. Compiling from source is NOT a good idea in SW for this chipset.

gregorian 05-26-2008 12:00 AM

I don't understand why it defaults to 1024 x 768 every time I log in. Don't know if it's related but I chose Frame Buffer Console 1024 x 768 during setup. That's what it chose for me.

H_TeXMeX_H 05-26-2008 04:37 AM

Have you tried deleting the other modes and leaving only
Code:

Modes      "1280x1024"

gregorian 05-26-2008 05:30 AM

I didn't do that. Since the modes were not present in the original xorg.conf file, I didn't expect it to have an effect. I can set resolutions even higher than 1280 x 1024 even though they're not there in the file.

gregorian 05-27-2008 12:02 AM

Can I write a script to change the resolution at startup? Something I could set to autostart every time I log on to KDE?

H_TeXMeX_H 05-27-2008 01:13 AM

Maybe it's something to do with KDE. Maybe a setting or something that changes it.

gregorian 05-27-2008 01:34 AM

I hope there's a way. Changing the display resolution every time I startx is tiresome. If Ctrl Alt + worked, it wouldn't have been so bad, but even that doesn't work for me.


All times are GMT -5. The time now is 03:47 AM.