LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't mount windows partition in non admin mode (http://www.linuxquestions.org/questions/linux-newbie-8/cant-mount-windows-partition-in-non-admin-mode-789275/)

puneetsoni 02-15-2010 01:17 PM

Can't mount windows partition in non admin mode
 
Hi all,
My problem goes as :
I can mount and access windows drive in root, but cannot mount NTFS partition in non admin mode. It tells authentication required!! , could not find out why it is happening. Please help me out

MY /etc/fstab goes as :

/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda10 during installation
UUID=80117144-8dfc-47ad-8896-dea9c426f7ee / ext4 errors=remount-ro 0 1
# swap was on /dev/sda9 during installation
UUID=40e64729-21e7-495a-a0f1-89636ede0262 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

biggocharley 02-15-2010 01:45 PM

[QUOTE=puneetsoni;3864609]Hi all,
My problem goes as :
I can mount and access windows drive in root, but cannot mount NTFS partition in non admin mode. It tells authentication required!! , could not find out why it is happening. Please help me out


I think you may have an ownership issue. Suggest you mount the partition as root --then check the properties and you will find that root is the owner. Change the ownership to your username and that will probably solve the problem.
Charley

puneetsoni 02-15-2010 02:02 PM

Hi i was able to mount the disk.

All i did was i worked with /etc/fstab.

Thanks for the help.

jschiwal 02-15-2010 02:09 PM

I don't know which Linux distro and version you are using and whether you are talking about an external (removable) drive or an internal one.

For removable drives, on recent distro versions, policy-kit is used to enable the desktop user to the media. There is a similar policy for fixed media. This is how auto-mounting of pen drives works.

Code:

polkit-auth --show-obtainable
org.freedesktop.network-manager-settings.system.modify
org.freedesktop.hal.storage.mount-fixed
org.opensuse.cupspkhelper.mechanism.printer-set-default
org.opensuse.cupspkhelper.mechanism.printer-enable
org.opensuse.cupspkhelper.mechanism.printer-local-edit
org.opensuse.cupspkhelper.mechanism.printer-remote-edit
org.opensuse.cupspkhelper.mechanism.class-edit
org.opensuse.cupspkhelper.mechanism.server-settings
org.opensuse.cupspkhelper.mechanism.job-not-owned-edit
org.opensuse.cupspkhelper.mechanism.printeraddremove
org.freedesktop.policykit.read
org.freedesktop.policykit.revoke
org.freedesktop.policykit.grant
org.freedesktop.policykit.modify-defaults

For fixed media, a root user can edit /etc/fstab so that is mounted when you boot up. After that it doesn't need to be mounted by a regular user.

If the /etc/fstab entry uses the "user" or "users" option and the "uid=" value is set, then a regular user can mount that partition. ( This is for systems where the mount command is suid root ) The "mount" command checks for a uid= value. For removable drives, the first column in the /etc/fstab file should be a unique identifier for the filesystem.

The uid, gid, fmask and dmask mount options determine the permissions of a HFS, FAT32 or NTFS filesystem. The permissions of all files will be the same.


All times are GMT -5. The time now is 01:23 PM.