LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-24-2004, 06:29 AM   #1
dwarf007
Member
 
Registered: Sep 2004
Location: Malaysia
Posts: 181

Rep: Reputation: 30
cant modify a file on mounted FAT partition


1) I already mount my FAT partition but cant modify the openoffice sxw file, can i know how to solve this problem?

2) Can i know how to open a sxw file on terminal?

Anyone knows please help, thanks.....
 
Old 09-24-2004, 06:36 AM   #2
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
I hope you have "rw" permissions not only as root but also as normal user that you use to login. Also, check the permission of the file itself. Right click on the file in a browser like nautulis or konqueror and see the permissions. (or do "ls -l" in a terminal)

(the line in /etc/fstab should be something like this)
Code:
 /dev/hdX        /mnt/windows     vfat        users,owner,rw,umask=000 0 0

Last edited by akudewan; 09-24-2004 at 06:38 AM.
 
Old 09-24-2004, 06:41 AM   #3
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
What permissions were set on the fat partition when you mounted it? what is the line in /etc/fstab that mounted the partition?
I think sxw files are a compressed xml format so you'll probably need to use Open Office to open them. You should be able to launch Open Office from the terminal though
soffice -writer /path/to/file.sxw
 
Old 09-24-2004, 07:03 AM   #4
dwarf007
Member
 
Registered: Sep 2004
Location: Malaysia
Posts: 181

Original Poster
Rep: Reputation: 30
I had check the permission of my FAT permission
owner --> r,w,x
goupr --> r,-,x
others --> r,-,x

I also had tried the command, the partition mount as usual but stil cant modify the file

code:
/dev/hdX /mnt/windows vfat users,owner,rw,umask=000 0 0



I also tried the command, but cant applies to my situation , can i know why?
soffice -writer /path/to/file.sxw

[root@localhost eugene]# soffice -writer /home/eugene/to/Guide.sxw



Anyone knows please help, thanks......
Thanks for the help of akudewan and Andrew Benton
 
Old 09-24-2004, 07:21 AM   #5
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Code:
[root@localhost eugene]# soffice -writer /home/eugene/to/Guide.sxw
What exactly was the output in the terminal when you did this?
 
Old 09-24-2004, 08:47 AM   #6
dwarf007
Member
 
Registered: Sep 2004
Location: Malaysia
Posts: 181

Original Poster
Rep: Reputation: 30
I tried the following command, the output are as below,

[root@localhost eugene]# soffice -writer /home/eugene/to/Guide.sxw
bash: soffice: command not found

can i know why? Please help, Thanks..........
 
Old 09-24-2004, 08:55 AM   #7
dwarf007
Member
 
Registered: Sep 2004
Location: Malaysia
Posts: 181

Original Poster
Rep: Reputation: 30
Post

[root@localhost /]# mount /dev/hdb5 /mnt/FATPartition

Normally i use the above code as mount my FAT Partition, but once i use the below code, it fails

[root@localhost /]# mount /dev/hdb5 /mnt/FATPartion users,owner,rw,umask=000 0 0

Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .
[/list][root@localhost /]# mount /dev/hdb5 /mnt/FATPartition
 
Old 09-24-2004, 09:02 AM   #8
michapma
Member
 
Registered: Oct 2003
Location: Zürich
Distribution: Debian
Posts: 537

Rep: Reputation: 39
bash: soffice: command not found

This indicates that either Open Office is not installed (I am assuming that that is the correct command) or else that it is not installed in a way that the system knows how to find it without a direct link. Is Open Office installed on your distribution?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a way to modify/edit/erase a file in a WinXP partition from within Linux? aixarat Linux - Newbie 8 09-26-2004 12:07 AM
writing a file to a FAT partition Cman Programming 8 09-21-2004 05:25 PM
i want to compile fat file system module and get fat.o working ramya272 Linux - Newbie 9 02-26-2004 12:41 PM
Can't see files in mounted fat partitions mcfly420 Slackware 4 05-29-2003 03:23 AM
modify file access & modify timestamps i2itstud Linux - General 1 05-20-2003 04:34 AM


All times are GMT -5. The time now is 01:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration