LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2012, 11:25 AM   #1
sankarm72
LQ Newbie
 
Registered: Apr 2012
Posts: 4

Rep: Reputation: Disabled
cant login locally keep getting login prompt over and over on redhat linux 5.4


I am unable to login locally on my redhat linux 5.4 server.The login prompt keep getting again and again when I type userid. It doesn't allow me to type in my userID .When I just type the frist letter of my user-ID the login prompt again pops up.the /var/log/secure has the following message
bind to port 22 on 0.0.0.0 failed address already in use.

Please kindly help me on how to resolve this issue. I need to login to my server ASAP.
Thaks a lot in advance.
 
Old 04-01-2012, 11:01 PM   #2
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 656

Rep: Reputation: 121Reputation: 121
Is this login console based or gui based?
 
Old 04-02-2012, 02:48 AM   #3
sankarm72
LQ Newbie
 
Registered: Apr 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
It is the root console and a local console. The login is a gui login . When I try to type my login ID the login gui display keep on coming up.I am unable to type even a single letter. The server boots without any errors in Single user mode and in INIT 3(runlevel3).As A Mentioned earlier in the post the /var/log/secure says unable to bind to port 22(sshd port) .The error is written to the file when ever I try to login at runlevel 5 using GUI local console. It is related to sshd . Will the editing of sshd_config help?right now my /etc/services file says port 22
is allocated to ssh for both protocols UDP and TCP.

Please kindly help me.
 
Old 04-02-2012, 03:35 AM   #4
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 8,121

Rep: Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270Reputation: 2270
you need to find the error. Maybe sshd could not be started, or ?
 
Old 04-02-2012, 04:04 AM   #5
ericson007
Member
 
Registered: Sep 2004
Location: Japan
Distribution: CentOS 7.1
Posts: 656

Rep: Reputation: 121Reputation: 121
as per the post above and...

Check your ssh config and see check root login settings. make sure there are no other stuff blocking you like a hosts deny file, tcpwrappers etc.
 
Old 04-02-2012, 05:13 AM   #6
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
Quote:
Originally Posted by sankarm72 View Post
I am unable to login locally on my redhat linux 5.4 server.The login prompt keep getting again and again when I type userid. It doesn't allow me to type in my userID .When I just type the frist letter of my user-ID the login prompt again pops up.the /var/log/secure has the following message
bind to port 22 on 0.0.0.0 failed address already in use.

Please kindly help me on how to resolve this issue. I need to login to my server ASAP.
Thaks a lot in advance.
This happens when you are using both IPv4 and IPv6 for ssh. If you don't use IPv6 then make sure you have disabled all IPv6 options in your machine

Code:
#vi /etc/ssh/sshd_config
#ListenAddress 0.0.0.0
#ListenAddress ::
Code:
#vi /etc/sysconfig/network
NETWORKING_IPV6=no
Code:
#vi /etc/modeprobe.conf
install ipv6 /bin/true
if the above file is not present then

Code:
#touch /etc/modprobe.d/disable-ipv6.conf
# echo "install ipv6 /bin/true" >> /etc/modprobe.d/disable-ipv6.conf
Code:
#chkconfig --level 345 ip6tables off
rebooting your machine to take affects will be best
 
Old 04-03-2012, 12:35 AM   #7
sankarm72
LQ Newbie
 
Registered: Apr 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
I tried the disabling of IPV6 protocol as mentioned in the above steps . After doing the above steps the server was rebooted and the problem was not resolved. I once agaain mention the problem.
The problem is I am unable to type in my login userID in the GUI console on the local box console(The console of the server itself. When I try to type in any thing the login window keeps on popping up and I am unable to type in the login userID or password. I again mention that the console is local to the machine and is on the same box.
The /var/log/secure file is having the following messages ..Repeatedly
APR 3 09:45:30 bujji sshd[2740]: recieved signal 15 ; terminating
APR 3 09:47:04 bujji sshd[2661]: server listenig on :: port 22.
APR 3 09:47:04 bujji sshd[2661]:error:bind to port 22 on 0.0.0.0 failed:Address already in use

the /etc/service file has the following entries..
ssh 22/tcp #ssh remotelogin protocol
ssh 22/udp #ssh remotelogin protocol
x11-ssh-offset 6010/tcp #ssh X11 forwarding offset

Please kindly help me solving this problem .. Thanks a lot in advance
 
Old 04-03-2012, 12:56 AM   #8
sankarm72
LQ Newbie
 
Registered: Apr 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
One thing I would like to know from you all is ...If I configure sshd to run on an additional port that is not being used .. I mean configuring sshd to run both on port 22 and an additional port.. Will it help?
If so please let me know how to configure sshd to run both port 22 and an additional port..
Thanks a lot for your help in advance
 
Old 04-03-2012, 01:06 AM   #9
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
your problem seems more like a GUI issue rather than ssh. If you are not able to login using GUI then ssh or port 22 has nothing to do with it.
The error which you see in /var/log/secure must signify about the alarms when you attempt to login to your machine using ssh
Try reinstalling your GUI package Gnome Desktop Environment or install KDE using yum and see if the problem persists.

If you want to add additional ports to ssh then edit your sshd_config file

Code:
#vi sshd_config
Port 22
Port 2222
restart the service

Code:
#ssh -p 2222 server_ip
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't log in locally (keep getting login prompt over and over) on Red Hat EL5 pedram9 Linux - Server 5 07-24-2012 09:33 AM
When power is reset Linux server sits at login prompt, want this to login automatical jenniekingsland Linux - Newbie 1 09-07-2010 08:29 AM
vsftpd login locally, but not remotely. get a login prompt though! ajkett Linux - Server 0 02-22-2007 05:18 AM
RedHat graphical login prompt fails LQtoto Linux - General 1 02-12-2004 06:42 AM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration