LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-25-2011, 02:07 PM   #1
wildcat777
LQ Newbie
 
Registered: Mar 2011
Posts: 12

Rep: Reputation: 0
cant install flashplayer for love or money:[


hi all i'm worst than a noob when it comes to computers all i use my old acer aspire one for is watching the odd you tube clip,anyway i fired up my acer the other day and was greeted with the message "ive got to install latest macromedia plugin to watch this video.....Ive tried all i can to get flashplayer,i downloaded yum,tar,rpm..tried troublshooting the various forums for tips on getting it installed but to no avail...im running linpus and my acer is quite old.Believe it or not ive even managed to find out how to get root user priveleges still doesnt help though,ive downloaded and extacted more than i can remember lol tried copying to differnt destinations but nothing......one said to copy file to /usr/lib/opera/plugins...but i get message say i dont have authority for that....but i know how in terminal to get root...i type su... it asks for password... i type it and it looks like i have root......guys i really need some help here ive been trying allsorts and me heads throbbing,basically got a defunct unit if i cant watch flash videos...help please guys.
 
Old 03-25-2011, 02:46 PM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,479

Rep: Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020
If you're using Firefox (which would be a Good Idea), you can simply go to to Tools - Add-ons and get it there (along with Acrobat Reader -- see https://addons.mozilla.org/en-US/firefox/browse/type:7). Otherwise, you ought to be able to, using the browser you use, go to http://get.adobe.com/flashplayer and pick the format you need.

If you choose the [I]tar.gz/I] format, save the file in /tmp then unzip and untar it (use tar xzv filenameyoudownload. What you'll get is a file named libflashplayer.so which you copy to /usr/lib/mozilla/plugins (you'd do the same with the Adobe Reader plugin). That same thing should work with Opera, except copying to the appropriate Opera plugin directory.

Hope this helps some.

Last edited by tronayne; 03-26-2011 at 08:01 AM. Reason: Forgot the "lib" in /usr/lib/mozilla
 
Old 03-25-2011, 02:50 PM   #3
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,078

Rep: Reputation: 195Reputation: 195
Use of capitalisation, proper punctuation and paragraphs would all make your post a lot easier to read.

That said, there's something you need to understand about the Linux you have installed which is pretty much encompassed in this post I wrote in another thread:
http://www.linuxquestions.org/questi...ml#post4261789
That's about updating Firefox on an old Asus, but it applies to your situation as well.


You might be able to get Adobe Flash updated though. Go to http://get.adobe.com/flashplayer/otherversions/ and select Linux and then the option that ends .tar.gz.

Then get a command prompt and run this command
Code:
$ tar zxvf install_flash_player_10_linux.tar.gz
This will leave you with a file called libflashplayer.so

Now find the plugins directory for your web browser. Where that is will depend on which web browser you are using. (Whatever it is, I'm guessing it's a hopelessly out of date version.) If you're using Opera, it might be the directory you mention. If you're using Firefox it's probably /usr/lib/firefox/plugins or something similar to that.

As root, copy the libflashplayer.so in to your plugins directory.
Code:
$ cp libflashplayer.so /your/plugin/directory/
 
Old 03-25-2011, 03:28 PM   #4
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,028

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
are you using a 64-bit machine ?

http://www.jamesward.com/2010/09/15/...-64-bit-linux/

Last edited by schneidz; 03-25-2011 at 03:33 PM.
 
Old 03-25-2011, 04:58 PM   #5
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 2,175

Rep: Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172
Quote:
Originally Posted by tronayne View Post
If you're using Firefox (which would be a Good Idea)
Don't be mean! Why should he settle for second best. :P

Quote:
Originally Posted by tronayne View Post
What you'll get is a file named libflashplayer.so which you copy to /usr/mozilla/plugins (you'd do the same with the Adobe Reader plugin). That same thing should work with Opera, except copying to the appropriate Opera plugin directory.
I think you meant /usr/lib/mozilla/plugins and actually Opera will look in there as well, so you could save it there and it will work in both browsers.

If you continue to have problems saving to one of the /usr/lib sub directories because of permissions you can actually save it in any directory and ask Opera to look there. I'm not sure all lesser browsers will let you do this but I'll tell you how in Opera.

Start a terminal and issue:

Code:
mkdir -p ~/adobe_flash
wget -O- http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz | tar -xzf- -C ~/adobe_flash
chmod +x ~/adobe_flash/libflashplayer.so
Then in Opera open "Preferences (Alt+p) > Advanced > Content > Plug-in options > Change path > Add" and add the directory 'adobe_flash' from your home directory. After confirming all dialogs restart Opera and you will have Flash.

Last edited by ruario; 03-25-2011 at 05:00 PM.
 
Old 03-25-2011, 07:14 PM   #6
wildcat777
LQ Newbie
 
Registered: Mar 2011
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by arizonagroovejet View Post
Use of capitalisation, proper punctuation and paragraphs would all make your post a lot easier to read.

That said, there's something you need to understand about the Linux you have installed which is pretty much encompassed in this post I wrote in another thread:
http://www.linuxquestions.org/questi...ml#post4261789
That's about updating Firefox on an old Asus, but it applies to your situation as well.


You might be able to get Adobe Flash updated though. Go to http://get.adobe.com/flashplayer/otherversions/ and select Linux and then the option that ends .tar.gz.

Then get a command prompt and run this command
Code:
$ tar zxvf install_flash_player_10_linux.tar.gz
This will leave you with a file called libflashplayer.so

Now find the plugins directory for your web browser. Where that is will depend on which web browser you are using. (Whatever it is, I'm guessing it's a hopelessly out of date version.) If you're using Opera, it might be the directory you mention. If you're using Firefox it's probably /usr/lib/firefox/plugins or something similar to that.

As root, copy the libflashplayer.so in to your plugins directory.
Code:
$ cp libflashplayer.so /your/plugin/directory/
thanks for the help all...i tried all the above..i got the libflashplayer.so file..then i became root and typed $ cp libflashplayer.so /usr/lib/opera/plugins and got message missing destination file operand......i also tried /usr/lib/mozilla/plugins and also /usr/lib/firefox/plugins...on each occasion got message missing destination file operand...so stuck again,got quite hopeful when the libflashplayer.so file appeared lol. By the way regarding my grammer and punchuation and spelling,i apologize its just i'm absolutly going cross eyed trying to sort this out,had about 7 hours sleep in 4 days since this problem arose...just been constantley on my acer trying to sort it,you also asked about backing up files,ive never done this basically i wouldnt know how to.You gotta take into account i only use my acer for watching youtube.Was quite hopeful when i saw the respones hoping one of them might get it sorted but it was not to be..Listen all who responded a really big thank you for taking the time to post the your thoughts on the problem,i really am grateful. Think i'll have to admit defeat now though there just seems no way i can get flashplayer to install,time to start saving up for a more modern netbook,will definatley be steering clear of linux linpus whatever its called,its just way to complacated for a simpleton like me lol. thanks again all.
 
Old 03-25-2011, 07:20 PM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Don't type the $ before cp libflashplayer.so /usr/lib/mozilla/plugins .
 
Old 03-26-2011, 06:39 AM   #8
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,078

Rep: Reputation: 195Reputation: 195
What web browser are you using?

Try this command, it will find any directories call plugins. It might take a while. Don't get impatient and interrupt it, just let it run.

Code:
$ find /usr -name plugins

If you're using Firefox look and see if you have a directory in your home directory called .mozilla. If so there should be a directory in there called plugins. If not, make one. Try putting the .so file in there.


Limpus isn't any more complicated than other Linux it's just that it's not designed for modifications such as you are trying to achieve. See my comments in that other thread I linked about how it's designed to be an appliance and as a result it's very difficult to modify the software, especially when you have no idea what you're doing. You don't have to buy a new netbook, can replace Limpus with a different version of Linux such as Ubuntu, again see the other thread for details.
 
Old 03-26-2011, 08:04 AM   #9
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,479

Rep: Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020
Quote:
I think you meant /usr/lib/mozilla/plugins and actually Opera will look in there as well, so you could save it there and it will work in both browsers.
Oh, blah!

Yup, /usr/lib/mozilla/plugins; fumble-fingered that one and didn't see it, thanks.
 
Old 03-26-2011, 08:48 AM   #10
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 2,175

Rep: Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172
@wildcat777: Ok, I had a further think about this and can make it even simpler for you. Enter these two lines in a terminal window:

Code:
mkdir -p ~/.local/lib/opera/plugins
wget -O- http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz | tar -xzf- -C ~/.local/lib/opera/plugins
if you get an error stating 'wget: command not found' then try this instead:

Code:
curl http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz | tar -xzf- -C ~/.local/lib/opera/plugins
Then restart Opera and you should have Flash.
 
Old 03-26-2011, 07:43 PM   #11
wildcat777
LQ Newbie
 
Registered: Mar 2011
Posts: 12

Original Poster
Rep: Reputation: 0
thanks for sticking with me

thanks all for sticking with me,i've tried the other things youve said but still no flash...can i just give you some more imformation on some of the problems ive been encountering,i'll just list them in no particular order..1 just out of interest i double clicked on the libflashplayer.so file and i get archived format is not reconized. 2 i put the libflashplayer.so in the /usr/lib/opera/plugins and went to opera,i pressed alt and p and got preferances i clicked plugins and got to the change path..i go to the folder/directory? where libflashplayer.so is and libflashplayer.so is faded out..like not in bold black ink,wondering if this is linked to problem 1,i'm starting to think that even though i have this file libflashplayer.so theres something corrupt with it..anyway when i click on find new plugins in opera it finds nothing. Another thing i've not a clue weather my acer is 32 bit or 64 bit or is using fedora or debian..im clueless...wondering if on the adobe flashplayer website when im asked to pick 32 bit or 64 bit fedora or debian im picking the right one,guess you can see what a mess im in...also had some messages whilst in terminal...one word keeps popping up is operand..and something about no end to my directory...ive looked in system and my acer is running....linpus lite v 1.0.9.e dont know if this helps you in determining anything about my machine that might help you help me...ive got the firefox browser installed but i can tell you its the version that was installed when i got the acer so its quite old,it keeps telling me to upgrade to 4.0..ha chance will fine thing...but get this i was on you tube before i flashplayer problems and there was a banner across the top of my screens saying i was useing an out of date broswer,there was options for firefox 4.0 google chrome safari and opera 11...dont ask me how beginners luck maybe but i some how managed to opera 11 downloaded and installed and its running perfectley..does this mean anything to you,,i'm thinking if my acer can run opera 11 there must surely be someway to finally get flashplayer installed..well i live in hope...if anyone can some how get flashplayer to be installed on my machine you must be a bloody genius.By the way my machine does not have a disc drive. thanks to the posters who have tried to help me i'm truely grateful.
 
Old 03-26-2011, 07:54 PM   #12
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,028

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
^ please post the output of:
Code:
uname -a -m -p
cat /proc/cpuinfo
edit: fyi, linpus lite is the name of the distribution you are running. i heard horrible things about it (related: http://www.linuxquestions.org/questi...s-lite-669864/)
i recomend installing fedora or ubuntu on it.

Last edited by schneidz; 03-26-2011 at 08:00 PM.
 
Old 03-26-2011, 07:57 PM   #13
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: openSUSE, Fedora, CentOS
Posts: 1,078

Rep: Reputation: 195Reputation: 195
If you were someone looking to provide help rather than someone asking for help, would you bother to try and read that?

Help people to help you. Capitalisation. Punctuation. At least make an attempt at paragraphs even if it's just hitting enter every few sentences.
 
1 members found this post helpful.
Old 03-26-2011, 08:20 PM   #14
wildcat777
LQ Newbie
 
Registered: Mar 2011
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by arizonagroovejet View Post
If you were someone looking to provide help rather than someone asking for help, would you bother to try and read that?

Help people to help you. Capitalisation. Punctuation. At least make an attempt at paragraphs even if it's just hitting enter every few sentences.
In answer to you question yeah i would try and read that,because i'm kind of an helpful guy a bit like you...i'm really sorry if my rushed and rather manic typing style has offended you,i was'nt being presumptuous and just expecting help without putting some effort in myself.Maybe i'm just going slightley crazy trying to sort this problem out and in doing so neglecting how i write my questions.Putting all that aside i'm grateful for your help and no i've not backed anything up.
 
Old 03-26-2011, 08:33 PM   #15
wildcat777
LQ Newbie
 
Registered: Mar 2011
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by schneidz View Post
^ please post the output of:
Code:
uname -a -m -p
cat /proc/cpuinfo
edit: fyi, linpus lite is the name of the distribution you are running. i heard horrible things about it (related: http://www.linuxquestions.org/questi...s-lite-669864/)
i recomend installing fedora or ubuntu on it.
hi there i entered that code and got... uname:extra operand "cat/proc/cpuinfo" try "uname --help" for imfomation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
install flashplayer 10?? ClayOgre Slackware 13 11-02-2009 05:59 AM
How do I install flashplayer 7 genuinefake Linux - Software 7 08-13-2006 09:39 PM
ho to install flashplayer howarddevore Ubuntu 5 12-07-2005 06:49 AM
Flashplayer install MRDucks Linux - Newbie 1 09-03-2005 09:46 PM
install flashplayer romcgill Linux - Software 8 03-22-2003 07:45 PM


All times are GMT -5. The time now is 02:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration