LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2010, 08:21 PM   #1
linuxishard
Member
 
Registered: Jun 2010
Distribution: Ubuntu 10.10 Netbook Remix
Posts: 81

Rep: Reputation: 16
Cant install Doom Level Editor


this is super embarresing. ive made desktop enviroments for my friends but i cant figure out how too install this


http://www.teaser.fr/~amajorel/yadex...tml#2003-04-01


can some one please help step by step with terminal commands and everything? this is very embarrising.
 
Old 08-05-2010, 08:24 PM   #2
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,087

Rep: Reputation: 337Reputation: 337Reputation: 337Reputation: 337
see here
https://help.ubuntu.com/community/CompilingEasyHowTo
 
Old 08-05-2010, 08:26 PM   #3
LinuxBauer
LQ Newbie
 
Registered: Aug 2010
Posts: 7

Rep: Reputation: 0
How come ubuntu is always so good at answering questions? It's always the place to check
 
Old 08-05-2010, 08:46 PM   #4
linuxishard
Member
 
Registered: Jun 2010
Distribution: Ubuntu 10.10 Netbook Remix
Posts: 81

Original Poster
Rep: Reputation: 16
i got lost and failed.

help?
 
Old 08-05-2010, 09:35 PM   #5
linuxishard
Member
 
Registered: Jun 2010
Distribution: Ubuntu 10.10 Netbook Remix
Posts: 81

Original Poster
Rep: Reputation: 16
i was doin good until i got to the end.






src/colour4.cc:33:22: error: X11/Xlib.h: No such file or directory
src/colour4.cc: In function ‘pcolour_t* alloc_colours(rgb_c*, size_t)’:
src/colour4.cc:101: error: ‘XColor’ was not declared in this scope
src/colour4.cc:101: error: expected ‘;’ before ‘xc’
src/colour4.cc:102: error: ‘xc’ was not declared in this scope
src/colour4.cc:105: error: ‘Status’ was not declared in this scope
src/colour4.cc:105: error: expected ‘;’ before ‘r’
src/colour4.cc:109: error: ‘r’ was not declared in this scope
src/colour4.cc: In function ‘void free_colours(pcolour_t*, size_t)’:
src/colour4.cc:187: error: ‘dpy’ was not declared in this scope
src/colour4.cc:187: error: ‘cmap’ was not declared in this scope
src/colour4.cc:187: error: ‘XFreeColors’ was not declared in this scope
make: *** [obj/0/colour4.o] Error 1

checkinstall 1.6.1, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
This software is released under the GNU GPL.



*****************************************
**** Debian package creation selected ***
*****************************************

This package will be built according to these values:

0 - Maintainer: [ root@drew-laptop ]
1 - Summary: [ level editor for doom ]
2 - Name: [ yadex ]
3 - Version: [ 1.7.0 ]
4 - Release: [ 1 ]
5 - License: [ GPL ]
6 - Group: [ checkinstall ]
7 - Architecture: [ i386 ]
8 - Source location: [ yadex-1.7.0 ]
9 - Alternate source location: [ ]
10 - Requires: [ ]
11 - Provides: [ yadex ]

Enter a number to change any of them or press ENTER to continue:

Installing with make...Installing with install...

========================= Installation results ===========================
obj/0/install -m 755 obj/0/yadex /usr/local/bin/yadex-1.7.0
make: execvp: obj/0/install: Permission denied
make: *** [install] Error 127

**** Installation failed. Aborting package creation.

Cleaning up...OK

Bye.
 
Old 08-05-2010, 09:43 PM   #6
linuxishard
Member
 
Registered: Jun 2010
Distribution: Ubuntu 10.10 Netbook Remix
Posts: 81

Original Poster
Rep: Reputation: 16
nevermind, just had to change permissions on install. thanks guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install Doom 3 and other babujbf Sabayon 1 08-05-2009 10:55 AM
doom install JoeUser11 Linux - Newbie 8 04-28-2005 03:00 PM
WANTED: Low Level Disc Sector editor for LINUX SAB Linux - General 4 04-24-2005 09:24 PM
Help me with Doom Install! Eagle_Seven Linux - Games 6 08-26-2004 11:47 PM
Frozen Bubble Level Editor nutbrownhares Linux - Games 4 04-05-2004 11:41 PM


All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration