LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2006, 09:25 PM   #1
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Rep: Reputation: 0
Angry Cant go online eth0 FAILED!!!!


Help i cant seem to go online i just intalled fedora core 6 on my computer, i keep on getting eth0 failed on boot also i cant access network even if i put in the root password i dont know what to do please help!

TIA!
 
Old 12-21-2006, 09:34 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
enter "lspci" and report the line which tells you about your nic.

enter "ifconfig" and tell us the output.

have you tried adding and configuring your card?
 
Old 12-21-2006, 09:39 PM   #3
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge
enter "lspci" and report the line which tells you about your nic.

enter "ifconfig" and tell us the output.

have you tried adding and configuring your card?
sorry im so noob to linux but i got to applications->accesories->terminal put in su then my pw that went fine i put in lspci got bash: lspci: command not found.

if i go to system ->administration->network it wants the root pw from me i put that in nothing happens.

ifconfig gives me
bash: ifconfig: command not found.

am i putting this in the wrong place?????

thanks for your help!

Last edited by n00b_101; 12-21-2006 at 09:43 PM.
 
Old 12-21-2006, 10:03 PM   #4
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
Either do "su -" (get the root environment) instead of "su", or do "/sbin/ifconfig" instead of "ifconfig". This is because only the root user has /sbin/ in their $PATH, which is where the shell looks for programs to execute.
 
Old 12-21-2006, 10:17 PM   #5
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Ynot Irucrem
Either do "su -" (get the root environment) instead of "su", or do "/sbin/ifconfig" instead of "ifconfig". This is because only the root user has /sbin/ in their $PATH, which is where the shell looks for programs to execute.
thanks man appreciate that!,
for LSPCI i got
i got Ethernet Controller : 3Com Corporation 3c905B 100BaseTX [Cyclone ] Rev 30

for ifconfig
eth0: Link Encap : Ethernet HWaddr 00:50a:B6:16:01
inet6 addr : fe80::250::daff::feb6::1601/64 Scope: Link
UP BROADCAST MULTICAST MTU:1500 METRIC :1
RX PACKETS:445963 errors: 0 : dropped :0 overruns: 0 frames: 0
TX PACKETS:80 errors : 0 dropped: 0 overruns : 0 carrier : 0
collisions : 0 txqueuelen:1000
Rx bytes :2706094 (25.8 MIB) tx bytes :17030 (16.6kb)
Inturrupt :10

lo: Link encap:Local Loopback
inet addr :127.0.0.1 mask 255.0.0.0
inet6 addr: :: 1/128 Scope : host
UP LOOPBACK RUNNING MTU : 16346 Metric :1
RX PACKETS:4635 errors: 0 : dropped :0 overruns: 0 frames: 0
TX PACKETS:4635 errors: 0 : dropped :0 overruns: 0 carrier: 0
collisions : 0 txqueuelen:0
RX bytes :5175764 (4.19 MIB) TX bytes :517564 ( 4.9 MIB)
 
Old 12-21-2006, 11:12 PM   #6
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Your Ethernet card appears to be a well supported model. Looking at you ifconfig output you only have an inet6 (IPv6) address assigned. Most networks do not yet use IPv6 so this is likely the problem. Are you running DHCP on your network (i.e. can you use "get an address automatically" in Windows and have it work?). If so try just typing "dhclient eth0" and see if you get an IP address. If so you are probably OK.

To make that fix permanently type "nano -w /etc/sysconfig/network-scripts/ifcfg-eth0" (nano is a text editor). When you have the file opened, edit out the IPv6 stuff and add a line saying

BOOTPROTO=dhcp

(delete any other BOOTPROTO lines).
 
Old 12-21-2006, 11:36 PM   #7
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by btmiller
Your Ethernet card appears to be a well supported model. Looking at you ifconfig output you only have an inet6 (IPv6) address assigned. Most networks do not yet use IPv6 so this is likely the problem. Are you running DHCP on your network (i.e. can you use "get an address automatically" in Windows and have it work?). If so try just typing "dhclient eth0" and see if you get an IP address. If so you are probably OK.

To make that fix permanently type "nano -w /etc/sysconfig/network-scripts/ifcfg-eth0" (nano is a text editor). When you have the file opened, edit out the IPv6 stuff and add a line saying

BOOTPROTO=dhcp

(delete any other BOOTPROTO lines).
didnt work my file was already set to dhcp any other fixes for this ?????
 
Old 12-21-2006, 11:44 PM   #8
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
also i tried system-config-network and then i get locale.Error :Unsupported locate setting
 
Old 12-21-2006, 11:50 PM   #9
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Maybe you don't have a DHCP server on your network? Do you have to statically assign your IP? Maybe you could try setting your IP address statically if you're on your own network. It would really help if you gave us some details of your network setup (e.g. are you behind a router or connecting directly, etc.).
 
Old 12-21-2006, 11:52 PM   #10
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by btmiller
Maybe you don't have a DHCP server on your network? Do you have to statically assign your IP? Maybe you could try setting your IP address statically if you're on your own network. It would really help if you gave us some details of your network setup (e.g. are you behind a router or connecting directly, etc.).
no it is by dhcp the cable modem is supposed to make it automatically thats how i do it in windows. just plug in the wire/ repair dns/dchp automatically. so im directly connected to the modem hope that helps ya.

Last edited by n00b_101; 12-21-2006 at 11:54 PM.
 
Old 12-22-2006, 01:51 AM   #11
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,899

Rep: Reputation: 68
Please run the following as root:
Code:
export LC_ALL=C;
export LANG=C;

/sbin/dhclient ;
and post output.
 
Old 12-22-2006, 02:03 AM   #12
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
Just to eliminate one possibility, are you using the ethernet cable or usb cable to connect from your PC to modem? It's recommended to use ethernet, as it doesn't require a driver.
 
Old 12-22-2006, 02:19 AM   #13
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
no it is by dhcp the cable modem is supposed to make it automatically
... if it's anything like mine, then your modem also does nat routing and dhcp ... you can configure it through http (via a web browser).

Now with mine, there is a section where I can decide on the range of IPs that can be assigned by dhcp. If you are lucky, you can get it to assign ipv4 addresses. Give it a go.
 
Old 12-23-2006, 01:34 AM   #14
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by raskin
Please run the following as root:
Code:
export LC_ALL=C;
export LANG=C;

/sbin/dhclient ;
and post output.
i put this in text editor pasted and hit enter and nothing happened.... am i doing this wrong ??????

Last edited by n00b_101; 12-23-2006 at 01:36 AM.
 
Old 12-23-2006, 01:35 AM   #15
n00b_101
LQ Newbie
 
Registered: Dec 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Ynot Irucrem
Just to eliminate one possibility, are you using the ethernet cable or usb cable to connect from your PC to modem? It's recommended to use ethernet, as it doesn't require a driver.
i already use ethernet works on my windows laptop works fine trying the same cable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 cannot get online anymore!? Please help. touser Linux - Networking 1 04-14-2006 09:12 AM
ifup eth0 failed, failed to bring eth0 MKSrivastava Debian 1 12-07-2005 11:35 AM
eth0: [Failed] antiliphe Linux - Networking 1 09-17-2004 06:09 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 06:33 PM
...eth0 [Failed] Nooooobie Linux - Newbie 22 10-21-2001 11:07 PM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration