LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cant get my ATI driver to work on ubuntu 8.10. (http://www.linuxquestions.org/questions/linux-newbie-8/cant-get-my-ati-driver-to-work-on-ubuntu-8-10-a-701633/)

garrydog 02-02-2009 08:36 AM

Cant get my ATI driver to work on ubuntu 8.10.
 
Hi
I hope that someone can help on this forum ,I have downloaded the ATI driver from the ATI website ,and after a lot of trouble I have got it to install onto the computer .
I rebooted the computer normally and I get a black screen with " cannot display this video mode"so I rebooted in recovery mode ,then xfix to get the desktop back.
Can someone please help me to get this driver working so that I may change my screen resolution .

b0uncer 02-02-2009 09:37 AM

Did you check if the driver is supposed to work with your ATI card at all? I found that for example the fglrx driver used to support an oldish Radeon 9200SE (installed it in the past, worked great), but the version available today does not -- it can be installed of course, but using it results in black screen or X failing to start at all.

So either post here the ATI card model you have so others can check if it should work with the current ATI driver (or what driver it's supposed to work with) or find out yourself; another thing that might help is that you should add the distribution of Linux you use to your LQ profile, so others can see it (under your name etc. information to the left of your posts). Installing certain drivers may be done in different ways depending on your flavor of Linux, for example on Ubuntu the Restricted Drivers Manager is a lot easier (and "safer", as it checks if the driver suits your hardware at all) method than the "manual" route if you're installing ATI/nVidia graphics drivers..

garrydog 02-02-2009 11:01 AM

Quote:

Originally Posted by b0uncer (Post 3429183)
Did you check if the driver is supposed to work with your ATI card at all? I found that for example the fglrx driver used to support an oldish Radeon 9200SE (installed it in the past, worked great), but the version available today does not -- it can be installed of course, but using it results in black screen or X failing to start at all.

So either post here the ATI card model you have so others can check if it should work with the current ATI driver (or what driver it's supposed to work with) or find out yourself; another thing that might help is that you should add the distribution of Linux you use to your LQ profile, so others can see it (under your name etc. information to the left of your posts). Installing certain drivers may be done in different ways depending on your flavor of Linux, for example on Ubuntu the Restricted Drivers Manager is a lot easier (and "safer", as it checks if the driver suits your hardware at all) method than the "manual" route if you're installing ATI/nVidia graphics drivers..

Hi I am on ubuntu 8.10 ,my card is an ATI RV610 video device [Radeon HD 2400 PRO].

I have done this once ,I have had the cube on my desktop and the correct resolution,but don't ask me how I did it.I did an update as normal I had to restart so I did ,then the screen went black could not sort it out so I reinstalled ubuntu ,that was a week ago and I am still trying to get it working .going round in circles .


All times are GMT -5. The time now is 11:10 AM.