LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   can't differentiate system language from keyboard language? (http://www.linuxquestions.org/questions/linux-newbie-8/cant-differentiate-system-language-from-keyboard-language-802036/)

lilou_b 04-14-2010 04:47 PM

can't differentiate system language from keyboard language?
 
i recently got a french msi wind U100x running on linux suse enterprise 10 sp1. (i am french and wanted a light netbook with french keyboard)

i am totally new to linux and i believe that msi wind is not helping.

because i am more used to english for settings, i set the main language to english, but it seems that it automatically reconfigures my keyboard mapping to english as well, so that azerty becomes qwerty.
i reset it back to french, so now my keyboard is french, but so is the system.

is there a way to differentiate keyboard from main user setting language? how?

thanks!!

ekj 04-14-2010 05:29 PM

I use openSuse 11.2, but I assume that it's the same.

Anyway, I use a Swedish keyboard layout and have English as system language. It works perfectly for me. During the installation the keyboard layout and the system language were two separate choices, that's where I set it.

I took a look in yast trying to find where to set the default settings, but as you said I only saw one language setting, and that was the primary language (system language I guess).

However, I found a user-specific setting for the keyboard layout. In Configure Desktop (find it in the menu or start it with the command "systemsettings"), click on the "Regional&Language" button, click on "Keyboard Layout". Here you can change the keyboard layout, but it has to be done for all users separately.

There really should be a way to set keyboard layout that isn't user-specific, but I cannot find any at the moment.

lilou_b 04-14-2010 06:09 PM

thanks!!

it was under
- administrator settings
- system
- keyboard layout.

now i have system setting as english and keyboard layout as french, but somehow the screen resolution has changed!

lilou_b 04-14-2010 06:47 PM

reset the correct screen resolution,
and it is now all sorted, merci!


All times are GMT -5. The time now is 01:56 AM.