LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2007, 12:48 AM   #1
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Rep: Reputation: 15
Cant connect to the internet


Hello,
I loaded up Ubuntu Feisty 7.04 and cant connect to the internet.
This post is written on a an other comp so and I don't have a means of getting information from one to the other so I typed it out as I see it.

The internet connection in the upper right hand of my gnome desktop says that I am connected and using driver 8139too.
The cable is good and getting flashing rapid green light (switched with working computer)

I have tried to ping several known web sites but no connection. I read other posts and tried to do the same as recommended but no resolve.
I did get some information that was asked on other posts and oh lucky me I cant get the usb drive to work so I will summerize as best as i can the outputs: /sigh.

After running lspci -v the listing shows my ethernet card. I don't know what the disbled part is?

Code:
00:0a. Ethernet controller: Realtek Semiconductor Co., LTd.
RTL-8139/8139c/8139C+ (rev 10)
Subsystem: Realtek Semiconductor Co., LTd. RT8139
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at e400 (size=256)
Memory at eb000000 (32-bit,non-prefetchable) [size=256}
[virtual] Expansion Rom at 30000000 [disabled] [size=64k]
When I ping www.google.com
Code:
ping: unknown host www.google.com
Code:
ifconfig eth0 up
I get the command line back like it went well?

Results from lsmod |grep 8139

Code:
8139too           27648 0
8139cp            25088 0
mii                6528 2 8139too,8139cp
This is all that I know to do?
 
Old 07-15-2007, 01:58 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Look at the output of "ifconfig eth0"
Code:
/sbin/ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:0F:B0:0C:EF:AB
          inet addr:192.168.1.100  Bcast:192.168.1.127  Mask:255.255.255.128
          inet6 addr: fe80::20f:b0ff:fe0c:efab/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3950697 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2766986 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5515186406 (5259.6 Mb)  TX bytes:208650016 (198.9 Mb)
          Interrupt:185 Base address:0xe800
If you see an IP address, then the device setup is probably OK.

Look at the contents of the /etc/resolv.conf file:
[code]

You should see entries for your ISP's nameserver (DNS) addresses:
Code:
nameserver 24.116.209.232
nameserver 24.116.0.202
nameserver 24.116.212.232
Check the output of /sbin/route:
Code:
/sbin/route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
jesnet          *               255.255.255.128 U     0      0        0 eth0
loopback        *               255.0.0.0       U     0      0        0 lo
default         linksys         0.0.0.0         UG    0      0        0 eth0
Make sure that you have a default route. The gateway entry should be your router's IP address.
If you are using DHCP, then the resolv.conf and default gateway items as well as the IP address of the interface should be configured for you. Otherwise you need to configure these things yourself.

Last edited by jschiwal; 07-15-2007 at 12:19 PM.
 
Old 07-15-2007, 11:47 AM   #3
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Quote:
If you see an IP address, then the device setup is probably OK.
Mine shows:
Code:
inet addr: as 192.168.1.101
Quote:
Look at the contents of the /etc/resolve.conf file:
<< I think that should be /etc/resolv.conf >>
I show a single address
Code:
nameserver 192.168.1.1
Code:
Check the output of /sbin/route:
Here is mine
Code:
/sbin/route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
198.168.1.0     *               255.255.255.128 U     0      0        0 eth0
link-local      *               255.0.0.0       U     1000   0        0 eth0
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
I don't know anything about networking but get the feeling this is not set up correctly?
So now what do I need to do? I have the Ubuntu Bible in front of me .. is there a specific
section I should read up on?
 
Old 07-15-2007, 12:58 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Use your ISP's name server addresses in place of the 192.168.1.1 entry in the /etc/resolv.conf file.
 
Old 07-15-2007, 08:29 PM   #5
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Everything looks fine. As for jschiwal's post, the entry in the /etc/resolv.conf file may have been placed there by DHCP (in which case, there is no need to change it, it will be changed back anyway).

Was this connection ever working? Was this computer connected somewhere else? What are you connecting to (router, wireless router, DSL modem, cable modem, etc.)?

I don't know which DHCP client ships with Ubuntu, but you could try "pump", "dhcpcd -n eth0", or "dhcpclient" (not sure of the options).

If this was working elsewhere, and you moved it, you may need to manually configure your setup (/etc/networking/interfaces, I think. I'm in front of my SuSE box right now, not my Debian one).
 
Old 07-15-2007, 08:42 PM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
You can configure the dhcp client not to overwrite the /etc/resolv.conf file. The OP should at least try to ping an internet address such as Google using the IP address.

ping -c 3 64.233.167.99

If that is successful then the problem most likely is that domain names are not being resolved to IP addresses.
At least editing the /etc/resolv.conf file will allow testing if internet access works.

192.168.1.1 is the router and I doubt that it is also a nameserver. If DHCP is being used, which I don't know if it is, the DHCP server should be supplying the addresses of the ISP's nameservers and not the address of the DHCP server.

Last edited by jschiwal; 07-15-2007 at 08:55 PM.
 
Old 07-15-2007, 10:12 PM   #7
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Quote:
Use your ISP's name server addresses in place of the 192.168.1.1 entry in the /etc/resolv.conf
I didn't know what my ISP nave server address was so I looked at my other machine and copied those numbers
into the resolve file.. it was overwritten at reboot
I tried this but no good
Code:
ping -c 3 64.233.167.99
Destination Net unreachable
Quote:
Was this connection ever working?
This connection works fine on my other two comps
Quote:
Was this computer connected somewhere else?
This computer was running "windows" and
I wiped the hard drive to load Ubuntu. The internet worked fine with windows. This is a fresh install of Ubuntu.
Quote:
What are you connecting to (router, wireless router, DSL modem, cable modem, etc.)?
I am using a Linksys router with cable ISP

Quote:
I don't know which DHCP client ships with Ubuntu, but you could try "pump", "dhcpcd -n eth0", or "dhcpclient" (not sure of the options).
I have been using Fedora 5 (I really like it) but I have been begging friends to migrate to Linux for years and so I have three that I am helping to make the Linux move. For some reason "advertising or what ever" they heard and wanted Ubuntu so I converted this machine over so I could understand how Ubuntu works vs Fedora 5. I have loaded Ubuntu on an other machine and the internet works just fine.

Quote:
If this was working elsewhere, and you moved it, you may need to manually configure your setup (/etc/networking/interfaces, I think. I'm in front of my SuSE box right now, not my Debian one
The network program provided by Ubuntu is pretty Straight forward (i think) and shows that this is set up as a DHCP machine.. just like the others. From what i have read on the internet my network card should be vanilla plain 8139 protocol requiring nothing special. The only difference that I have noted is that his card is a PCI card and not build in to the mother board like the working Ubuntu machine. This should not make any difference?

I am sure this is something really simple.. my experience has been to discover the obious. I am baffeled here.

I really appreciate your help.. anymore Ideas?
 
Old 07-16-2007, 02:03 AM   #8
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Can you ping the gateway address (192.168.1.1)?
 
Old 07-16-2007, 06:26 AM   #9
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Quote:
Can you ping the gateway address (192.168.1.1)?
Yes it pings just fine
 
Old 07-16-2007, 07:17 AM   #10
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
More info:
After seeing that I was able to ping the router It is now obvious that the router was blocking me. Therefore I bypassed the router and connected directly to the cable modem and it is working just fine. In fact I am on this machine now..

The question remains.. why is the router blocking this machine and not the others? In the process of rerouting directly to the cable modem I reset the modem by unplugging it for 20 seconds. I did that to the router once before but not the cable modem. Any clue there?
it is a 4 port router. Is there something in the router that needs to be adjusted? when I was connected to it before I had all the Leds doing there blinking thing like the ones next to it?

Gray
 
Old 07-16-2007, 07:32 AM   #11
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
The router may have a web based interface. It could be filtering you by MAC address. Another possibility is if you have a router that has a non-crossover port one one of the outputs. It may share that output with another port and you can't connect both. Earlier Linksys routers had that.

Make sure that that router port isn't configured in the DMZ.

If you are not configured to use DHCP, then make sure that you choose an IP address that is below the starting DHCP IP range. Linksys will start assigning IP's at 192.168.1.100. So pick an IP between 192.168.1.2-99.
 
Old 07-16-2007, 08:58 AM   #12
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
I will look into that. The router is about 6 years old and I set it up as a DHCP but that was ages ago. Also I remember blocking a ton of ports so I need to go into it and see what is open.
It is a Windows OP system based router so I need to use wine to edit it(I think).
 
Old 07-16-2007, 10:37 AM   #13
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
It may have a web interface at 192.168.1.1.

A Linksys router that I had had an extra port that was meant to connect to another router. However, if you used it, you couldn't use the one just to the left of it. If your router auto negotiates straight through connections, this probably isn't the case.
 
Old 07-16-2007, 11:33 PM   #14
edooze
Member
 
Registered: Jul 2006
Location: Brisbane, Australia.
Distribution: KUbuntu 11.04
Posts: 30

Rep: Reputation: 1
Hi

Just a quick suggestion, make sure you have IPv6 disabled. I had the same trouble with my (FC5) machine until I disabled IPv6 traffic. Apparently the router was too old to understand what on earth IPv6 was.

Hope this helps!
edooze.
 
Old 07-18-2007, 09:37 PM   #15
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Well some how I got my internet connection. I am still not sure why I was not able to before but I ended up pushing the reset button on both my router and the cable modem.

I was pleased to find that I could connect directly to the router via Firefox at:
Quote:
It may have a web interface at 192.168.1.1.
but I needed the "/" at the end of 192.168.1.1.
I was able to re-configure my router.
Quote:
A Linksys router that I had had an extra port that was meant to connect to another router. However, if you used it, you couldn't use the one just to the left of it. If your router auto negotiates straight through connections, this probably isn't the case.
U know you made a very good point and I thought that maybe I had plugged into this port
(it would be very easy to do), but I was using the cable pulled directly out from the back of working computers.

In summary I really don't know what the problem was but I can say that all your advice and help was crucial in helping me figure out what it wasn't and I learned more about my internet connections because of it..

Thank you very much

Gray
 
  


Reply

Tags
internetconnection


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Not Connect Internet zecster SUSE / openSUSE 6 03-20-2006 08:52 AM
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 07:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM


All times are GMT -5. The time now is 10:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration