LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't change keyboard layout in Ubuntu 8.04 login screen (http://www.linuxquestions.org/questions/linux-newbie-8/cant-change-keyboard-layout-in-ubuntu-8-04-login-screen-637811/)

Anonymous1993 04-25-2008 12:20 PM

Can't change keyboard layout in Ubuntu 8.04 login screen
 
I have just upgraded from Gutsy to Hardy and before I could login I ran onto a problem, please help. Not so long ago,I thought I will never have to boot XP again, but I was wrong. My default keyboard layout in Gutsy was
Serbian(Latin), but I also had Serbian(Cyrillic) as my secondary layout.
These letters are quite different, so I can't type my username and password in the login screen, because since the upgrade the default layout is switched to Serbian(Cyrillic) and I can type my username and password correctly only if a Latin keyboard layout is configured(this includes English, German, etc.) Since I can't do it from the login screen( or so I think), is there any other alternative to it?
Thank you.
P.S. Sorry for bad English.

Simon Bridge 04-26-2008 05:20 AM

The login screen uses a different configuration script to the main part. To change the keyboard layout it uses you have to edit the configuration file. (I had the same issue changing to dvorak).

To get the gdm login screen to recognise the your layout,

sudo gedit /etc/default/console-setup

... add the XKBVARIANT="$your-layout"
in the correct place. (eg. see mine below.)
Code:

# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.
XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT="dvorak"
XKBOPTIONS="lv3:ralt_switch"

You'll need to put the sr_CS in the right place.

Note - I have been harassing native English speakers for months about writing decent English. Yours is perfect. (i.e. your English is better than most natives.) Relax.

refs:
http://www.ibiblio.org/pub/Linux/doc.../Serbian-HOWTO
... an old serbian howto - I did not see the login config in there - but it does give a good overview as to how locales work.

Anonymous1993 04-26-2008 06:44 AM

The problem is that I can't even login with Serbian(Cyrillic) keyboard set as default in GDM. Anyway, thanks for the advice, both for the layout and English.

Simon Bridge 04-26-2008 08:31 AM

Yes - you will have to edit the file from a live session.


All times are GMT -5. The time now is 07:21 PM.