LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can't boot Wary Puppy Linux anymore, login: root (automatic login) (http://www.linuxquestions.org/questions/linux-newbie-8/cant-boot-wary-puppy-linux-anymore-login-root-automatic-login-4175427445/)

theADOLESCENT 09-15-2012 07:56 PM

Can't boot Wary Puppy Linux anymore, login: root (automatic login)
 
Hey guys, I had Wary Puppy 5.2.2 working and I used Gparter to give my drive a "boot flag" because I thought that would load up Wary Puppy right away instead of loading what I think is the grub loader.

Now I'm on a screen that says:

Wary Puppy Linux
Linux 2.6.32-uni [i686 arch]

puppypc10613 login: root (automatic login)
#

I can type stuff in now but I have no idea how to get back to the normal Wary Puppy Linux and taking that bootflag off.

Any help is appreciated.

By the way I have Wary Puppy linux on a full install, XP shouldn't be on the system anymore ( I know people say don't do this but it's what I did).

Thanks again.
-theadolescent

EDDY1 09-15-2012 08:05 PM

What Desktop environment gnome3? If so
Quote:

startgdmd
or
Quote:

startx

theADOLESCENT 09-15-2012 08:17 PM

Thanks, I typed that in, and it says
Starting X, specs in /etx/X11/xorg.conf, startup apps /root/.xinitrc...
Exited from X. Type "xwin [fvwm95:jwm]" to restart X ([ ] mean optional).
(To shutdown PC type "poweroff", to reboot PC type "reboot")
If X failed to start, type "xorgwizard" to set up x.

I tried xorgwizard, put in necessary information. Then I get

If X did not work, type "xorgwizard" to run video wizard again.
After that, type "xwin" to run X graphics mode.
Note, if X works but need sminor adjustment to the display, run the
Video Wizard from within X (in the Setup menu) -- module "xvidtune"
may be used, with caution, to finetune the display dimensions.

I type in xwin, then I get

Starting X, specs in /etx/X11/xorg.conf, startup apps /root/.xinitrc...
Exited from X. Type "xwin [fvwm95:jwm]" to restart X ([ ] mean optional).
(To shutdown PC type "poweroff", to reboot PC type "reboot")
If X failed to start, type "xorgwizard" to set up x.

again

EDDY1 09-15-2012 10:05 PM

What Desktop environment gnome3?

theADOLESCENT 09-15-2012 10:12 PM

startgdmd did not work, startx is what got it to attempt to start

EDDY1 09-16-2012 01:00 AM

Quote:

Originally Posted by theADOLESCENT (Post 4781352)
startgdmd did not work, startx is what got it to attempt to start

My
bad typo if you have gnome3 & gdm it would be startgdm3

theADOLESCENT 09-16-2012 08:53 AM

Oh, okay.

startgdm3 doesn't work either.

EDDY1 09-16-2012 08:57 AM

What Desktop environment?

theADOLESCENT 09-16-2012 12:38 PM

I'm not sure. It's Wary Puppy Linux 5.2.2

EDDY1 09-16-2012 07:13 PM

Ijust downloaded puppy it uses jwm atleast wary does unless you changed it.
Try
Quote:

jwm -restart
Also have you tried changing boot flag back to the other partition?


All times are GMT -5. The time now is 03:03 AM.