LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-03-2005, 09:51 AM   #1
supersucker
Member
 
Registered: Jul 2004
Location: Berlin
Distribution: fedora 3
Posts: 79

Rep: Reputation: 15
canon printer prints in miniature font


hi everybody,

i have the following problem, which drives me mad:

i print with a canon ip 2000 (OS: Fedora Core 3), printing itself works, but everything gets printed in a tiny font.
this means all formattings e.g. font style are printed out correctly, but so small that only half
of the paper is filled.

to clarify that:

if i have an openoffice-doc which extends over exaclty one side on the screen and i print it out the font gets that small that the lower half of the paper is empty and there is a margin of 6 or 7 cms on the right side.
i have the same problem with printing from all editors (emacs, nedit etc) so it isnt an openoffice configuration problem.

here is my printer configuration:

there are 5 tabs:

1. qeue name:


name=ip2000-2


ok, printer recognized....

2. Qeue type:


Qeue type: locally connected

/dev/usb/lp0 Custom device



3. Qeue Options:

Imageable area:

top margin(pt) = 0 right margin=0
left margin = 0 bottom margin = 0

cpi = 12 (characters per inch
lpi = 12 (lines per inch)
page-bottom=86
page-left=57
page-right=57
page-top=72
scaling=100
wrap=true


4. printer driver:


printer manufactorer and model = bjc-2000
driver=gimp-print-ijs (this is the recommended driver)




5. driver options:

Send-Form-Feed : nein
Send End-of-Transmission : nein
Assume unknown data is text : nein
prerender postscript : nein
convert text to postscript : nein

Effective Filter Locale : C
Printer Model : Canon BJC 2000
page size : A4
input slot : auto sheet feeder
quality: 360 x 360 dpi
printout mode : normal


has anybody an idea what i can do to solve this?

thx in advance.........
 
Old 10-03-2005, 05:48 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
ohhh i have one of those printers
access cups with
http://localhost:631/admin
set the driver to
CANON BJC 2000 - CUPS+Gimp-Print

see if that helps
can't remember if there were any more tricks to it
 
Old 10-04-2005, 10:13 AM   #3
supersucker
Member
 
Registered: Jul 2004
Location: Berlin
Distribution: fedora 3
Posts: 79

Original Poster
Rep: Reputation: 15
my driver is already set to

CANON BJC 2000 - CUPS+Gimp-Print

my driver configuration says:

printer manufactorer and model = bjc-2000
driver=gimp-print-ijs (this is the recommended driver)

that is what you meant, isnt it?

any other ideas?

thx in advance
 
Old 10-04-2005, 10:13 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
no -- i don't know that much about it
i have set the printer up a couple of times from scratch now but i can't really say exactly how i do it
i don't use a distribution and i have no idea where you are getting those stats from so i can't compare.

Basically i mean DON'T use the GhostScript IJS plug-in.
That is a way to use gimp-print as a ghostscript driver and that is not what you want and most likely why you are getting the odd results.

i choose exactly what i put there from the list in the CUPS settup page
CANON BJC 2000 - CUPS+Gimp-Print <plus it has a version number i think after it>

no IJS
 
Old 10-05-2005, 10:11 AM   #5
supersucker
Member
 
Registered: Jul 2004
Location: Berlin
Distribution: fedora 3
Posts: 79

Original Poster
Rep: Reputation: 15
hi,

if i look at my printing configuration, i can only select 3 drivers:

1. bjc-600
2. gimp-print-ijs
3. omni-compiled

how do i use the gimp-print driver without the ijs plugin?
do i have to install a separate driver ?

i am absolutely clueless, please help!

thx in advance..........
 
Old 10-06-2005, 10:51 AM   #6
supersucker
Member
 
Registered: Jul 2004
Location: Berlin
Distribution: fedora 3
Posts: 79

Original Poster
Rep: Reputation: 15
ok,

now i have downloaded and installed gimp-print-4.2.7 successfully.

it appears in the list of possible drivers, but if i select the driver and save the configuration
my printer doesnt print anymore....:-((((

if i look at http://localhost:631 at the "jobs" -section i see that every job which i started with the new
driver has been aborted, if i now click on "restart job" i get the error message:

client-error-not-possible

can anybody help me fix this problem? what could be wrong?

thx in advance......
 
Old 10-07-2005, 10:47 AM   #7
supersucker
Member
 
Registered: Jul 2004
Location: Berlin
Distribution: fedora 3
Posts: 79

Original Poster
Rep: Reputation: 15
or should i maybe install another driver?

are there any other standard driver except gimp-print which could work?

thx
 
Old 10-07-2005, 08:27 PM   #8
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
the printing system is so complicated so bear with me and i'm sure we can find the solution
i think whats happening now is no ghostscript installed.

check ghostscript with the command
gs
this should open a useless window and return a prompt
GS>
at that prompt type
devicenames ==
should return a bunch of devices
if this stuff doesn't work install
ESP Ghostscript
ESP Ghostscript converts PostScript data to raster images for interpretation by gimp print

keep postig back if that's not it
 
Old 10-09-2005, 10:44 AM   #9
supersucker
Member
 
Registered: Jul 2004
Location: Berlin
Distribution: fedora 3
Posts: 79

Original Poster
Rep: Reputation: 15
hi,

thx for the help!


you wrote:


check ghostscript with the command
gs
this should open a useless window and return a prompt
GS>
at that prompt type
devicenames ==
should return a bunch of devices


i did that and everything happened as you described it, except for that there is no window opened when i type

gs

but a GS prompt is opened.

any more ideas?

thx for any help!
 
Old 10-09-2005, 11:20 AM   #10
supersucker
Member
 
Registered: Jul 2004
Location: Berlin
Distribution: fedora 3
Posts: 79

Original Poster
Rep: Reputation: 15
ah,

i forgot to mention that a

>> yum search ghostscript

shows

>>ghostscript.i386 7.07-33 installed

so this shouldnt be a ghostscript - problem.......

damn, i cant believe that it is that difficult to get my printer working properly under linux........

please help.......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Canon prints SLOWLY, parallel:/dev/unknown-parallel0 netcrawl Linux - Hardware 5 03-26-2005 09:13 PM
Mozilla prints in a wierd font jimsproch Linux - Software 1 12-18-2004 12:32 PM
Canon BJC 210 SP prints gibberish!! blaze_wk Linux - Hardware 1 02-25-2004 03:02 AM
Samba printer help(can see and have access to printer but nothign prints out) rmanocha Linux - Networking 1 11-05-2003 07:54 AM
I have a Canon BJC 2100 printer and it prints slowlyyyyy. Please help petru_b16 Linux - Hardware 1 09-01-2003 11:56 PM


All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration