LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 06-09-2012, 11:50 PM   #1
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Rep: Reputation: Disabled
Cannot yum install mgp123 with missing libltdl.so.3


Salvete! I want to install mpg123 on my new CentOS 6.2 installation, but I get a package resolution dependency error:

Requires: libltdl.so.3()(64bit)

Now, I have libtool 2.2.6 installed, as well as the runtime libraries, libtool-ltdl.x86_64.

I tried putting a copy of libltdl.so.3 in /lib and also in /lib64 and also in /usr/lib/ and also in user/lib64, but it didn't help.

How can I resolve the dependency? I already ran yum update, but it didn't accomplish what I want to do. Please help!

(there is no tag for CentOS6, by the way... and I can't create tags)
 
Old 06-10-2012, 12:41 AM   #2
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian jessie/sid; OpenSuSE; Fedora
Posts: 1,593

Rep: Reputation: 162Reputation: 162
do this:

$ locate libltdl | grep lib

observe the path,

$ ls -al /path/libltdl*

find the libltdl file that is NOT a symlink (doesn't point to another file).

then do:

$ ln -s /path/libltdl.so.3.45.672 /path/libltdl.so.3

That method is a cure-all for everything!
 
Old 06-10-2012, 08:12 PM   #3
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Thanks for helping me out! I see now that I have /usr/lib64/libltdl.so.7.
That must mean that mpg123 wants an older version of libtool, right?

I downloaded the 3.1.4 package from this page, and was able to put libltdl.3.1.4 into /usr/lib64, but if I try to put the accompanying pointer (?) file, libltdl.3 into that folder, it says the file already exists - even though I don't see it (not even hidden) in the directory.

So then I saw that yum only retrieved mpg123 version 1.3, so I downloaded mpg123 version 1.9 from here, but that mpg123 package still seems to require libltdl.3!

Hmmm... Can I have both versions at the same time?

What do I do now?
I need mpg123 so that I can play mp3 files with Asterisk. The "Definitive Guide" for Asterisk 1.8 says to use mpg123.

Last edited by brother.gabriel; 06-10-2012 at 08:27 PM.
 
Old 06-10-2012, 08:53 PM   #4
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Okay! I think I got it.

I downloaded mpg123-1.13.6-17.el6.x86_64.rpm from http://pkgs.org/centos-6-rhel-6/atrp...86_64.rpm.html and it didn't give me the libltdl dependency. Instead, it gave me two others:

jack-audio-connection-kit-0.116.1-6_1.el6.x86_64.rpm which required libfreebob-1.0.11-6.el6.x86_64.rpm
nas-libs-1.9.2-1.el6.x86_64.rpm

After all of that, it worked! And what's better, the files are all from the rhel6 resource.

Anybody dealing with CentOS 6, make sure to visit this page: http://pkgs.org/
 
  


Reply

Tags
centos, libtool, mpg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing php_gd2.dll (I tried yum install php-gd) auftbl Linux - Software 7 10-14-2010 11:56 PM
Missing Dependecy:libartsc.so.0 while install mplayer using yum karthickk02 Linux - Newbie 15 10-01-2010 05:37 AM
yum install PackageKit .............libchewing missing dependency yukapuka Fedora 1 02-17-2009 03:55 AM
yum install kino - Missing Dependency: libavutil.so schlough Linux - Software 5 01-13-2006 10:07 PM
Missing Dependencies during Yum Install? keysorsoze Fedora 4 01-17-2005 01:01 AM


All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration