LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-20-2003, 01:57 PM   #1
garsch
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Cannot start Gnome after Suse 8.2 install


I just installed Suse 8.2 and cannot get the Gnome environment running. I tried startx gnome2 from the command line and get the following:

Fatal server error:
Server is already active for disply 0
If this server is no longer running, remove /tmp/.X0-lock
and start again

What can I do to include the Gnome environment integrated and available at the login prompt?

TIA,
Garsch
 
Old 09-20-2003, 02:20 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Are you trying to run gnome from another X server? You cannot run 2 xservers at once. Check those 2 files located at your /etc/X11/xinit

Xclients
xinitrc

Depending how you login (graphical or text mode) you need to edit one or another. I edited Xclients because I use text login.
Check to see if you find PREFERRED=gnome-section as first choice there and it should do the trick . If you login in graphical env. I think (I'm not sure) you'd to add exec gnome-section at the end of xinitrc

Good luck!

P.S: there are easiers ways to do this, but I cannot remember. However, it should still work
 
Old 09-20-2003, 03:58 PM   #3
garsch
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Since I am using the graphical env. I edited the xinitrc file. Thanks for the help!
 
Old 09-20-2003, 04:44 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Cool I'm glad it helped
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto Install GNOME in SUSE 9.1 pins SUSE / openSUSE 1 07-19-2005 10:31 AM
SUSE 9.1: KDE or GNOME start only as root blish_blash Linux - General 4 09-18-2004 10:35 AM
SuSE 9.1 and gnome install problems GoSTaRnE Linux - Newbie 1 06-20-2004 11:50 PM
How do I install Gnome in suse cbhomeseller Linux - Newbie 3 02-25-2004 10:19 PM
Install of Metacity theme causes GNOME 2.2 to hang at start-up and errors with Gaim SDSkyle Linux - Software 2 08-23-2003 10:58 PM


All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration