LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-26-2008, 01:58 AM   #1
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Rep: Reputation: 15
Cannot setup bridge br0 without cutting all internet.


Feel free to move to Software if applicable, but I'm pretty sure I'm missing something stupid simple here.

I installed Windows on VirtualBox (Ubuntu 8.04 host), and I'm trying to add a bridge so windows can use internet.

Here is my working /etc/network/interfaces file:
Quote:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The Primary network interface
auto eth0
iface eth0 inet static

address 192.168.1.100
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
I try adding
Quote:
auto br0
iface br0 inet dhcp
bridge_ports eth0
I've added it above and below the loopback stanza.


I then type
Quote:
/etc/init.d/networking restart
and I the readout says it waits for br0 to get ready, maxwait is 32
I count to 32, and it waits that long to continue, so I assume it doesn't work at that point.

Afterwards apache, proftpd, ping, and firefox dont have internet connection (so no connection period).

What am I doing wrong? Is it because eth0 is static and br0 isn't setup that way?

Thanks
-SS
 
Old 05-26-2008, 07:29 PM   #2
rtspitz
Member
 
Registered: Jan 2005
Location: germany
Distribution: suse, opensuse, debian, others for testing
Posts: 307

Rep: Reputation: 32
if you want to bridge the virtualbox host interfaces to your local lan, eth0 must _NOT_ have an ip address !

bridge0 will "replace" eth0 with all the ip settings and eth0 will run without any ip address assigned, just like the host interface created for virtualbox.
 
Old 05-26-2008, 08:52 PM   #3
SimbaSpirit
Member
 
Registered: Feb 2008
Posts: 109

Original Poster
Rep: Reputation: 15
Ok well I have to have a static IP for my box, since its a server. How would I go about reserving a new static IP just for the bridge? Just add the same stanza below br0 and remove it from eth0?

Last edited by SimbaSpirit; 05-26-2008 at 08:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bridging interfaces (eth0 + eth1 = br0) Mithrilhall Linux - Networking 1 10-27-2007 05:35 AM
Network Bridge Setup Issue PsychoGTI Linux - Networking 1 07-24-2007 08:28 PM
br0 with ath0 and eth0 not working on ixp vinodl Debian 0 09-16-2006 06:37 AM
bridge enabled, no internet filipanu Linux - Networking 5 01-04-2005 03:18 AM
Internet, routing and bridge Gorchi Linux - Networking 3 03-01-2003 09:29 PM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration