LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2013, 03:24 AM   #1
xeechou
Member
 
Registered: Jun 2013
Location: China
Distribution: Archlinux
Posts: 67

Rep: Reputation: Disabled
Cannot play sound under DE


Hey guys, I got this sound issue on archlinux.I have this problem for a long time and I really dont know why.
I will display my situation really carefully:
1:I have installed alsa-utils.
2: I can invoke alsamixer under tty(any user).
3: root can invoke alsamixer under a desktop environment and this super user can play sound without any pressure.
4: a normal user, however, can invoke alsamixer under tty but not under a DE, no sound output either.
the output is :
Code:
alsa cannot open mixer: no such file or directory
In addition:
I have tried several desktop, wm, such as kde xfce and awesome. I got same result.
some guys say that I need to add user to audio group, but it didnt work. As arch wiki says, local user needn't added into audio group.

Can anybody help me on this? Really apreciate for your help
 
Old 09-10-2013, 04:56 AM   #2
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Rep: Reputation: 103Reputation: 103
Lightbulb

Are you a member of the 'audio' group ? Sounds like a permission issue.
 
Old 09-10-2013, 07:03 AM   #3
xeechou
Member
 
Registered: Jun 2013
Location: China
Distribution: Archlinux
Posts: 67

Original Poster
Rep: Reputation: Disabled
Question Re:jv2112

Quote:
Originally Posted by jv2112 View Post
Are you a member of the 'audio' group ? Sounds like a permission issue.
I hope it is a permission problem, I just added myusr in audio group by
Code:
gpasswd -a myusr audio
Do I need to do reboot or do something else?
Appreciate your help.
 
Old 09-12-2013, 04:06 AM   #4
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Rep: Reputation: 103Reputation: 103
I don't believe so but it couldn't hurt.
 
Old 09-12-2013, 07:19 AM   #5
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,748
Blog Entries: 11

Rep: Reputation: 233Reputation: 233Reputation: 233
Groups are provided at login. So changes to the groups of a logged in user don't take immediate effect. Also no need for reboot, just logout and back in again.
 
  


Reply

Tags
alsa-utils


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No surround sound, mic not working, XMMS wont play (others give sound) Virtuality Linux - Hardware 2 03-26-2012 07:26 PM
Isnt it xmms crappy to play sound, like detecting sound cards. Others are all better frenchn00b Linux - General 2 02-11-2008 06:51 PM
I can't hear any sound when I play a cd or mp3...but tested with system tools->Sound Niceman2005 Linux - General 6 10-31-2005 09:51 AM
FC2: Sound Card (SiS SI7012) Detect But Donot Play Sound rajanaeem Linux - Hardware 0 10-22-2004 03:41 PM
Problems getting sound to play under Mandrake w/2 sound cards HGeneAnthony Linux - Hardware 1 07-02-2004 02:19 PM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration