LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2009, 01:48 AM   #1
Lord Xeb
Member
 
Registered: Nov 2008
Location: Ohio, USA
Distribution: Ubuntu 8.10 (I always update)
Posts: 34

Rep: Reputation: 15
cannot obtain lock on /media/.mtab


I used this command I found earlier to get some info for you guys, here is what I got:
~$ sudo hald --daemon=no --verbose=yes --use-syslog
Runner started - allowed paths are '/usr/lib/hal:/usr/lib/hal/scripts:/usr/bin'

** (process:4755): WARNING **: Failed to add monitor on '/etc/hal/fdi/policy/20-ntfs-config-read-policy.fdi': No such file or directory
Error binding udev_event socket: Address already in use




/etc/hal/fdi/policy/20-ntfs-config-read-policy.fdi


http://i117.photobucket.com/albums/o...mega/error.png

here is another error I am getting
PLEASE HELP ME! I am afraid to reboot.
 
Old 01-03-2009, 02:04 AM   #2
Lord Xeb
Member
 
Registered: Nov 2008
Location: Ohio, USA
Distribution: Ubuntu 8.10 (I always update)
Posts: 34

Original Poster
Rep: Reputation: 15
Fixed. I went and ran:

sudo dbus-daemon --system



And it said to delete /var/run/dbus/pid

I did, then ran it again, it gave me no errors.

Next I ran the following:

sudo dpkg-reconfigure hal


Afterward, I rebooted, and fixed. I can now access my USB drives again and have no problem mounting anything.
 
Old 01-03-2009, 05:41 AM   #3
scottwest2
Member
 
Registered: Jun 2003
Distribution: Mac OS X 10.5.7, Athlon 64 X2 4200+, 2GB Ram, nVidia GeForce 9400 GT 1GB --- Ubuntu 9.04 Jaunty x64
Posts: 58

Rep: Reputation: 16
Nice Job Man! I saw this earlier and unfortunately didn't have time to respond. I'm glad you figured it out.
 
Old 01-04-2009, 10:33 PM   #4
Lord Xeb
Member
 
Registered: Nov 2008
Location: Ohio, USA
Distribution: Ubuntu 8.10 (I always update)
Posts: 34

Original Poster
Rep: Reputation: 15
I found those commands on launchpad. Here is the link I looked at: https://bugs.launchpad.net/ubuntu/+s...nit/+bug/85424
 
Old 10-11-2010, 03:54 AM   #5
sent222
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Rep: Reputation: 0
sudo dpkg-reconfigure hal

when i run the above command in my fedora 10, i got the following error

sudo: dpkg-reconfigure: command not found

how to proceed?

Last edited by sent222; 10-12-2010 at 01:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable) phreakshew Linux - Newbie 17 07-12-2016 03:50 AM
/media/.hal-mtab and /media/.hal-mtab-lock SlowCoder Linux - General 2 05-13-2008 05:17 PM
Cannot open /media/.hal-mtab STARHARVEST Slackware 3 03-03-2008 11:02 PM
automount[10761]: failed to mount /media/.hal-mtab kevkim55 Linux - General 0 06-23-2007 01:29 PM
FC4 install hang, unable to obtain lock n0xvb Fedora 3 07-11-2005 05:32 AM


All times are GMT -5. The time now is 06:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration