LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-08-2012, 03:11 PM   #1
alankenyon55
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Rep: Reputation: Disabled
Cannot mount remote filesystem. Error "Unable to find suitable address"


I have a Linux box, running Fedora 16 and am trying to mount the C: drive from my Win XP box. I seem to have done everything by the book, but have obviously missed something. I have run out of ideas.

My Linux and XP boxes are connected to my home router, and can ping each other OK.
I have made my C: drive sharable.

I used the following command (and variations on it):

# mount -t cifs -o user=root,password=<mypassword>,rw //192.168.2.1/C /mnt/Windows-C

and the error I get is: "Unable to find suitable address."

I have this entry in my /etc/fstab:
//192.168.2.1/C /mnt/Windows-C cifs -o rw,guest,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0

What services should I be checking for? What else can I try?

Any help would be much appreciated. Thanks in advance.
 
Old 01-08-2012, 03:17 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

Hi alankenyon55

The command should read as follows:

Code:
mount -t cifs //192.168.2.1/C /mnt/Windows-C -o user=name_of_windows_user_account
Where :

//192.168.2.1/C is the remote share. Remember I am assuming that you have shared C drive with the share name C. If you have shared it with some other name then use that name.

/mnt/Windows-C is your local linux mount point

-o user=name of the windows user account. The user account that is there on your Windows XP box which has right to access C drive.

When you will hit enter it will ask you for the password for the windows user account. Enter the password and it should work. I hope your Fedora system is configured to be part of the same workgroup as that of your Windows system. If not then please paste the smb.conf file of your Fedora system here in this thread.
 
1 members found this post helpful.
Old 01-08-2012, 03:34 PM   #3
alankenyon55
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Thanks for the quick reply.

I wasn't sure about the user/password. I had actually started with the Windows user/psw but with the same results.

I have checked the XP workgroup, which is "WORKGROUP". Here is a cutdown copy of my smb.conf.

#======================= Global Settings =====================================

[global]
workgroup = WORKGROUP
server string = Samba Server Version %v

; netbios name = MYSERVER

interfaces = lo eth0 192.168.2.1/24 192.168.13.2/24
hosts allow = 127. 192.168.2.

#============================ Share Definitions ==============================

[homes]
comment = Home Directories
browseable = no
writable = yes
; valid users = %S
; valid users = MYDOMAIN\%S

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
; guest ok = no
; writable = No
printable = yes
[home]
comment = Fedora-home
path = /home
; read only = yes
; browseable = yes
guest ok = yes

[samba-writable]
comment = for updating remotely
path = /home/alan/samba-writable
read only = no
browseable = no
guest ok = yes
 
Old 01-08-2012, 03:41 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

You're welcome.

Did you try the command that I mentioned. If yes, what was the result?

If it failed then try the same command again and paste the output of the following command:

Code:
tail /var/log/messages
Paste any error message that you see on your terminal after typing the command.
 
Old 01-10-2012, 04:11 PM   #5
alankenyon55
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Yes, I tried that command.
[root@fedora-1 ~]# mount -t cifs //192.168.2.1/C /mnt/Windows-C -o user=owner

messages log tail as follows:

[root@fedora-1 ~]# tail /var/log/messages
Jan 10 20:52:44 fedora-1 systemd[1]: Failed to read PID file /run/sm-client.pid after start. The service might be broken.
Jan 10 20:52:44 fedora-1 systemd[1]: Startup finished in 1s 463ms 945us (kernel) + 2s 548ms 947us (initrd) + 2min 17s 227ms 892us (userspace) = 2min 21s 240ms 784us.
Jan 10 20:53:27 fedora-1 chronyd[841]: Selected source 80.92.126.65
Jan 10 20:56:22 fedora-1 kernel: [ 358.690185] TCP lp registered
Jan 10 20:57:13 fedora-1 kernel: [ 410.415053] CIFS VFS: Error connecting to socket. Aborting operation
Jan 10 20:57:13 fedora-1 kernel: [ 410.415123] CIFS VFS: cifs_mount failed w/return code = -111
Jan 10 20:59:56 fedora-1 chronyd[841]: Selected source 91.148.192.49
Jan 10 21:01:01 fedora-1 systemd-logind[814]: New user root logged in.
Jan 10 21:01:01 fedora-1 systemd-logind[814]: New session 3 of user root.
Jan 10 21:01:01 fedora-1 systemd-logind[814]: Removed session 3.
[root@fedora-1 ~]#

This doesn't mean much to me, and I couldn't find any reference to code= -111 in a google search.


Alan.
 
Old 01-10-2012, 05:04 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply



IGNORE THIS POST

Are you sure your smb and nmb services are running. Check the status using the following command:

Code:
service smb status
and

Code:
service nmb status
If they are showing as stopped then start both of them using the following command:

Code:
service smb start
and

Code:
service nmb start
I would also like to know selinux status. Check your selinux status using the following command:

Code:
sestatus
If sestatus output show as enabled and running in targeted mode then run the following command to check the booleans:

Code:
getsebool -a | egrep '(smb)|(nmb)|(winbind)|(samba)'
and look for the following booleans:

samba_export_all_ro --> off
samba_export_all_rw --> off

If they show as off then turn them on using the following command:

Code:
setsebool -P samba_export_all_ro on
setsebool -P samba_export_all_rw on
Give the above command sometime to execute do not cancel them using ctrl+z because setting up booleans on/off take sometime.

Once done restart smb and nmb service once again and then give it a try.

Last edited by T3RM1NVT0R; 01-11-2012 at 01:01 AM.
 
Old 01-10-2012, 07:35 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,173

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
FYI The server i.e. smbd and nmbd are independent of the client i.e. smbmount which is called by mount when using the cifs filesystem type.

In addition are you sure 192.168.2.1 is the correct IP address for your windows computer?

The console command smbtree will find all computers running SMB on your LAN and display their shares.
 
1 members found this post helpful.
Old 01-11-2012, 12:59 AM   #8
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

@ alankenyon55

Please ignore the stuff posted in my previous post. After posting I realized you are mounting via Windows server. Sorry was posting in another thread at the same time and thought you to be using samba on a linux server.

As this you have got shared configured on Windows machine you do not require to check selinux boolean stuff. This stuff is required when you are hosting samba share on a linux machine.

However, as michaelk said we need to check if 192.168.2.1 is the IP address of your Widnows machine. Check if you are able to telnet Windows machine from linux machine on port 139 or not. Run the smbtree command as suggested my michaelk.

Another thing that you could try is specifying the workgroup in the mount command. The reason I am saying because it is required with some distributions like SuSE.
 
Old 01-14-2012, 01:30 PM   #9
alankenyon55
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
The IP address certainly was 192.168.2.1, but today it is 192.168.2.3!

smb and nmb services were not running. Now smb is running, but nmb will not start:

[root@fedora-1 ~]# service nmb start
Redirecting to /bin/systemctl start nmb.service

[root@fedora-1 ~]# service nmb status
Redirecting to /bin/systemctl status nmb.service
nmb.service - Samba NMB Daemon
Loaded: loaded (/lib/systemd/system/nmb.service; disabled)
Active: failed since Sat, 14 Jan 2012 17:51:35 +0000; 8s ago
Process: 1902 ExecStart=/usr/sbin/nmbd $NMBDOPTIONS (code=exited, status=0/SUCCESS)
Main PID: 1903 (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/nmb.service

smbtree failed to find anything. I'm sure I don't need to start anything on my XP box - or do I?

the mount command now gives the following, and I am just investigating it:

# mount -t cifs -o user=root,rw //192.168.2.3/C /mnt/Windows-C
Password:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
 
Old 01-14-2012, 01:41 PM   #10
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

What is the name of the share on Windows. I doubt you shared it with the default name C. When you did smbtree did you not find Windows system and the device you shared?

As I can see in the command you are using user=root. As I mentioned before you need to mention the user name and the password of Windows user. Make sure that the user account that you are using with the mount command have access to the share.

Were you able to telnet Windows machine on port 139 from your linux machine?

Try the following command and see if it works:

Code:
mount -t cifs //192.168.2.1/C /mnt/Windows-C -o user=administrator
If you could share the screenshot of how you have shared the directory from Windows it will nice.
 
Old 01-15-2012, 11:55 AM   #11
alankenyon55
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Oh dear! yes, you're right, I was entering ROOT again.

It's working now. My next task is to connect to my remote printer, which I don't expect to be simple, so lookout for a new thread!

Thanks very much for all your help.


Alan.
 
Old 01-15-2012, 01:57 PM   #12
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

You're welcome. Enjoy linux!!!
 
Old 12-03-2014, 12:47 AM   #13
arpegiator
LQ Newbie
 
Registered: Dec 2014
Posts: 1

Rep: Reputation: Disabled
Check Firewall settings

I received the same message when I tried to mount a drive from Linux to a windows server. It was working before and then stopped. I checked and realised that the anti-virus updated and enabled my firewall. After disabling the firewall the mount was working again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6: "mount: could not find filesystem '/dev/root'" sancho Fedora - Installation 16 04-07-2010 09:35 PM
busybox mount iso: "mount could not find a spare loop device" error frenchn00b Linux - General 0 01-08-2010 03:37 AM
DFS shares - can mount shared folder, but no access - error "object is remote" gbloon Linux - Networking 6 08-20-2009 06:18 PM
FC6: "mount: could not find filesystem '/dev/root'" cheerful Fedora - Installation 2 07-27-2007 04:36 PM
unclean shutdown causes "Couldn't find matching filesystem: label=" error irnerdette Red Hat 3 06-02-2006 02:44 PM


All times are GMT -5. The time now is 08:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration