LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-03-2009, 03:57 PM   #1
BumbleBee
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora Core 11
Posts: 28

Rep: Reputation: 15
Cannot Mount NTFS External HDD on Fedora 11


Well basically, I have Fedora Core 11 (EXT4) Filesystem. I have 2 external NTFS Hard Drives with my data, and all I want to do it is access them. When I try to open it, the computer says it cannot mount. Here is the Specific message.

-A window pops up and says the following:

UNABLE TO MOUNT LOCATION
.org.freedesktop.devicekit.disks.error.failed:
Error creating mounting point: No such file or directory.


^the above is said with both drives, i know they aren't broken because they work perfectly with windows. Does linux have a problem with NTFS? What is the problem, any help would greatly be appreciated

-*Side Note*
-I have installed all Fedora Updates.
 
Old 09-03-2009, 04:09 PM   #2
firewiz87
Member
 
Registered: Jan 2006
Distribution: OpenSUSE 11.2, OpenSUSE 11.3,Arch
Posts: 240

Rep: Reputation: 37
The mount point ie the folder to which the driver is to be mounted should be created first.

eg:
you should first make the mount point in your /mnt dir
Code:
mkdir /mnt/mount-point
Then mount the device say /dev/sda0 using the following command
Code:
mount /dev/sda0 /mnt/mount-point
 
Old 09-03-2009, 04:14 PM   #3
djeikyb
Member
 
Registered: Nov 2005
Location: California
Distribution: ubuntu 10
Posts: 162

Rep: Reputation: 33
Hm. I'm not familiar with Fedora or Gnome, but..

Open a console. If you don't know the /dev/ path to your hard disk, check out fdisk -l. Make a directory to mount the drive to (mkdir /mnt/my-ntfs-0) and try mounting it: mount -t ntfs-3g /dev/sdb1 /mnt/my-ntfs-0. If this doesn't work, try changing the -t option to ntfs. If you get a message like "unknown file system type", you need to install support for ntfs. Make sure you get the device path correct, /dev/sdb1 is likely, but it varies.

If you can mount it manually, then blame whatever gui (I assume gnome) for doing it wrong.
 
Old 09-03-2009, 06:14 PM   #4
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
try using the dmesg command and post the output after your plugin the drive and get that failure message. From the looks of that message it looks like it can't find the mount point directory. So we first need to see where it is trying to mount to.

You also might want to look through /var/log/messages and see if anything shows up in there also.
 
Old 09-05-2009, 12:00 PM   #5
BumbleBee
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora Core 11
Posts: 28

Original Poster
Rep: Reputation: 15
Well, I actually saw on the internet that Linux (specifically Fedora) can see and access NTFS volumes but can't edit, wright, or do anything with them. So I was wondering, the two hard drives I want to use, is it possible for my to format them into EXT4 so linux can access them and edit, wright, and all of that? However I need windows to be able to access the EXT4 also. Is this possible.
-Basically if i make the two hard drives ext4, will Linux and Windows be able to access them completely with no problems?
 
Old 09-05-2009, 12:14 PM   #6
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Quote:
Originally Posted by BumbleBee View Post
Well, I actually saw on the internet that Linux (specifically Fedora) can see and access NTFS volumes but can't edit, wright, or do anything with them. So I was wondering, the two hard drives I want to use, is it possible for my to format them into EXT4 so linux can access them and edit, wright, and all of that? However I need windows to be able to access the EXT4 also. Is this possible.
-Basically if i make the two hard drives ext4, will Linux and Windows be able to access them completely with no problems?
After a quick read, the above posters' suggestions should help you get the NTFS drives mounted under Linux -- provided your Fedora has a new enough version of NTFS-3g, which as of version ~2.0+ or so, has full read/write ability on NTFS, non-encrypted filesystems.

As for if you were to make all your filesystems Ext4, then as far as I know, Windows will not be able to read them**. As a general rule, Windows cannot read any Linux filesystems, while Linux on the other hand, can read all or just about all, Windows filesystems.

** = There are some windows tools available, which apparently can allow windows to read Ext2 filesystems, but I have never tried them, or researched them, and have no clue whether they work, or where you might get them.

Hope that helps a bit
Sasha
 
Old 09-05-2009, 01:17 PM   #7
BumbleBee
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora Core 11
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by firewiz87 View Post
The mount point ie the folder to which the driver is to be mounted should be created first.

eg:
you should first make the mount point in your /mnt dir
Code:
mkdir /mnt/mount-point
Then mount the device say /dev/sda0 using the following command
Code:
mount /dev/sda0 /mnt/mount-point
-Ah, i tried what you said, I used the terminal and i created the directory "mkdir /mnt/mount-point" then when i tried the next command ("mount /dev/sda0 /mnt/mount-point") it says that I must specify my filesystem type. I know that the file system type is NTFs so how do i specify it in the command?
 
Old 09-05-2009, 04:42 PM   #8
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,976

Rep: Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283
mount -t ntfs /dev/sda0 /mnt/mount-point

The above assumes that the mount point/directory you created to mount your windows partitions is named "mount-point" and is in the /mnt directory. The "sda0" was just an example and is not going to work. You will have to use the actual drive your ntfs partitions are on. You can get this by loggin in as root and running the command "fdisk -l", without quotes and with Lower case Letter L) Replace sda0 in the above command with whatever shows up as ntfs in the fdisk command. If you don't understand, post the output of fdisk command and someone here will instruct you.
 
Old 09-05-2009, 11:51 PM   #9
BumbleBee
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora Core 11
Posts: 28

Original Poster
Rep: Reputation: 15
okay so I open terminal, entered into root and typed the command "fdisk-1"

Here is the exact Results:

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc8ccc8cc

Device Boot Start End Blocks Id System
/dev/sda1 * 1 26 204800 83 Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2 26 14593 117013441 83 Linux

Disk /dev/dm-0: 119.8 GB, 119819695104 bytes
255 heads, 63 sectors/track, 14567 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 117.1 GB, 117159493632 bytes
255 heads, 63 sectors/track, 14243 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table

Disk /dev/dm-2: 2650 MB, 2650800128 bytes
255 heads, 63 sectors/track, 322 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-2 doesn't contain a valid partition table

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbf5cbf5c

Device Boot Start End Blocks Id System
/dev/sdb1 1 9729 78148161 7 HPFS/NTFS



-The drive I wanted to mount has to be the last one, since its 80GB and mine is 80GB so since it matched, I saw it that is said "/dev/sdb" (without quotes) therefore I typed in your command exactly like this:

"mount -t ntfs /dev/sdb /mnt/mount-point"

Here is the results I got from that command:

NTFS signature is missing.
Failed to mount '/dev/sdb': Invalid argument
The device '/dev/sdb' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?



-I dont even know if any of my commands were correct, thats just what i recieved from what I typed in. Any corrections, help, or directions would really help

-BTW I assumed that the last drive was the one i wanted to mount since it said it was 80GB...is it right though? and since it said "sdb" there I assumed thats what i needed to use instead of sda0...is this right though? Thanks for any help.

Last edited by BumbleBee; 09-05-2009 at 11:53 PM.
 
Old 09-06-2009, 06:10 PM   #10
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,976

Rep: Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283
Quote:
The "sda0" was just an example and is not going to work
mount -t ntfs /dev/sdb /mnt/mount-point"

You forgot the 1, /sdb is the drive not the partition. Change it to:

Quote:
mount -t ntfs /dev/sdb1 /mnt/mount-point
I assume you have created a directory as a mount point named "mount-point" in the /mnt directory?
 
Old 09-06-2009, 09:30 PM   #11
BumbleBee
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora Core 11
Posts: 28

Original Poster
Rep: Reputation: 15
Hi,
so anyway here is the results so far.
-I took and open terminal and entered the root
-Then just to make sure everything is the same, I typed in "fdisk -l" again and for some reason my hard drive now happens to be sdc instead of sdb...why?

Disk /dev/sdc: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbf5cbf5c

(I did turn off the hard drive today and I did reboot my system), however anyway, I took the command you gave me and changed it to sdc now. So here is the command I typed it, please tell me if its right:

"mount -t ntfs /dev/sdc1 /mnt/mount-point" <Tell me if this the right command.

Here is the results I got from that command

ntfs-3g-mount: failed to access mountpoint /mnt/mount-point: Input/output error

So then since it failed, I went into my mnt directory and found that "mount-point" was not there. So I went back to terminal and tried to make another mount-point by typing this command

"mkdir /mnt/moint point"

And when i typed in "mkdir /mnt/moint point" it tells me this: "mkdir: cannot create directory `/mnt/mount-point': File exists"

-Something is really weird, any help? you find my explanation confusing just say and I will just copy and paste all the text from terminal. Thanks for any help

-Bumblebee=linux noobie who needs help for linux.
 
Old 09-06-2009, 09:45 PM   #12
mobinskariya
Member
 
Registered: Sep 2007
Location: Kerala, India
Distribution: ubuntu 10.04
Posts: 367

Rep: Reputation: 55
it would be better if you highlight your code with the # option in the panel..
can give us the output of the command
Code:
ls -l /mnt/
 
Old 09-07-2009, 03:27 PM   #13
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,976

Rep: Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283Reputation: 1283
Quote:
I typed in "fdisk -l" again and for some reason my hard drive now happens to be sdc instead of sdb...why?
Couldn't say for certain. This usually happens if you attach or connect another drive of some type and disconnect it??

As far as the directory "mount-point", not sure what the problem is there. mount point (with a space between the words) is totally different than mount-point (with a dash between the words). If you are creating the directory with a Live CD, every time you re-boot you will need to do it again as you are working in RAM.

Do you have ntfs-3g installed?
 
Old 09-07-2009, 07:52 PM   #14
BumbleBee
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora Core 11
Posts: 28

Original Poster
Rep: Reputation: 15
I am not sure what ntfs-3g is so probably not
-Can you please give me a link to it or a command for it in YUM?
-Thank you so much for help so far to everyone!
 
Old 09-07-2009, 08:20 PM   #15
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,140

Rep: Reputation: 99
ntfs-3g Are the drivers to mount Microsofts NTFS Filing System in Linux.

'yum search ntfs-3g' should confirm if you are able to find them in the repository then 'yum install ntfs-3g'. If this doesn't appear to work you may need another repository or another method of installing ntfs-3g.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
aa1 - How do I edit fstab to automount external ntfs-3g hdd? hegemoni Linux - Newbie 1 03-15-2009 10:52 AM
External HDD+Ntfs delta_9 SUSE / openSUSE 2 01-02-2008 12:46 PM
NTFS to FAT32 - External HDD SugarHiccup General 4 03-17-2007 02:39 PM
debian and ntfs external hdd wael_nasreddine Debian 22 03-16-2005 08:22 PM
External USB HDD with captive-ntfs alfonx Linux - Software 0 11-13-2004 02:20 PM


All times are GMT -5. The time now is 10:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration