LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-07-2009, 06:58 AM   #1
jens1245
LQ Newbie
 
Registered: May 2009
Posts: 18

Rep: Reputation: 5
cannot mount internal ntfs drive


I have a dual boot system with windows and debian.

Like this:
hda1 /boot
hda2 windows xp (ntfs)
hda3 /

Now i want to automount the windows ntfs partition in linux. To do so i tried to configure my /etc/fstab.

First i configured like this:

/dev/hda3 / ext3 errors=remount-ro 0 1
/dev/hda1 /boot ext2 rw,auto,user 0 2
/dev/hda5 none swap sw 0 0
/dev/hda2 /media/windows ntfs defaults 0 0
/dev/hdc /media/cdrom0 udf,iso9660 rw,user,noauto 0 0

The folder i mounted the partition in was owned by the user, but is now owned by the root. But now only root can read and others can't even read.

In other threads I found that I had to use rw or/and user instead of default, so i tried:
Still the same situation

So I continued looking and found i had to use umask=000, so i tried:
little progress, everyone is allowed to read.

umask=002, no difference
umask 022, no difference
rw,user,umask=000, no difference

Does anyone know what I am doing wrong?

Thanks in advance!
 
Old 05-07-2009, 07:02 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You might not have ntfs support built in by default in the kernel that you are using. You will need ntfs-3g package. And in /etc/fstab change ntfs to ntfs-3g
 
Old 05-07-2009, 07:11 AM   #3
jens1245
LQ Newbie
 
Registered: May 2009
Posts: 18

Original Poster
Rep: Reputation: 5
thanks!

Thanks man, i have been looking for this for hours. I just had to install the package and change to ntfs-3g!
 
Old 05-07-2009, 07:35 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Great to hear it worked for you !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to mount extra internal drive LinuxLiker VectorLinux 6 03-27-2009 10:49 AM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
internal SD drive wouldn't mount! jem81 Linux - Laptop and Netbook 3 12-21-2007 05:22 AM
got my ntfs sata drive to mount but cat get to auto mount Jack Daniels Linux - Hardware 3 04-15-2007 10:42 AM
Set up rsync to mirror mount on Windows Server to mount point on 2nd internal drive MoMule Linux - Server 4 04-13-2007 09:34 PM


All times are GMT -5. The time now is 04:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration