LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-31-2013, 11:30 PM   #1
ilesterg
Member
 
Registered: Jul 2012
Distribution: CentOS, SLES, RHEL, HP-UX, OpenSUSE Tumbleweed KDE
Posts: 504

Rep: Reputation: 54
Cannot install mp3 decoders - repos messed up


Hi all,

I'm having a bit of a problem trying to installing mp3 decoders. From my research I can make use of the packages in rpmfusion, so I tried a bunch of commands trying to install mp3 decoders. Then, I got this message:

Code:
http://mirror.nexcess.net/rpmfusion/nonfree/fedora/updates/14/i386/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for rpmfusion-nonfree-updates: Damaged repomd.xml file
Trying other mirror.
rpmfusion-nonfree-updates                                                                             | 1.0 kB     00:00     
http://mirror.web-ster.com/rpmfusion/nonfree/fedora/updates/14/i386/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for rpmfusion-nonfree-updates: Damaged repomd.xml file
Trying other mirror.
rpmfusion-nonfree-updates                                                                             |  999 B     00:00     
http://mirror.us.leaseweb.net/rpmfusion/nonfree/fedora/updates/14/i386/repodata/repomd.xml: [Errno -1] Error importing repomd.xml for rpmfusion-nonfree-updates: Damaged repomd.xml file
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rpmfusion-nonfree-updates. Please verify its path and try again
I tried to clean yum:
Code:
su -c 'yum clean headers'
su -c 'yum clean packages'
but still got the same results. Can you guys help me out? I'm using fedora 14.
 
Old 10-31-2013, 11:34 PM   #2
ilesterg
Member
 
Registered: Jul 2012
Distribution: CentOS, SLES, RHEL, HP-UX, OpenSUSE Tumbleweed KDE
Posts: 504

Original Poster
Rep: Reputation: 54
Also,

Code:
yum list all
returns the same error.
 
Old 10-31-2013, 11:49 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Quote:
http://mirror.nexcess.net/rpmfusion/...ta/repomd.xml:
[Errno -1] Error importing repomd.xml for rpmfusion-nonfree-updates:
Damaged repomd.xml file
No rpmfusion for Fedora 14 any more. The OS is too old.
( The oldest with the repodata sustained is Fedora 16.)

However : The Fedora 14 packages are still available :
Release http://download1.rpmfusion.org/free/...thing/i386/os/
Updates http://download1.rpmfusion.org/free/...dates/14/i386/

-
 
Old 11-01-2013, 12:52 AM   #4
ilesterg
Member
 
Registered: Jul 2012
Distribution: CentOS, SLES, RHEL, HP-UX, OpenSUSE Tumbleweed KDE
Posts: 504

Original Poster
Rep: Reputation: 54
Quote:
Originally Posted by knudfl View Post
No rpmfusion for Fedora 14 any more. The OS is too old.
( The oldest with the repodata sustained is Fedora 16.)

However : The Fedora 14 packages are still available :
Release http://download1.rpmfusion.org/free/...thing/i386/os/
Updates http://download1.rpmfusion.org/free/...dates/14/i386/

-
Too bad for me.

I tried to upgrade, first step:

Code:
yum install fedora-upgrade
and I got the same error
 
Old 11-01-2013, 01:50 AM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
the repos are NOT messed up
they no longer exist or the mirrors do not

fedora 14 is a dead and unsupported version

please do a new clean install of fedora 19

also there is NO way to do a inplace "upgrade" to 19
-- it is not possible

back up data
reformat the drive to ext4
and do a fresh install with 19

Last edited by John VV; 11-01-2013 at 01:52 AM.
 
Old 11-01-2013, 02:01 AM   #6
ilesterg
Member
 
Registered: Jul 2012
Distribution: CentOS, SLES, RHEL, HP-UX, OpenSUSE Tumbleweed KDE
Posts: 504

Original Poster
Rep: Reputation: 54
Quote:
Originally Posted by John VV View Post
the repos are NOT messed up
they no longer exist or the mirrors do not

fedora 14 is a dead and unsupported version

please do a new clean install of fedora 19

also there is NO way to do a inplace "upgrade" to 19
-- it is not possible

back up data
reformat the drive to ext4
and do a fresh install with 19
This is a bit frustrating

I will do just that. Thanks all.
 
Old 11-01-2013, 03:46 AM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
well fedora is a VERY VERY fast passed "Research and Development" distro
with a very NEW and often VERY different release every 6 months
and support for any one version for ONLY 13 months

now some people have not had many issues in doing a inplace UPGRADE
I am NOT one of them

fedora as of 17 dumped the testing "preupgrade"
they moved to a NEW upgrade system "FedUP" as of fedora 18

the BEST way to upgrade is to wipe the install and do a new install EVERY 6 months
or
once you get 19 installed then give "fedup" a go for upgrading to fedora 20 in about 20 to 30 days .

as i recall as of fedora 16 they moved to the "systemD" boot process dumping the old systenV
-- there are no "runlevels" any longer


PS.
there is a VERY good guide for installing things like mp3 and movie support
-- so good that it is the VERY first one listed in the fedora set up guide
Mjmwired

http://www.mjmwired.net/resources/mjm-fedora-f19.html

Last edited by John VV; 11-01-2013 at 01:46 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to update repos in CentOS 5.6 yum.repos.d!!!!! Explore_Linux Linux - Newbie 1 09-28-2011 05:20 AM
Repos messed up? danbuter Bodhi 2 02-21-2011 11:24 PM
mp3 file header is messed up Furlinastis Linux - Software 2 03-07-2007 10:50 PM
Can't Install Repos In Yast 10.1 Red Knuckles SUSE / openSUSE 13 06-22-2006 09:20 PM
Help! Mp3 Decoders Berto Linux - Software 4 05-26-2004 03:05 PM


All times are GMT -5. The time now is 09:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration