LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-19-2008, 03:22 AM   #1
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Rep: Reputation: 15
Exclamation Cannot install limewire or java ---> errors -----> not comprehending ---> help!!!


An error shows up after I try to install LimeWire with Package Installer:

Only one software management tool is
allowed to run at the same time

Please close the other application e.g. 'Update Manager', 'aptitude' or 'Synaptic first.




I cant find out where these programs would be listed in order to exit them. I am at a loss there. Help????????????


ANOTHER PROBLEM:


I hear Java runtime environment is supposed to be installed for Limewire to work. I CANNOT INSTALL IT BECAUSE!!!:

An Error Occurred.

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.


W T F !

Last edited by NOoBuntuLinux; 11-19-2008 at 03:28 AM.
 
Old 11-19-2008, 04:43 AM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
So what happens if, as suggested, your run sudo dpkg --configure -a in a terminal?
 
Old 11-19-2008, 10:37 PM   #3
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Original Poster
Rep: Reputation: 15
superuser

It needs "superuser" privelege... I think thats what it was called. 1 word: superuser. I tried to figure out what that was, but nothing.

Know anything about the trying to install java part? Do those programs that 'need to be closed, and not on at the same time as' sound familiar?
I tried looking through processes in system monitor but .. nothing close to the names.
 
Old 11-19-2008, 10:42 PM   #4
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Original Poster
Rep: Reputation: 15
Arrow P.S.

Furthermore, I'm not touching ANY of the 284 supposed available updates until I know that they are fine to go ahead and install... which might fix the problem, but for the sake of me having to re-install ubuntu again because I installed them before... (I tried clicking on anything browser or program and nothing opened or turned on), I will not.
 
Old 11-19-2008, 10:46 PM   #5
claudius753
Member
 
Registered: Jan 2004
Distribution: Mac OS X 10.6.4 "Snow Leopard", Win 7, Ubuntu 10.04
Posts: 322

Rep: Reputation: 31
Quote:
Originally Posted by NOoBuntuLinux View Post
It needs "superuser" privelege... I think thats what it was called. 1 word: superuser. I tried to figure out what that was, but nothing.

Know anything about the trying to install java part? Do those programs that 'need to be closed, and not on at the same time as' sound familiar?
I tried looking through processes in system monitor but .. nothing close to the names.
The "Superuser" is root. If you put "sudo" in front of the command, it should work, you will have to enter your password for it to confirm.

I have had errors about "other package manager is running" but usually I could tell what it was.
 
Old 11-19-2008, 11:07 PM   #6
dv502
Member
 
Registered: Sep 2006
Location: USA - NYC
Distribution: Whatever icon you see!
Posts: 642

Rep: Reputation: 57
Try installing the restricted extras package. This packages has the proprietary codecs to play most online content and it includes java.

If you manage to get the restricted extras to install, then install limewire from ubuntu repository or download the limewire deb package from limewire.com and install as follows:

dpkg -i LimeWireLinux.deb

Last edited by dv502; 11-19-2008 at 11:10 PM.
 
Old 11-19-2008, 11:39 PM   #7
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Original Poster
Rep: Reputation: 15
Arrow

Thanks so much for the tip. I only wish I could install a single thing right now, and I cant because it keeps giving me the error. Yes I tried installing 1 of the 2 restricted extras packages but still gives me the stupid manual dpkg error. I'll try sudo before command codes first then password and see what happends........
 
Old 11-19-2008, 11:45 PM   #8
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,275

Rep: Reputation: 126Reputation: 126
If you have a window open that's asking you to install those updates, then that's the one that needs to be closed before dpkg or any of the other package installers will run. If that's not actually open, then are you sure you don't have it or synaptic open in another of the 4 workspaces?
 
Old 11-20-2008, 12:17 AM   #9
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Original Poster
Rep: Reputation: 15
Question I installed restricted extras. Now for LimeWire

I successfully installed a restricted extras file after doing the sudo with pass afterwards. Took a little bit to load/whatever, but successfully installed after. So Limewire... Now for some weird reason.. I cant find my installer that would possibly install limewire. Wth? (this was before I installed the extras)
 
Old 11-20-2008, 12:32 AM   #10
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Original Poster
Rep: Reputation: 15
Lightbulb

__________________ !

Last edited by NOoBuntuLinux; 11-20-2008 at 12:41 AM. Reason: ladkaldksdlaklkfa
 
Old 11-20-2008, 12:39 AM   #11
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Original Poster
Rep: Reputation: 15
Lightbulb

I INSTALLED LIMEWIRE WOHOOOO!!!!!!!!!!!!!!!!!!!!! YEAH! HOLY ... crap! I feel like obama after he won.......... "I did?.... I... uh............... still cant believe it."



::::::::::::PROBLEM REVISITED FOR YOUR CONSIDERATION:::::::::::::

Problem: Could not install ANY items in Add/Remove because of an error:

An Error Occurred.

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.


Problem Fixed by using Terminal and typing:

linuxuseroncomputer> sudo dpkg --configure -a [ENTER]
> "Please enter linuxuseroncomputer's password."
doninoes123 [ENTER]


THEN! Installed restricted package for ubuntu
THEN! Installed Limewire
PROBLEM SOLVED!!!!!! I SO HAPPY!
 
Old 11-20-2008, 12:46 AM   #12
claudius753
Member
 
Registered: Jan 2004
Distribution: Mac OS X 10.6.4 "Snow Leopard", Win 7, Ubuntu 10.04
Posts: 322

Rep: Reputation: 31
That's not your actual password is it? You might not want to be posting that on a forum...
 
Old 11-20-2008, 12:51 AM   #13
dv502
Member
 
Registered: Sep 2006
Location: USA - NYC
Distribution: Whatever icon you see!
Posts: 642

Rep: Reputation: 57
Glad it's working.

It's optional, but a profile or sig of the ubuntu version you're using and specs for your system can be helpful for future incidents.

Last edited by dv502; 11-20-2008 at 12:56 AM.
 
Old 11-21-2008, 12:18 AM   #14
NOoBuntuLinux
Member
 
Registered: Nov 2008
Posts: 43

Original Poster
Rep: Reputation: 15
Arrow no its not my password.

No. I am not that entirely stupid.
 
Old 11-21-2008, 04:34 AM   #15
claudius753
Member
 
Registered: Jan 2004
Distribution: Mac OS X 10.6.4 "Snow Leopard", Win 7, Ubuntu 10.04
Posts: 322

Rep: Reputation: 31
Quote:
Originally Posted by NOoBuntuLinux View Post
No. I am not that entirely stupid.
I didn't mean to imply that you were. Sometimes people are just unaware of that sort of thing, so I just thought I'd check.

Glad you got it working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LimeWire install - problems with Java Runtime Enviroment Par4n0iA Linux - Software 15 03-15-2007 07:22 PM
Limewire and java Install presnwa Mandriva 3 09-25-2005 12:35 PM
LimeWire Install. Yes. Java VM is installed ThePenguin Linux - Software 2 09-05-2004 07:12 AM
java is installed but still cant install limewire zexter Linux - Software 12 12-21-2003 10:44 AM
Limewire will not install, java not in PATH endezeichen Linux - Software 2 12-20-2003 02:53 PM


All times are GMT -5. The time now is 05:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration