LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-03-2009, 08:39 PM   #16
diananewuser
LQ Newbie
 
Registered: Jun 2009
Posts: 10

Original Poster
Rep: Reputation: 0

Hello Simon

The wireless card is switching itself on when I connect to ubuntu and the light on the laptop is on to indicate that it is working. In windows I normally have to switch it on manually but its coming on by itself in ubuntu,

Output files as follows: looks like you have found something that is not working

dianamay@ubuntu:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSIDff/any Nickname:"ipw2100"
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Powerff
Retry short limit:7 RTS thrff Fragment thrff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.


dianamay@ubuntu:~$ lsmod | grep ipw
ipw2100 79536 0
ieee80211 38344 1 ipw2100
dianamay@ubuntu:~$ dmesg | grep ipw
[ 19.078531] ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, git-1.2.2
[ 19.078536] ipw2100: Copyright(c) 2003-2006 Intel Corporation
[ 19.079100] ipw2100 0000:02:06.0: PCI INT A -> Link[LNKG] -> GSI 10 (level, low) -> IRQ 10
[ 19.079812] ipw2100: Detected Intel PRO/Wireless 2100 Network Connection
[ 19.079838] ipw2100 0000:02:06.0: firmware: requesting ipw2100-1.3.fw
dianamay@ubuntu:~$


Thanks for your persistence Simon!
Diana
 
Old 07-03-2009, 11:46 PM   #17
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Cool - the information is telling me that you have the ipw2100 driver and that it is being correctly assigned to your card (eth1) - your card is detected and switched on. But it has not been associated with a wireless network.

This means you don't need to do any compiling of anything.

To connect to a wireless network, you use the network applet in the top panel.

Look in the top panel, on the right hand side. There should be an icon that looks like a couple of TVs. When you mouse over it, the tooltip says its something to do with networks. Click on that, and it should show you a selection of connections - select the one that corresponds to your wireless network.

FYI: eth0 is your ethernet card, and lo is the "loopback interface" which is the network used internal to linux. If either of these had wireless extensions, there would be trouble.
 
Old 07-04-2009, 02:46 AM   #18
diananewuser
LQ Newbie
 
Registered: Jun 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Hi Simon

This is the problem I had at the start. When I right click on that icon, it has an item on the menu that says "ebable wireless" - but this is blanked out and i cannot click on it. If I just left click on this icon there is a menu that has options which are:

Wired connection
Wireless Networks
Wireless is disableed
Auto eth0
VPN Connections

Most of these are blanked out so I cannot click on them, I can only click on the auto eth0 ad the VPN connections.

???

Thanks
Diana
 
Old 07-04-2009, 03:22 AM   #19
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Press the wireless killswitch. Light goes out? Try the enable wireless again.
 
Old 07-04-2009, 08:42 PM   #20
diananewuser
LQ Newbie
 
Registered: Jun 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Hi

I have pressed the switch to turn off the wireless but nothing happens. I had a look around to try and find some help somewhere and someone suggested pressing fn + f2. But this didn't do anything. I also tried logging into Windows and disabling the wireless card, but it still came on when I rebooted into Ubuntu.

Hopefully we are nearly there....I can feel the solution getting close!

Cheers
Diana
 
Old 07-05-2009, 01:19 AM   #21
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
I have pressed the switch to turn off the wireless but nothing happens.
What do you mean by "nothing happened"?

I need everything described to me as if I am on the other side of the world and cannot actually see what is happening in front of you.

What we are expecting is that the blue light goes out.
Whether it does or not, check the "enable wireless" option. Does it remain greyed out?

Please note that disabling wireless in windows can disable it for everything.
Make sure wireless in enabled in windows. Does windows disable the wireless on exit?
http://ubuntuforums.org/showthread.php?t=882357

Have a look at your wireless card in System->Administration->Network



You could try a manual connection:

sudo ifconfig eth1 down
sudo dhclient -r eth1
sudo ifconfig eth1 up
sudo iwlist scan
sudo iwconfig eth1 essid "linksys"
sudo iwconfig eth1 mode Managed
sudo dhclient eth1
ping -c 5 www.yahoo.com

note, your wlan essid is probably different. The error messages
 
Old 07-10-2009, 08:19 PM   #22
diananewuser
LQ Newbie
 
Registered: Jun 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Not sure what is supposed to happen when i type that stuff in, but access was denied when I tried it,

Would it be easier just to delete this Ubuntu software and install something a bit more user-friendly? It obviously does not want to play with me?
 
Old 07-11-2009, 09:00 AM   #23
Angry_Tommy
LQ Newbie
 
Registered: May 2009
Location: Leeds
Distribution: Gentoo, Arch Linux
Posts: 25

Rep: Reputation: 17
to type in those commands you have to be root (system administrator or user with correct privilages). simply before those commands type
Code:
su
and then type password.
after that you command prompt will change from '$' to '#'. after that type those commands again (without 'sudo' in front of them). good luck

Last edited by Angry_Tommy; 07-11-2009 at 09:01 AM.
 
Old 07-12-2009, 01:16 AM   #24
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
When you type sudo command, you should be prompted for your password. Enter your password.


"su" does not work in ubuntu.

@ Angry Tommy: I refer you to the manual page for sudo - can you think of any reason that those particular commands must have an explicit root terminal rather than sudo?

You can try:

sudo su -

(don't forget the dash on the end).

This will ask for a password, then change the prompt from $ to #.
Then you can enter the commands without the sudo in front.

But - if you cannot use sudo at all, then that is another issue.

Sadly Ubuntu is as user friendly as you can get.
What normally happens for every other Ubuntu user is that the interface starts up right away and you can connect immediately with none of this messing around with the commandline. The only setup you end up needing is to enter a keyphrase for encrypted networks.

This is something special to you - which means it is something to do with your laptop, something to do with windows, or your installation has something wrong with it.

Note: if you have disabled wireless in windows - go back and enable it. Does windows shut down the wireless when it shuts itself down? (In general, Windows assumes it is the only one on the machine, so it can mess things up for other oses - we need to eliminate windows as the source of your problems.)

You can eliminate the problem of there being something a bit out in your installation by reistallig ubuntu from scratch, getting all the updates, then attempting a wireless connection. Ideally, you install to the whole disk, erasing windows...

Please remind me which exact fujistu siemens laptop you have.

Last edited by Simon Bridge; 07-12-2009 at 01:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless not working on Ubuntu 8.04 linuxnewbie68 Linux - Laptop and Netbook 11 12-05-2008 08:52 PM
Wireless device crash when wireless network is lost (ubuntu/gutsy on ThinkPad) daganesh Linux - Wireless Networking 6 11-24-2008 06:06 AM
Wireless not working with Ubuntu asm06230 Linux - Newbie 1 06-25-2008 07:15 PM
Ubuntu network install using eth1 wireless network detection failed! xterminator890i Linux - Networking 3 06-23-2008 01:26 PM
Ubuntu newb: How do I get my wireless connection working with Ubuntu? devilgates Linux - Newbie 12 02-21-2008 08:05 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration