LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-21-2003, 08:49 PM   #1
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Rep: Reputation: 0
Cannot get network card status up


I have just installed Mandrake Linux 9 on an older system of mine and everything went smooth, but I'm try to set up the linux box to work on my network so I can access the internet with it but it is just not working. I'm running an XP box on the same router but on the linux box the eth0 is always in the down status (I'm sure thats my problem). I checked the MandrakeLinux site and the network card..which is a realtek RTL-8139..and the site said I was known to work..yet it does not.

Any suggestions?

Also, my router shows that there is a connection so it is sending a signal to the router.

Last edited by Synth3tic; 05-21-2003 at 08:51 PM.
 
Old 05-21-2003, 09:05 PM   #2
manthram
Member
 
Registered: Feb 2002
Location: Fairfax, VA
Distribution: RedHat 8, Mandrake9.1, Slack9
Posts: 456

Rep: Reputation: 31
post the results of 'ifconfig'

and 'lsmod' and check if there is a module '8139too' loaded.

post the contents of '/etc/sysconfig/network-scripts/ifcfg-eth0'
 
Old 05-21-2003, 11:34 PM   #3
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
ifconfig gives:

Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:58 errors:0 dropped:0 overruns:0 frame:0
TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4060 (3.9 Kb) TX bytes:4060 (3.9 Kb)


Yes there is a 8139too under lsmod

the contents of /etc/sysconfig/network-scripts/ifcfg-eth0 are:

DEVICE=eth0
BOOTPROTO=dhcp
IPADDR=192.168.1.101
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes


Is there a config problem on my part?
 
Old 05-22-2003, 01:30 AM   #4
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Your ifconfig display looks like its only detecting loopback... Anyway, it will help a lot if you can copy the exact output generated by ifconfig.

And... you might want to try ifconfig eth0 up...
 
Old 05-22-2003, 10:05 AM   #5
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
When I try ifconfig eth0 up it says that the "Device or resource busy"

and that is the exact output of ifconfig
 
Old 05-22-2003, 10:50 AM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,965

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
Try this:

ifconfig eth0 192.168.1.101 netmask 255.255.255.0 up

You don't need to use dhcp and then set a static address.

Last edited by michaelk; 05-22-2003 at 10:53 AM.
 
Old 05-22-2003, 11:30 AM   #7
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
after I type in the command I get this:

SIOCSIFFLAGS: Device or resource busy
SIOCSIFFLAGS: Device or resource busy

Should I try a new NIC?
 
Old 05-22-2003, 02:17 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,965

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
It might be a module problem and / or IRQ resource conflict etc.

Look at the output of dmesg and see what it says for the ethernet card.
 
Old 05-22-2003, 02:42 PM   #9
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
dmesg for eth0 gives:

eth0: RealTek RTL8139 Fast Ethernet at 0xcc847000, 00:e0:4c:00:0d:fd, IRQ 0

eth0: Identified 8139 chip type 'RTL-8139b'

should the IRQ be 0?
 
Old 05-22-2003, 02:53 PM   #10
manthram
Member
 
Registered: Feb 2002
Location: Fairfax, VA
Distribution: RedHat 8, Mandrake9.1, Slack9
Posts: 456

Rep: Reputation: 31
DEVICE=eth0
BOOTPROTO=dhcp
IPADDR=192.168.1.101
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes


--------------------------------------------------


change the second line to

BOOTPROTO=static


and do a '/etc/rc.d/init.d/network restart'

and then see the output of 'ifconfig'
 
Old 05-22-2003, 03:23 PM   #11
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
Same as before but the RX and TX packets changes from 58 to 126 and the RX and TX bytes changed from 4060 to 9206

and still fails to bring up eth0

I know the card works because I was just testing Windows server 2003 and it worked fine.

Last edited by Synth3tic; 05-22-2003 at 03:25 PM.
 
Old 05-22-2003, 03:33 PM   #12
jfrey
Member
 
Registered: May 2003
Location: California
Distribution: Mandrake
Posts: 50

Rep: Reputation: 15
I just encountered this same kind (I think) of issue when I started playing with Mandrake's 9.1 release.
Check in yourBIOS and see if you have a setting for APCI. If so, disable it. It does something with the allocation of your PCI bus. I can run WinXP with it on, but when I boot to Linux, I have to go in and disable it.
I could not get either my onboard NIC (it's a Realtek as well) or a PCI NIC to work until I found out about that, even though in Windows they work just fine.
Hope this helps.


JF
 
Old 05-22-2003, 07:40 PM   #13
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,965

Rep: Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530Reputation: 1530
You also might try disabling plug and play in the BIOS
 
Old 05-22-2003, 11:09 PM   #14
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
I don't have a APCI setting or anywhere to disable PnP (which is weird)
 
Old 05-22-2003, 11:13 PM   #15
Synth3tic
LQ Newbie
 
Registered: May 2003
Location: /\/a|> T0\/\/N
Distribution: Mandrake Linux 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
WHOA.....When I was in the BIOS looking for those setting I noticed that the set OS was Win98/WinNT...I changed it to other and my NIC is up and I'm online!!! Sweet

Thanks to everyone for their help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Interface Status ejtbrown Programming 5 08-04-2006 02:12 AM
Checking network card status BNI Linux - Networking 1 06-15-2005 06:55 AM
Network status from within C/C++ tbruer1138 Linux - Software 1 02-27-2005 01:11 AM
Network status from C/C++ program tbruer1138 Programming 1 02-26-2005 06:00 PM
Cannot Get network card status up Synth3tic Linux - Networking 3 05-21-2003 12:32 PM


All times are GMT -5. The time now is 08:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration