LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cannot find Nagios web interface (Nagios 3.2.0) and O/S = Fedora 10 (http://www.linuxquestions.org/questions/linux-newbie-8/cannot-find-nagios-web-interface-nagios-3-2-0-and-o-s-%3D-fedora-10-a-786144/)

gutiojj 02-01-2010 03:43 AM

cannot find Nagios web interface (Nagios 3.2.0) and O/S = Fedora 10
 
Hi all,

I am new to this Linux forum !

I installed Nagios 3.2.0 on Linux server with O/S = Fedora 10.
I installed both Nagios and Apache service.
iptables service is stopped.

When I try to browse http://localhost/nagios (on Fedora 10 locally), the message of "The webpage cannot be found"

However, it can display the webpage successfully when I browse http://localhost

Thus, apache service seems work fine.

May you please help to give some advice on this case ?
Thanks very much !


Rgds,
Gutio

mesiol 02-01-2010 06:16 AM

Hi,

did you configure apache for nagios website?

vinaytp 02-01-2010 06:32 AM

This has been done ?

Configure the Web Interface

Install the Nagios web config file in the Apache conf.d directory.
Code:

make install-webconf
Create a nagiosadmin account for logging into the Nagios web interface. Remember the password you assign to this account - you'll need it later.
Code:

htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin
Restart Apache to make the new settings take effect.
Code:

service httpd restart

mesiol 02-01-2010 07:48 AM

Hi,

how does httpd.conf look like?

bittus 02-03-2010 07:57 PM

I think you need to install nagios-plugins also.

BTW, I got nagios working successfully on a test box. But when I tried installing it in my servers, I ended up in an error. However nagios got installed and is working well. But the page is not coming up. So I understood that it is bcos I failed the installation of nagios-plugins. I am trying to install nagios-3.2 and nagios-plugins-1.4.11 on Red Hat Enterprise Linux WS release 3.
The installation of nagios-plugins, end up in the following:

Quote:

#make
make all-recursive
make[1]: Entering directory `/installs/nagios/nagios-plugins-1.4.11'
Making all in gl
make[2]: Entering directory `/installs/nagios/nagios-plugins-1.4.11/gl'
make all-am
make[3]: Entering directory `/installs/nagios/nagios-plugins-1.4.11/gl'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/installs/nagios/nagios-plugins-1.4.11/gl'
make[2]: Leaving directory `/installs/nagios/nagios-plugins-1.4.11/gl'
Making all in lib
make[2]: Entering directory `/installs/nagios/nagios-plugins-1.4.11/lib'
Making all in tests
make[3]: Entering directory `/installs/nagios/nagios-plugins-1.4.11/lib/tests'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/installs/nagios/nagios-plugins-1.4.11/lib/tests'
make[3]: Entering directory `/installs/nagios/nagios-plugins-1.4.11/lib'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/installs/nagios/nagios-plugins-1.4.11/lib'
make[2]: Leaving directory `/installs/nagios/nagios-plugins-1.4.11/lib'
Making all in plugins
make[2]: Entering directory `/installs/nagios/nagios-plugins-1.4.11/plugins'
/bin/sh ../libtool --tag=CC --mode=link gcc -g -O2 -L. -L/usr/local/ssl/lib -o check_http check_http.o sslutils.o netutils.o utils.o ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lssl -lcrypto
gcc -g -O2 -o check_http check_http.o sslutils.o netutils.o utils.o -L/installs/nagios/nagios-plugins-1.4.11/plugins -L/usr/local/ssl/lib ../lib/libnagiosplug.a ../gl/libgnu.a -lnsl -lresolv -lssl -lcrypto
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0x37): In function `dlfcn_load':
: undefined reference to `dlopen'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0x98): In function `dlfcn_load':
: undefined reference to `dlclose'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0xc0): In function `dlfcn_load':
: undefined reference to `dlerror'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0x141): In function `dlfcn_bind_var':
: undefined reference to `dlsym'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0x16c): In function `dlfcn_bind_var':
: undefined reference to `dlerror'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0x229): In function `dlfcn_bind_func':
: undefined reference to `dlsym'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0x254): In function `dlfcn_bind_func':
: undefined reference to `dlerror'
/usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o)(.text+0x512): In function `dlfcn_unload':
: undefined reference to `dlclose'
collect2: ld returned 1 exit status
make[2]: *** [check_http] Error 1
make[2]: Leaving directory `/installs/nagios/nagios-plugins-1.4.11/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/installs/nagios/nagios-plugins-1.4.11'
make: *** [all] Error 2
Is there a solution for this? Can anyone help me.
Thanks in advance.

kirukan 02-03-2010 08:52 PM

Dont want to go far away for solution, in nagios website there is a well documented pdf just follow their instruction

bittus 02-04-2010 12:43 AM

I agree that we got the documentation on site. But this is out of range of those documents. I followed the documentation to install the package. But I don't get any help regarding this error from the documentation.

Thanks

kirukan 02-04-2010 08:55 AM

Hmmm, In google there are lot of discussion similar to this
refer the following
http://www.linuxquestions.org/questi...others-679867/
http://www.google.com.sg/#hl=en&sour...e0be963af83b19


All times are GMT -5. The time now is 12:16 AM.