LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-07-2004, 12:25 AM   #1
Metal Martian
Member
 
Registered: Aug 2003
Posts: 33

Rep: Reputation: 15
Cannot enter NTFS partition directory


Please help I'm such a n00b!

/dev/hda1 /mnt/windows auto ro,auto,user 0 0
/dev/hdb1 /mnt/aux auto rw,auto,user 0 0

Ok those are the two lines from my fstab I am using SUSE 9 with KDE

so I logged in as root and created the two mount points and then added the two lines to fstab for my windows/ntfs partition, and my 2nd hard drive which is a Fat32 partition.

so after that I log out and log back in as my regular user and the 2 hard drive icons appear on the desktop both mounted. I can view the contents of the 2nd hard drive no prob but when I try to view the windows/NTFS partition it tells me I can't enter the directory. If I log out and log in as root I can view both no problems. So how can I view the windows/NTFS partition when I'm just joe user? Thanks for any help anyone is willing to give.

MM
 
Old 03-07-2004, 04:11 AM   #2
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Change
/dev/hda1 /mnt/windows auto ro,auto,user 0 0
/dev/hdb1 /mnt/aux auto rw,auto,user 0 0

to
/dev/hda1 /mnt/windows ntfs ro,noauto,user,umask=222 0 0
/dev/hdb1 /mnt/aux vfat rw,noauto,user,sync,codepage=437,umask=000 0 0

umask=222 will make everybody have access to your windows drive but they can only read and execute. umask=000 will make everybody have access to your fat32 drive but they are able to read, write, and execute data. codepage=437 is Windows US language format. If you are using another langauge format you have to look up the code for your langauge. sync makes sure anything that is written to the drive goes directly on to the drive. This make sure that anything happens you still have your data intact. You do not need to use rw and ro because umask will take over those settings.

BTW, do not run GUI as root. Its very dangerous. Use root only for command line or bash.
 
Old 03-07-2004, 04:26 PM   #3
Metal Martian
Member
 
Registered: Aug 2003
Posts: 33

Original Poster
Rep: Reputation: 15
Ok I made the changes but still no joy. Unless I'm root it will not let me view the NTFS partition. It keeps saying "cannot enter directory". Any other comments? No problem with the second hard drive.

Thanks
MM
 
Old 03-07-2004, 05:31 PM   #4
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Before mounting set the directory so that all users can access it. Use the chmod. Something like 7xx. The x is up to you and the 7 is for entering into the directory.

You can try changing umask=222 to 022. Be careful when you are logged as root and you are in the ntfs hard drive.
 
Old 03-08-2004, 08:18 PM   #5
Metal Martian
Member
 
Registered: Aug 2003
Posts: 33

Original Poster
Rep: Reputation: 15
What does that mean the x is up to me? can you tell me exacly what to write? and how would I go about modifying the fstab using the console and not the root GUI if it is dangerous? Is it hard?

MM
 
Old 03-08-2004, 08:29 PM   #6
uteck
Member
 
Registered: Oct 2003
Location: Elgin,IL,USA
Distribution: Sidux, LinHES, and Mythbuntu
Posts: 209

Rep: Reputation: 32
Unmount the partition and do
chmod 777 /mnt/windows
that should allow you to enter the directory. You made /mnt/windows as root so normal users can not access it.
The other option is
chmod a+r /mnt/windows
to give everyone read access, a+rwx is read,write execute, but that is bad to do with ntfs since linux does not write to it very well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deleted ntfs partition - added linux partition in its place - corrupt! eklhad Linux From Scratch 2 06-28-2005 02:31 AM
What do I enter in the Swap Partition prompt? milesonwheels Linux - Laptop and Netbook 38 09-10-2004 10:14 PM
Cannot Enter chroot /usr/bin/env directory not found Zero-0-Effect Linux From Scratch 2 03-13-2004 01:41 PM
How to enter swap partition when installing suse8.2 with only 40mb ram cirelj Linux - Newbie 8 02-27-2004 07:06 PM
Could not enter directory mnt/cdrom mgbgt Linux - Newbie 5 06-17-2003 08:50 PM


All times are GMT -5. The time now is 10:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration