LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-04-2006, 01:40 PM   #1
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Rep: Reputation: 15
Cannot connect to the internet


Ok I just got openSUSE v10 and WinXP Pro (with SP2) to share a hard drive, but I can't connect to the internet on openSUSE ("Cannot find <insert url here>"). It works under WinXP without any problems though. OpenSUSE seems able to read my network card (Broadcom 802.11b/g WLAN), but it lists it as disabled. How would I go about enabling it? I'm running this on an HP Pavilion notebook, with the GNOME desktop. I'm somewhat computer literate, but have virtually no experience with Linux, so I may require some extensive guidance. Thanks.
 
Old 04-04-2006, 02:45 PM   #2
chief_officer
Member
 
Registered: Mar 2006
Location: Istanbul, TR
Distribution: Red Hat, CentOS, Ubuntu
Posts: 180

Rep: Reputation: 30
Your Broadcom card possibly has a wireless interface of wlan0. Try

Code:
ifconfig wlan0
and see if that works.

Meantime go to Yast->Network Devices->Network Card and select your card under the "Already Configured Devices". Click configure and set your card to start on boot.

Edit: I made a typo in the command. Corrected it.

Last edited by chief_officer; 04-05-2006 at 01:54 AM.
 
Old 04-04-2006, 05:34 PM   #3
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Original Poster
Rep: Reputation: 15
Oops...made a mistake. Linux doesn't seem to recognize my Broadcom, it can find my Realtek RTL8139/810x Family Fast Ethernet NIC. It doesn't seem to know my Broadcom is there. I looked up "Linux" and "wireless" on google, I'm guessing this is going to be messy? Also, for future reference, is there a specific terminal I was supposed to put that code in? My distro seems to have several from which to choose.
 
Old 04-05-2006, 01:55 AM   #4
chief_officer
Member
 
Registered: Mar 2006
Location: Istanbul, TR
Distribution: Red Hat, CentOS, Ubuntu
Posts: 180

Rep: Reputation: 30
Can you post the output of lspci and lspci -n?
 
Old 04-05-2006, 08:56 PM   #5
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Original Poster
Rep: Reputation: 15
As I said before this may require some guidance. Where am I supposed to put these commands? I tried putting them in some consoles, but they didn't seem to recognize it.
 
Old 04-06-2006, 09:04 AM   #6
chief_officer
Member
 
Registered: Mar 2006
Location: Istanbul, TR
Distribution: Red Hat, CentOS, Ubuntu
Posts: 180

Rep: Reputation: 30
Ok. Here we go:

Open up a terminal. Type
Code:
su
and enter your root password.

Then type
Code:
cd /home/your_user_name/Desktop
. After that
Code:
pwd
. The output must be
Code:
/home/your_user_name/Desktop
. Then
Code:
lspci > lspci.txt
This will create a file named lcpci.txt on your desktop containing the output of the lspci command.

Then type
Code:
lspci -n > lspcin.txt
. This will create a file named lcpcin.txt on your desktop containing the output of the lspci -n command.

Copy -> Paste the contents of the two files here.

Edit: I didn't catch that when you're root cd ~ changes to / not your regular /home/user_name directory.

Last edited by chief_officer; 04-10-2006 at 02:31 PM.
 
Old 04-06-2006, 01:45 PM   #7
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Original Poster
Rep: Reputation: 15
See Below! I messed up

Last edited by Jack of Spades; 04-06-2006 at 01:47 PM.
 
Old 04-06-2006, 01:46 PM   #8
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Original Poster
Rep: Reputation: 15
Thank you thats much more clear . Eveything works well until I cut and copy the first line of code. The terminal is convinced that "lspci" is not a command. It does make the text file, but its empty.
 
Old 04-10-2006, 02:32 PM   #9
chief_officer
Member
 
Registered: Mar 2006
Location: Istanbul, TR
Distribution: Red Hat, CentOS, Ubuntu
Posts: 180

Rep: Reputation: 30
If people can't see how you "messed up", they can't help you. If you want answers, provide whole output, whatever information you have so that we can track what you are doing. Maybe you're doing correct, but your system is not properly configured.

lspci comes with pciutils after kernel 2.2. It is not likely that your SuSE did not install it during installation.

Also, please accept my apologies for that I have written something wrong in my post above. I have edited it and it must work fine now.

Please let people know what have you come up with. Remember: the solution to your problem may be a solution for a lot of people.
 
Old 04-11-2006, 01:18 AM   #10
expat
Member
 
Registered: Mar 2006
Location: China
Distribution: Linux Mint-Debian
Posts: 125

Rep: Reputation: 17
Just a gamble but I had 2 weeks of hell trying to connect to the internet as well, and I tried everything i read and more and nothing worked...I could easily connect with windows but not with Linux....finally I fiddled around long enough and got it working. Try this.....launch connect to internet then properties then protacol and hardware ppp settings and change the setting from PAP to CHAP......believe it or not thats all I did and it worked....hopefully it works for you too...good luck
 
Old 04-11-2006, 08:45 AM   #11
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Original Poster
Rep: Reputation: 15
YAY! I almost thought this post was dead thanks for proving me wrong! Anyway, first off the whole "messed up" comment had to do with some problem I had posting my responce on the forum, its not anything related to the actual thread. Please just ignore it.

Heres the output of those commands you requested Mr. Officer:

lspci returns:
Code:
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc: Unknown device 5a3f
00:04.0 PCI bridge: ATI Technologies Inc: Unknown device 5a36
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 10)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 01)
00:14.6 Modem: ATI Technologies Inc: Unknown device 4378 (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 5955 (PCIE)
03:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
03:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
03:04.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
03:04.3 Unknown mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
03:04.4 Class 0805: Texas Instruments PCI6411, PCI6421, PCI6611, PCI6621, PCI7411, PCI7421, PCI7611, PCI7621 Secure Digital (SD) Controller
03:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
lspci -n returns:
Code:
00:00.0 Class 0600: 1002:5950
00:01.0 Class 0604: 1002:5a3f
00:04.0 Class 0604: 1002:5a36
00:13.0 Class 0c03: 1002:4374
00:13.1 Class 0c03: 1002:4375
00:13.2 Class 0c03: 1002:4373
00:14.0 Class 0c05: 1002:4372 (rev 10)
00:14.1 Class 0101: 1002:4376
00:14.3 Class 0601: 1002:4377
00:14.4 Class 0604: 1002:4371
00:14.5 Class 0401: 1002:4370 (rev 01)
00:14.6 Class 0703: 1002:4378 (rev 01)
00:18.0 Class 0600: 1022:1100
00:18.1 Class 0600: 1022:1101
00:18.2 Class 0600: 1022:1102
00:18.3 Class 0600: 1022:1103
01:05.0 Class 0300: 1002:5955
03:00.0 Class 0c00: 104c:8023
03:02.0 Class 0280: 14e4:4320 (rev 03)
03:04.0 Class 0607: 104c:8031
03:04.3 Class 0180: 104c:8033
03:04.4 Class 0805: 104c:8034
03:06.0 Class 0200: 10ec:8139 (rev 10)
As for Mr. Expat, uh, I was unable to find what you're talking about. I can't tell if you want me to do this in windows or linux. I checked linux, but couldn't find it there. Could you be so kind as to post some screenshots? Thanks.
 
Old 04-12-2006, 05:01 AM   #12
chief_officer
Member
 
Registered: Mar 2006
Location: Istanbul, TR
Distribution: Red Hat, CentOS, Ubuntu
Posts: 180

Rep: Reputation: 30
Everything seems fine given the information in your post. Now we move on to the next step: Post your output of ifconfig so that we can see your network interfaces.
 
Old 04-12-2006, 08:07 AM   #13
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Original Poster
Rep: Reputation: 15
Ok, here we are:
Code:
eth0      Link encap:Ethernet  HWaddr 00:0F:B0:70:15:21  
          inet6 addr: fe80::20f:b0ff:fe70:1521/64 Scope:Link
          UP BROADCAST NOTRAILERS MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:209 Base address:0x2400 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:52 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3648 (3.5 Kb)  TX bytes:3648 (3.5 Kb)
That help?
 
Old 04-13-2006, 01:40 AM   #14
chief_officer
Member
 
Registered: Mar 2006
Location: Istanbul, TR
Distribution: Red Hat, CentOS, Ubuntu
Posts: 180

Rep: Reputation: 30
What does YaST say about your hardware? What do you see in YaST->Network->Network Cards?
 
Old 04-13-2006, 08:09 PM   #15
Jack of Spades
LQ Newbie
 
Registered: Apr 2006
Location: Orlando, Florida
Distribution: Kubuntu 8.04
Posts: 24

Original Poster
Rep: Reputation: 15
It lists my Realtek RTL8139/810X Family Fast Ethernet NIC, but not my Broadcom 802.11b/g WLAN.
 
  


Reply

Tags
broadcom


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 01:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 07:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM
Not able to connect to the internet DC12k Linux - Networking 1 04-24-2002 08:50 PM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration