LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cannot connect to Samba Server share from windows 2000 or xp pro machines (http://www.linuxquestions.org/questions/linux-newbie-8/cannot-connect-to-samba-server-share-from-windows-2000-or-xp-pro-machines-590432/)

dan98 10-09-2007 12:31 AM

Cannot connect to Samba Server share from windows 2000 or xp pro machines
 
I just installed unbuntu for the first time ever and I was completely amazed that it actually worked! All of the hardware in the box booted right up without a hesitation. Within a few minutes I was able to surf the internet and with the right user/pass I was able to browse my windows network lan. This is the first time that I have installed an os on a computer and didn't have to go to battle with the operating system just to get the computer to boot. :-)

I am however stumped at the moment, I installed the ubuntu samba server and designated one of the hard drives in the box to be a shared file. I am able to ping all the machines from each other. The unbuntu machine can read and write to all the machines on the network. I cannot however do the reverse. When I try to log into the Samba server it gives me the "incorrect password or unknown users" error. I am using the same login/pass for all machines on the network.

I would like to get the server to be accessible on the network, have a shared file that I could put archive files in and hot swap the drive when it is full. I plan to replace the drive with another so that I don't have to burn dvds for my file archives.

What do I need to do in order to be seen from the windows machines?

larkl 10-09-2007 05:14 PM

Did you add a samba user with the same name and passwd as the windows user ala:
Code:

smbpasswd -a <usr>
?

You want to have user security enabled in smb.conf (generally).

It could be a firewall issue, as some firewalls will block the NetBIOS "surfing" that's required to get to the samba share (sorry that I don't have a more technical explanation). If you have a software firewall enabled on the linux box, turn it off to see if it helps.

It won't hurt to turn on the WINS server in smb.conf, this may help with the netBIOS name resolution.

It's probably just a password issue.


All times are GMT -5. The time now is 10:00 PM.