LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-22-2008, 12:02 AM   #1
B-Boy
Member
 
Registered: Jan 2008
Posts: 103

Rep: Reputation: 15
Unhappy cannot connect to samba Server on suse server 10


Hi guys ...I setup a Samba server but i can not connect to it from my WIN XP PC it does not appear on my network places as well this is the config:
# smb.conf is the main Samba configuration file. You find a full commented # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the # samba-doc package is installed.
# Date: 2006-06-16
[global]
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
security = user
passdb backend = smbpasswd
wins support = Yes
netbios name = (my choice)
ldap suffix =
workgroup =
[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/ [groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
write list = root
[(my choice)]
comment = (my choice)
inherit acls = Yes
path = /home/(my choice)
read only = No
 
Old 01-22-2008, 12:18 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
You didn't state if you are using XP pro or XP home.
Code:
wins support = Yes
netbios name = (my choice)
ldap suffix =
workgroup = 
Since you have "wins support = Yes", then enter your samba server's IP address as the WINS address in the windows TCP/IP configuration. If you use a NAT router, then you may be able to enter it there instead and DHCP will supply this info if the XP computer uses DHCP.

Enter in the name of your Workgroup. That is probably the reason that your Samba server doesn't show up.

With your configuration, there are 3 services which should be running: smbd, nmbd and winbind.
You can check if they are with:
sudo /usr/sbin/rcsmb status
sudo /usr/sbin/rcnmb status
sudo /usr/sbin/winbind status

Also, when posting a config file, please put it inside [ code ] ... [ /code ] blocks (without the spaces I added to print it literally).

Last edited by jschiwal; 01-22-2008 at 12:22 AM.
 
Old 01-22-2008, 12:43 AM   #3
B-Boy
Member
 
Registered: Jan 2008
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
You didn't state if you are using XP pro or XP home.
Code:
wins support = Yes
netbios name = (my choice)
ldap suffix =
workgroup = 
Since you have "wins support = Yes", then enter your samba server's IP address as the WINS address in the windows TCP/IP configuration. If you use a NAT router, then you may be able to enter it there instead and DHCP will supply this info if the XP computer uses DHCP.

Enter in the name of your Workgroup. That is probably the reason that your Samba server doesn't show up.

With your configuration, there are 3 services which should be running: smbd, nmbd and winbind.
You can check if they are with:
sudo /usr/sbin/rcsmb status
sudo /usr/sbin/rcnmb status
sudo /usr/sbin/winbind status

Also, when posting a config file, please put it inside [ code ] ... [ /code ] blocks (without the spaces I added to print it literally).

all the services are running except winbind ...i also added a work group but the problem persists
 
Old 01-22-2008, 12:53 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
See if you can ping the Samba server. If not check your network configuration.

Enter the IP address in the filebrowser:
\\192.168.1.100
for example. Do the shares show up.

Make sure you have the same username/password for the two machines and use the "smbpasswd" command to enter this info into samba's password file. This is needed for the [profile] and [homes] services to work.

Install the samba-doc package. It adds 3 books in /usr/share/doc/packages/samba/. Both "Samba 3 by Example" and "Samba 3 HOWTO & Reference Guide" will contain troubleshooting sections that might help.

Also, consider using Samba Swat to configure the samba server.
First edit /etc/xinet.d/swat:
Code:
 cat /etc/xinetd.d/swat
# SWAT is the Samba Web Administration Tool.
service swat
{
        socket_type     =  stream
        protocol        =  tcp
        wait            =  no
        user            =  root
        server          =  /usr/sbin/swat
        only_from       =  127.0.0.1 
        log_on_failure  += USERID
        disable         =  no
}
Change "disable=yes" to "disable=no". Then restart xinetd: "sudo killall -SIGHUP xinetd" or "sudo /usr/sbin/xinetd restart". Next point your web browser at "http://localhost:901"

Last edited by jschiwal; 01-22-2008 at 01:09 AM.
 
Old 01-22-2008, 01:07 AM   #5
B-Boy
Member
 
Registered: Jan 2008
Posts: 103

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
See if you can ping the Samba server. If not check your network configuration.

Enter the IP address in the filebrowser:
\\192.168.1.100
for example. Do the shares show up.

Make sure you have the same username/password for the two machines and use the "smbpasswd" command to enter this info into samba's password file. This is needed for the [profile] and [homes] services to work.

Install the samba-doc package. It adds 3 books in /usr/share/doc/packages/samba/. Both "Samba 3 by Example" and "Samba 3 HOWTO & Reference Guide" will contain troubleshooting sections that might help.

Also, consider using Samba Swat to configure the samba server.
First edit /etc/xinet.d/swat:
Code:
 cat /etc/xinetd.d/swat
# SWAT is the Samba Web Administration Tool.
service swat
{
        socket_type     =  stream
        protocol        =  tcp
        wait            =  no
        user            =  root
        server          =  /usr/sbin/swat
        only_from       =  127.0.0.1 
        log_on_failure  += USERID
        disable         =  no
}
Change "disable=yes" to "disable=no". Then restart xinetd: "sudo killall -SIGHUP xinetd" or "sudo /usr/sbin/xinetd restart". Next point your web browser at "http://localhost:901"

i can ping the ip and its all ok i can even ssh into the server and if I enter the IP address in the filebrowser and i get an error Windows cannot find {ipaddress) i also tried the other stuff you posted and it still does not work
 
Old 01-24-2008, 09:27 AM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Look in the trouble shooting sections of the books I mentioned. I probably didn't think of something, that that would be my next step if I were having a problem. If you were having the problem when using Linux, I would recommend checking the /etc/nsswitch.con and /etc/host.conf files. The error message you posted doesn't make sense because Windows already has the IP address. Did you enter "\\<ip address>" or just "<ip address>". If you know the service name, enter "\\<ip address>\service".

Also make sure that the WINS field in the TCP/IP network configuration has the IP address of the server. Check that ports 137-139 are open on both computers. Also open 445. I think that is what WINS uses.

I am using a simpler global configuration. To tell the truth, I'll only boot up into XP to run updates periodically.
Code:
[global]
        workgroup = JESNET
        map to guest = Bad User
        printcap name = cups
        logon path = \\%L\profiles\.msprofile
        logon drive = P:
        logon home = \\%L\%U\.9xprofile
        wins support yes
        usershare allow guests = No
        printing = cups
        cups options = raw
        print command =
        lpq command = %p
        lprm command =
        include = /etc/samba/dhcp.conf
This is my desktop's smb.conf. I don't have the samba services running normally but I did start them up and verified that I could reach my desktop from my laptop. I should really remove the [home] service. The [profile] service will do the same thing without displaying the other users. My username and password is the same on both machines in windows and Linux and I use smbpasswd to update them in samba after a change.

You could try adding your server in your windows hosts and lmhosts files but you shouldn't have to.

Last edited by jschiwal; 01-24-2008 at 09:43 AM.
 
Old 01-24-2008, 10:07 AM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Update: I booted my laptop into XP and verified that I could access my desktop from an XP Home computer. If you have an old share mapped for the server, go into tools -> unmap network drive and unmap it and then try again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I connect samba client from samba server wampire Linux - Networking 2 02-13-2006 10:38 AM
Cannot connect to samba server sp4nk3r Fedora 2 06-08-2004 01:05 AM
SuSE 9, Samba server and Win2k server domain koskoboy Linux - Networking 3 12-11-2003 06:32 AM
Is samba required to connect to a Windows Advanced server from RedHat 8.0 server? NemesisStar Linux - Hardware 1 10-20-2003 12:32 AM
Can not connect to my Samba Server victorc Linux - Newbie 11 05-09-2003 01:18 PM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration