LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2009, 05:03 AM   #1
perfectpol7
Member
 
Registered: Feb 2009
Posts: 84

Rep: Reputation: 15
Cannot configure Gadmin squid 0.1.0


Hie! I have installed GADmin in my fedora 10 which i want to use as a proxy server. Now my problem is to configure the Gadmin to work. I have tried but to no avail. here is the outputs errors from the GADmin when i tred to activate it:

009/02/03 12:57:02| cache_cf.cc(346) squid.conf:67 unrecognized: 'wais_relay_port'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:78 unrecognized: 'refresh_stale_hit'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:117 unrecognized: 'max_filedesc'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:132 unrecognized: 'acl_uses_indirect_client'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:135 unrecognized: 'delay_pool_uses_indirect_client'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:136 unrecognized: 'log_uses_indirect_client'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:140 unrecognized: 'httpd_accel_no_pmtu_disc'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:165 unrecognized: 'cache_vary'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:167 unrecognized: 'collapsed_forwarding'
2009/02/03 12:57:02| aclParseIpData: WARNING: Netmask masks away part of the specified IP in '10.0.0.255/255.255.255.0'
2009/02/03 12:57:02| cache_cf.cc(346) squid.conf:193 unrecognized: 'broken_vary_encoding'
2009/02/03 12:57:02| aclParseAccessLine: ACL name 'allow' not found.
FATAL: Bungled squid.conf line 196: reply_body_max_size 0 allow 10.0.0.23
Squid Cache (Version 3.0.STABLE10): Terminated abnormally.
CPU Usage: 0.007 seconds = 0.004 user + 0.003 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0

I am using eth1 for internet connection with ip address 192.168.0.11 and my lan is on eth0 with ip address 10.0.0.23 subnet mask 255.255.255.0 is there anyone who have use it before who may assist me.
 
Old 02-03-2009, 05:17 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Gadmin is just a front end for squid proxy. Have you looked at the errors at the line numbers that it says. And just try to run squid without errors then.
If GAdmin does not work for you, try Webmin.
 
Old 02-03-2009, 06:16 AM   #3
perfectpol7
Member
 
Registered: Feb 2009
Posts: 84

Original Poster
Rep: Reputation: 15
Cannot configure Gadmin squid 0.1.0

i have install webmin but i cannot find it on GUI if l try to install it say already installed. Are the any command to invoke it.
 
Old 02-03-2009, 06:36 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
It is accessed through web browser. Point your browser to the port 10000 on the system where it is installed.

For eg:

Code:
 https://localhost:10000
It will give you the login for webmin. Use root user to login and then create a webmin user from the panel and give access rights as needed and then use the user to login.
 
Old 02-03-2009, 07:04 AM   #5
perfectpol7
Member
 
Registered: Feb 2009
Posts: 84

Original Poster
Rep: Reputation: 15
Cannot configure Gadmin squid 0.1.0

this is the error I am getting after enter this code https://localhost:10000/ to the browser:

Secure Connection Failed

localhost:10000 uses an invalid security certificate.

The certificate is not trusted because it is self signed.

(Error code: sec_error_untrusted_issuer)
* This could be a problem with the server's configuration, or it could be someone trying to impersonate the server.

* If you have connected to this server successfully in the past, the error may be temporary, and you can try again later.

so what next and how come the security certificate are invalid. I am using the server to browser right now
 
Old 02-03-2009, 11:05 PM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Did you try http? Otherwise there is an option to accept the certificate that is invalid for browser.
 
Old 02-04-2009, 08:24 AM   #7
perfectpol7
Member
 
Registered: Feb 2009
Posts: 84

Original Poster
Rep: Reputation: 15
installed webmin and here are the error log from webmin


Failed to start Squid :

Starting squid: [FAILED]
2009/02/04 16:23:07| Processing Configuration File: /etc/squid/squid.conf (depth 0)
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:66 unrecognized: 'wais_relay_port'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:77 unrecognized: 'refresh_stale_hit'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:115 unrecognized: 'max_filedesc'
2009/02/04 16:23:07| WARNING: No units on 'authenticate_ip_ttl 5', assuming 5.00 second
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:129 unrecognized: 'acl_uses_indirect_client'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:132 unrecognized: 'delay_pool_uses_indirect_client'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:133 unrecognized: 'log_uses_indirect_client'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:137 unrecognized: 'httpd_accel_no_pmtu_disc'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:162 unrecognized: 'cache_vary'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:164 unrecognized: 'collapsed_forwarding'
2009/02/04 16:23:07| cache_cf.cc(346) squid.conf:190 unrecognized: 'broken_vary_encoding'
2009/02/04 16:23:07| aclParseAccessLine: ACL name 'allow' not found.
FATAL: Bungled squid.conf line 193: reply_body_max_size 0 allow 10.0.0.23
Squid Cache (Version 3.0.STABLE10): Terminated abnormally.
CPU Usage: 0.007 seconds = 0.006 user + 0.001 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 0
 
Old 02-04-2009, 10:57 PM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Your squid configuration is at fault. Do not blame Gadmin or webmin. Look at the line numbers that are invalid.
 
Old 02-05-2009, 08:43 AM   #9
perfectpol7
Member
 
Registered: Feb 2009
Posts: 84

Original Poster
Rep: Reputation: 15
I have uninstall the both gadmin, webmin and squid and then reinstall the squid and the webmin. So that i can start the configuration afresh. Now how should i go about to configure the webmin. my internet ip address is 192.168.0.10 subnet mask 255.255.255.0 and interna ip address for LAN is 10.0.0.23.
 
Old 02-05-2009, 11:20 PM   #10
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Search out for threads in LQ for squid configurations. You would find many of them. Webmin or GAdmin squid for that matter are not complete tools and lack some functionalities like delay pools and manually editing the file is a better option.

http://www.cyberciti.biz/tips/linux-...uid-howto.html

This is one of the links that google gives.
 
Old 02-06-2009, 03:17 AM   #11
perfectpol7
Member
 
Registered: Feb 2009
Posts: 84

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
Search out for threads in LQ for squid configurations. You would find many of them. Webmin or GAdmin squid for that matter are not complete tools and lack some functionalities like delay pools and manually editing the file is a better option.

http://www.cyberciti.biz/tips/linux-...uid-howto.html.
I have open the link above but cannot locate the squid directive for editing or modifying when entering the squid text editor with this code:
# vi /etc/squid/squid.conf

this is the section need to be modified but I can find this:-

First, Squid server installed (use up2date squid) and configured by adding following directives to file:
Modify or add following squid directives:

httpd_accel_host virtual
httpd_accel_port 80
httpd_accel_with_proxy on
httpd_accel_uses_host_header on
acl lan src 192.168.1.1 192.168.2.0/24
http_access allow localhost
http_access allow lan
 
Old 02-06-2009, 07:24 AM   #12
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Those directives are for old version of squid. You probably have a newer version. Forget those directives. Take it as reference. And configure everything else.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me to configure Squid sudheshpn Linux - Server 3 08-27-2008 09:29 AM
How to configure Squid karthik2fun Linux - Server 2 07-09-2008 06:57 AM
How i configure squid ravi_kumars Linux - Networking 1 01-31-2007 01:21 PM
how to configure squid lzakir Debian 1 07-06-2005 01:22 PM
To configure squid neophyte_linux Linux - Newbie 1 04-05-2005 04:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration