LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2015, 10:54 PM   #1
chelservoncoast
LQ Newbie
 
Registered: May 2015
Posts: 5

Rep: Reputation: Disabled
Cannot boot Linux USB or CD in Windows 8.1


I just got a new laptop with Windows 8.1 and I cannot figure out how to install Linux Mint by booting from a CD or USB drive. Previously, I had installed Linux Mint on my old desktop and netbook computers that were running Windows XP. I had no trouble booting from a CD. Now that the process has been complicated in Windows 8.1 I don't know what to do. Any help would be greatly appreciated, I would really like to get rid of Windows 8.1 ASAP. Thanks!
 
Old 05-31-2015, 01:11 AM   #2
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
Is the live USB creator compatible with Windows OS? For example, is it Unetbootin or Yumi?

What happens when you use the USB? Does Windows see the USB in a 'usb drive' or does it see it in a 'removable disk drive'?
Also, what type of Linux live CD are you using? Is their an error message?
 
Old 05-31-2015, 04:15 AM   #3
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 2,144
Blog Entries: 9

Rep: Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771
chelservoncoast,

Use a 64 bit version of Linux Mint, or whatever and have a read of this:

https://help.ubuntu.com/community/UEFI

In BIOS/Startup make sure that the DVD or USB HDD is set to boot first ahead of the hard drive.

Last edited by beachboy2; 05-31-2015 at 04:16 AM.
 
Old 05-31-2015, 06:48 AM   #4
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Make sure Secure Boot (and Fast Boot) is disabled in your firmware (BIOS) options.

If your firmware does not offer this option (it should, according to the UEFI specifications, but some don't) then you may have to boot & install with "CSM" or "Legacy" mode enabled and switch between that & EFI-mode to change between Mint and Windows.

Alternatively, you can install Ubuntu, Fedora or OpenSUSE with Secure Boot enabled.
 
Old 05-31-2015, 07:32 AM   #5
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,725

Rep: Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916Reputation: 1916
With Windows 8 accessing the BIOS (well, EUFI) can be tricky so you the first time you access it you may have to do so through an option in Windows. Google lead me to this explanation which seems to be roughly what I ended up doing to set things up on this laptop:
http://www.makeuseof.com/tag/how-to-...ws-8-computer/
 
Old 05-31-2015, 11:12 AM   #6
chelservoncoast
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
Higgsboson,
Yes, I am using Unetbootin. The computer detects the USB drive without a problem, I formatted it and used Unetbootin to put Linux Mint Live 17 on the USB drive. I just can't figure out how to boot from the USB. I've gone into the BIOs several times to make changes suggested in Youtube videos and other forums. No luck. Right now I'm restoring the laptop to the factory default settings so I can keep track of changes I make. Thanks so much for all of the suggestions, I will respond as I try each? The computer I'm using is a Lenovo G50, chosen because the price was right and I've had good luck with Lenovo in the past.
 
Old 05-31-2015, 12:19 PM   #7
chelservoncoast
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
Here is what happened so far...
I factory reset the computer and then went into BIOS and disabled secure boot, set UEFI mode and enabled USB boot. The computer booted in Windows like normal. Then I went into Control Panel and turned off fast startup.Same thing, it just booted Windows again.
So I went into BIOS and switched to Legacy mode with Legacy priority and USB boot enabled. At boot it boot.hung on a blank screen. I manually powered it off and turned it back on. I used F12 during boot, selected to boot from USB and it hung on the blank screen again.
Not sure what to do now, as there are no error messages or info telling me what went wrong.
 
Old 06-01-2015, 01:35 AM   #8
chelservoncoast
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
I was finally able to get it to work! Now I am getting the message that it's running in software rendering mode, so I'll have to figure that out. Thanks for the tips and suggestions everyone!
 
Old 06-01-2015, 02:00 AM   #9
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18 MATE, antiX-16.1, MX-16
Posts: 2,144
Blog Entries: 9

Rep: Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771Reputation: 771
I guess that you are using Cinnamon?

You need to use Mint 17.1 MATE (or XFce) to avoid this problem.

Use the Software Center to install the mint-meta-mate package.

Alternatively, open a Terminal:

Code:
sudo apt-get install mint-meta-mate
Logoff or restart your computer.

At the login screen there will be a button which allows you to choose MATE or Cinnamon.

Choose MATE and login.
 
Old 06-01-2015, 02:16 AM   #10
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by chelservoncoast View Post
I was finally able to get it to work!
Can you please share the final solution with the rest of the community.
 
Old 06-02-2015, 01:46 PM   #11
chelservoncoast
LQ Newbie
 
Registered: May 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
Sorry for taking so long to get back to you guys, been busy. So here is a rundown of what I did. Most of it is based on things other people suggested via forums or videos.
First, download UNetBootin so you can make your bootable USB drive. I used the 64bit version of Linux Mint.
Follow the instructions here for turning off Fast Startup.
Once you get that done you need to get into your BIOS (here) and create an administrator password so that you can disable Secure Boot. This is the step that confused me because I was getting mixed information about booting in Legacy VS UEFI mode. Most of these changes can only be made in UEFI mode.
After you're done with that make sure that your system is set to boot in UEFI, with USB Boot enabled.
From there I saved and let the computer restart. On the Lenovo boot screen I hit F12 until it brought up the boot menu and I selected my USB drive. It took me to the Linux install menu and everything worked out.
My only problem was that Linux kept booting in Software Rendering mode. I switched my video card driver from the default (xserver-xorg-video-ati) to fglrx-updates.
I hope this helps you guys. If you have any questions or some of my instructions seem vague, let me know. I've been house hunting and my brain isn't running at full capacity right now.
 
Old 06-02-2015, 02:55 PM   #12
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Unless you're going to remember the admin password I would remove it
 
Old 06-03-2015, 05:29 PM   #13
Datgeekycat
LQ Newbie
 
Registered: Jun 2015
Distribution: I dont use linux as my main os, but i like ubuntu
Posts: 1

Rep: Reputation: 0
Hello!

From what I'm understanding your have problems with booting from CD/USB storage.
First, make sure that your BIOS (or UEFI, which is probaly the case) allows you to boot from the media. Change the boot order to make the computer check the CD/USB first before your HDD.

Did you prepare your boot media properly? Try re-burning the image to the storage device.

You should also try both the 32-bit and 64-bit versions of your distro.

It also might be something like secure boot or UEFI.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tried to Make a bootable Linux mint usb but can't boot back into windows. deedi01 Linux - Newbie 8 05-04-2015 08:16 PM
Windows 7 dual boot with any linux distro messes usb/wireless adapter settings nickt1862 Linux - General 3 03-25-2013 12:13 PM
Windows vista how to boot linux .iso (no cd burner or USB) Infasoft Linux - Newbie 6 02-07-2009 12:58 PM
I can't (install in USB), boot from USB, from Ubuntu, from Windows XP... gginis Linux - Software 4 06-26-2008 09:46 AM
persistent fs mounts between linux usb-boot and qemu guest on windows? stairwayoflight Linux - Software 0 01-11-2007 03:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration