LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-13-2003, 07:18 PM   #1
complus
Member
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 76

Rep: Reputation: 15
cannot backup to tape drive


Hi all. I have a Dell Powervault 112LT SCSI tape drive connected to my Linux box, and I am trying to back up to tape but for some reason I'm running into some problems...

I did the following: less /proc/scsi/scsi and the tape device is listed as an attached device. The Id is 14.

I did an lsmod, and sd_mod, and scsi_mod were listed, but no st. I searched the drivers and st.o is listed in /usr/lib/2.4.18-3/kernel/driver/.

However when I run mt -f /dev/st0 status I get a "no such device" message. When I try to get just a table of contents for the tape with tar -tvf /dev/st0 I get "Cannot open, no such device".

Do I have to do anything like make the device, install anything in particular, etc? I just connected the tape drive to the server, and it was detected during bootup from the get go ...

Any suggestions are greatly appreciated. This is urgent ...
 
Old 08-14-2003, 10:13 AM   #2
complus
Member
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 76

Original Poster
Rep: Reputation: 15
Ok so I can finally see my tape drive, but I am having problems... any advice greatly appreciated...

tar -cvf /dev/st0 /test

This iterates whats in the test directory, and I am not given any error messages. However when I try to run either of the following commands:

tar -tvf /dev/st0
tar -xvf /dev/st0

I get the following:

tar: this does not look like a tar archive
tar: Skipping to next header
tar: Error exit delayed from previous errors.

Any ideas? Thanks.
 
Old 08-28-2003, 03:52 AM   #3
jack38
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
Dear Complus,

I got the same problem like yours.
My RedHat 6.2 runs on a Compaq box with a HP DDS4 tape unit.

Would you please told me how to "see" your tape device ?

thanx !

Jackson
 
Old 08-28-2003, 04:56 AM   #4
glj
Member
 
Registered: Jul 2001
Location: London
Distribution: RH 9
Posts: 151

Rep: Reputation: 30
This might sound really stupid, but I thought I'd post it just in case! I know some tape drives don't rewind when you've written/read from the tape, I think it depends on what device you use to access the tape drive (on the machine I had it was something like /dev/st0 or /dev/nst0 for rewinding and non-rewinding.) Did the tape rewind before you tried to re-read from it?
 
Old 08-28-2003, 05:18 AM   #5
jack38
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
It works serval times 2 weeks ago that I tar some folders to /dev/st0, but after that, I got error message like :

[root]# tar -tvf /dev/st0
tar: /dev/st0: Cannot open: No such device
tar: Error is not recoverable: exiting now

and I could not find "st0" if I used "dmesg" to check system message

But I moved the DPT scsi card and HP SureStore DDS tape unit to another RedHat 6.2 running MRTG, the tape unit works perfectly.

What is missing in my first RedHat ( hosting Oracle DB ) ?

Your comment and suggestion will be very welcome !

Jackson
 
Old 10-01-2003, 05:17 AM   #6
jferreira_pt
LQ Newbie
 
Registered: Sep 2003
Posts: 3

Rep: Reputation: 0
Unhappy Unable to use tape drive surestore

Hi,

I'm unable to see the tapedrive in Linux AS 2.1.

tapeinfo -f /dev/st0
cannot open SCSI device '/dev/st0' - No such device

The hardware boot recognizes the Tape drive but linux not.


any sugestions to solve this problem?

Regards
JF
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Backup Tape Drive - Fedora 3 joshnya Linux - Hardware 5 10-06-2005 12:12 PM
Help Pls Setup backup and Tape drive kesh Linux - Newbie 0 04-21-2004 09:18 AM
Please recommend me new backup tape drive. tommilaiho Linux - Hardware 3 11-14-2003 07:55 AM
How to take backup on HP SCSI tape drive? imran Linux - Hardware 0 04-14-2002 11:25 PM
2 questions(Re: backup to scsi tape drive) ascii2k Linux - General 5 07-16-2001 05:47 PM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration