LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-03-2009, 07:09 PM   #1
baileybaird
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Rep: Reputation: 0
cannot adjust resolution on ubuntu and mint


i have read some similar threads and know about the /ect/x11/conf..... SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
command. my problem is, when i do this and try to save, i get an error box that states this is a read only file and modifications cannot be saved. i have not been able to find a way around this. can anyone tell me how to get around the read only or authorizations? i cannot use most window boxes dues to my resolution being so low, it shows everything super magnified.
 
Old 10-03-2009, 07:20 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
you MUST be root to save the file .Or for that matter you need to be root to save anything in /
your "normal user" can only save to there OWN home folder.
 
Old 10-03-2009, 07:26 PM   #3
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
type these commands in order
sudo bash
chmod +w <configureation filename>
<your editor> <configuration filename>
exit
of cource change the names in the <>'s
 
Old 10-03-2009, 07:49 PM   #4
baileybaird
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
john, that makes some sense to me, exept, i am the only user and do not know how to change to root.

smeezey, that makes no sense to me. i'm sorry if i sound a little difficult, but i am 2 days into linux and know nothing of it yet, especially commands and where i would type such prompts.
thank you both. any further elaboration is greatly appreciated!
 
Old 10-03-2009, 07:53 PM   #5
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
you type it at the terminal
sudo bash changes to root
chmod +w conf would make it so you can write to the file name conf
then you type the name of your editor to run it as root to edit the file
 
Old 10-03-2009, 08:08 PM   #6
baileybaird
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by smeezekitty View Post
you type it at the terminal
sudo bash changes to root
chmod +w conf would make it so you can write to the file name conf
then you type the name of your editor to run it as root to edit the file
~ # chmod +w conf
chmod: cannot access `conf': No such file or directory

again, i am sorry if i'm not getting it...
 
Old 10-03-2009, 08:28 PM   #7
l1dge
LQ Newbie
 
Registered: May 2009
Location: UK
Distribution: fedora 11, Mandriva, RHEL 5, Linux Mint
Posts: 2

Rep: Reputation: 0
Have you tried Menu->Preferences->Display and used the gui to change resolution?

Cheers
l1dge
 
Old 10-03-2009, 08:37 PM   #8
baileybaird
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
ok, i think i get what you were saying, exept now my txt editor keeps crashing when i save the modification....
the editor i am using is kate i think...

i have tried the standard display settings. problem here is it gives me 2 very low choices a 320x and a 640x i need somewhere more around 1280x.
 
Old 10-03-2009, 08:38 PM   #9
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
cd /etc/X11
ls
post back waht you came up with
 
Old 10-03-2009, 09:11 PM   #10
baileybaird
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Last edited by baileybaird; 10-03-2009 at 09:13 PM. Reason: i could not figure out how to cd this section or file so i pulled this from my editor
 
Old 10-03-2009, 09:22 PM   #11
baileybaird
LQ Newbie
 
Registered: Oct 2009
Posts: 8

Original Poster
Rep: Reputation: 0
now, if you have a better video script for me to try, by all means, post it and i will try to runs yours
 
Old 10-03-2009, 09:43 PM   #12
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
Code:
Section "Monitor"
Identifier "NULL"
EndSection

Section "Screen"
Identifier "Default"
Monitor "NULL"
Device "Video Device"
SubSection "Display"
Depth 16
Modes "1696x1280" "1280x1024" "1280x800" "1024x768" "800x600"
EndSubSection
EndSection
 
Old 10-03-2009, 11:41 PM   #13
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,822

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
if you are the ONLY user then you set up a root account when you installed Ubuntu or Mint.
to edit and save /etc/X11/xorg.conf try this
in the terminal type this
Code:
su -
 ( your root password when asked )
cd /etc/X11
nano xorg.conf
nano is a text based text editor
to save use the commands at the bottom of the screen
PS. the " ^ " character is is the Ctrl button
--- or start kate as root ---
Code:
su -
--- your root password ---
kate
PS. DO NOT USE "chmod" and set it to you - FOR ANY CONFIG FOLER IN A SYSTEM FOLDER . THIS CAN AND WILL GIVE YOU A SYSTEM THAT MIGHT NOT BOOT
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I replace Linux Mint with Suse 11.0 on PC with Win XP Mint and Ubuntu? jremsen Linux - Software 4 02-15-2009 07:54 AM
how do I adjust the screen resolution on Ubuntu MurX Ubuntu 8 06-29-2006 08:50 PM
How to adjust the screen resolution? magamandrake Linux - Hardware 4 09-14-2005 12:03 PM
adjust screen resolution BDemers Linux - Newbie 5 08-18-2005 05:50 AM
How do I adjust screen resolution is Redhat 7.3? glitch Linux - Newbie 6 08-31-2002 10:50 AM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration